DX - Load Balancing & Application Acceleration
Showing results for 
Search instead for 
Do you mean 
Posts: 6
Registered: ‎11-21-2007
0 Kudos
Accepted Solution

Web Server Header Info

Hi, I would like to change the web server information on my DX.

I could not find much on KB. Any help will be appreciated.




Netcraft.com Server Info:


OS: unknown

Web Server: Concealed by Juniper Networks DX


Warning: 214 www.dmi.gov.tr "Juniper Networks DX Active" Via: 1.1 juniper (Juniper Networks Application Acceleration Platform - DX 5.3.7 0)


Recognized Expert
Posts: 205
Registered: ‎11-06-2007
0 Kudos

Re: Web Server Header Info

You can disable the DX setting the Via and/or Warning  HTTP headers respectively with:


  set server factory h v disabled

  set server factory h w disabled 



these are global settings, you can adjust these per cluster too with:


  set cluster <cluster name> factory h v disabled

  set cluster <cluster name> factory h w disabled



The DX adds these as it is acting as a reverse proxy; these headers notify clients  they don't talk directly to the server but through a proxy as per the HTTP RFC.


After disabling these you can use apprules to insert your own Via and/or warning header as required e.g.



PTH: url starts_with "/" then insert_reply_header "Via" "The long way"





You can use apprules to modify headers set by the target server, from your output it looks like you are using nitro.apprule or a modified version of it.   You can view this default file with 'show file nitro.apprule', within are statements that hide the Server header e.g.


PTH: reply_header "Content-Type" contains "plain"
    and reply_header "Cache-Control" not_contains "no"
    and reply_header "Cache-Control" not_contains "private"
    and reply_header "Cache-Control" not_contains "max-age"
    and reply_header "Pragma" not_contains "no-cache"
    and reply_header "Expires" not_exists
    and http_reply_code equals "200"
    and query_string not_exists
    then insert_reply_header "Cache-Control" "max-age=600"
    and update_reply_header "Server" "Concealed by Juniper Networks DX"
    and cache "600"



You can either modify your applied apprule to set the Server header as you wish (or preserve it by deleting the relevant line).