Ethernet Switching
Reply
Contributor
Robbie
Posts: 269
Registered: ‎06-07-2011
0

ESWD_ST_CTL_ERROR_IN_EFFECT:


show ethernet-switching-options                                                        
storm-control {
    interface ge-0/0/0.0 {
        bandwidth 1000;
    }
    interface all {
        bandwidth 100;
    }
}

 

 

in log:

]: ESWD_ST_CTL_ERROR_IN_EFFECT: ge-0/0/0.0: storm control in effect on the port

 

I tried to increase the value for ge-0/0/0.0(trunk interface),but still see this error

 

storm control can't be used in trunk interface?

how to find out the real broadcast/unknown-unicast traffic received in this interface?

 

JNCIE-SP/JNCIP-SEC/CCNP
Trusted Expert
Trusted Expert
jtb
Posts: 312
Registered: ‎08-26-2009
0

Re: ESWD_ST_CTL_ERROR_IN_EFFECT:

[ Edited ]

Hi Robbie,

 

I guess the BUM (broadcast/unknown unicast) traffic on your trunk exceeds the 1Mbps limit you set. As discussed in some other threads, the is no single correct bandwidth value to configure in all networks.

 

You should look at your network (sniff the traffic in each VLAN) to verify what's the 'regular' BUM traffic level or why it's so big. Depending on network size & applications 1Mbps may be OK.

 

Unfortunately Junos does not reported what BUM traffic level triggered the storm-control and I'm not aware of any easy method to measure unknown unicast level (without sniffer).

 

Test the config with bigger bandwidth values for trunk port.

jtb

Super Contributor
ChadM
Posts: 175
Registered: ‎10-14-2008
0

Re: ESWD_ST_CTL_ERROR_IN_EFFECT:

Also, be careful with that setting.  Earlier versions of code lumped unknown unicast, broadcast, and multicast together.  Newer versions allow you to specify values for each type of traffic.

 

From 12.1:

  multicast            Enable multicast storm control
  no-broadcast         Disable broadcast storm control
  no-multicast         Don't enable multicast storm control
  no-registered-multicast  Disable registered multicast storm control
  no-unknown-unicast   Disable unknown unicast storm control
  no-unregistered-multicast  Disable unregistered multicast storm control

 

-Chad

Recognized Expert
Dominik
Posts: 392
Registered: ‎01-05-2008
0

Re: ESWD_ST_CTL_ERROR_IN_EFFECT:

Hi,

 

when you configure such low limits like 1 MBit/s you need to take three things into account as well:

 

  1. Burst that exceed the measuring windows of ~10 ms (for Gigabit interfaces). See

    [EX] Storm control calculation for the EX Switch
    http://kb.juniper.net/InfoCenter/index?page=content&id=KB24246

    for more information.

  2. Measuring is not super exact, so plus minus a couple of percent is a good idea.

  3. If this is not production traffic that triggers storm control but lab generated traffic with a software generator, you have to know that these programs are very inaccurate to match the real bandwith. I had to learn this by hard and ended up always to use a real packet generator tool like Ixia. Everything else is not really reliable.

Cheers,

Dominik

JNCIE et al.

--
The Axiom of Choice is obviously true, the well-ordering principle obviously false, and who can tell about Zorn's lemma?
Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.