Switching

last person joined: 2 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Jumbo frames between vlans

    Posted 12-07-2016 12:44

    We have two EX4500s in a virtual chassis setup

    We have two vlans that both have routed vlan interfaces

    We would like to be able to route between these two vlans using jumbo frames

    Can this be done and if so how?

     

    We do have MTU set for 9216 for the interfaces that make up the vlan. Here is how the vlan is configured, notice the MTU of 1500

     

    root@Core> show interfaces vlan.123
    Logical interface vlan.123 (Index 94) (SNMP ifIndex 803)
    Flags: Up SNMP-Traps 0x0 Encapsulation: ENET2
    Input packets : 25554
    Output packets: 21219
    Protocol inet, MTU: 1500
    Flags: None
    Addresses, Flags: Is-Preferred Is-Primary
    Destination: 10.121.123/24, Local: 10.121.123.1, Broadcast: 10.121.123.255



  • 2.  RE: Jumbo frames between vlans

    Posted 12-07-2016 21:16
    Hi Henderson

    You have the set the max MTU value globally using the below mentioned command, this command will apply for all VLANs and then if required change the MTU for other VLANs.

    If Global MTU size is less than the individual interface VLAN MTU size, you will get error while committing stating " Family MTU is too large relative to device MTU"

    root@CE1# set interfaces vlan mtu 9216 --> To set the max MTU value globally
    root@CE1# show interfaces vlan
    mtu 9216; --> This applies for all VLANs
    unit 10 {
    family inet {
    address 10.10.10.1/24 {
    arp 10.10.10.2 mac 00:1f:12:37:65:41;
    }
    }
    }
    unit 20 {
    family inet {
    address 20.20.20.1/24;
    }
    }
    unit 30 {
    family inet {
    mtu 2000; --> VLAN interface specific MTU, This should be less than Global MTU value
    address 30.30.30.1/24;
    }
    }
    unit 100 {
    family inet {
    mtu 3000;
    }
    }

    {master:0}[edit]
    root@CE1#



    Thanks
    Arul


  • 3.  RE: Jumbo frames between vlans

    Posted 12-08-2016 10:49

    I set the gloabl MTU per your command and that worked fine. I then tried setting the MTU for vlan 123 and I get the message "Family MTU is too large relative to device MTU error: configuration check-out failed"

     

    vlan {
    mtu 9216;
    unit 80 {
    family inet {
    address 10.121.80.1/20;
    }
    }
    unit 123 {
    family inet {
    mtu 9200;
    address 10.121.123.1/24;
    }
    }
    unit 124 {
    family inet {
    address 10.121.124.1/24;
    }
    }



  • 4.  RE: Jumbo frames between vlans

    Posted 12-08-2016 19:51
    1. Set the Global MTU to 9216
    2. Commit
    3. Set the VLAN 123 MTU to 9200
    4. Commit

    Is this the step you followed ?


  • 5.  RE: Jumbo frames between vlans

    Posted 12-08-2016 20:04

    That is correct

    I think I am set though. I was trying to get jumbo frames working between an interface on a physical windows servers and the management interface on one of my ESXi hosts. A ping with size set to 8972 was not working. Once I set the global MTU, the ping with size 8972 is now working fine



  • 6.  RE: Jumbo frames between vlans
    Best Answer

    Posted 12-08-2016 20:14
    Glad it worked for you.

    Have a great day.

    Thanks
    Arul