Switching

last person joined: yesterday 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Juniper ex4500 QOS configuration

    Posted 04-09-2015 11:48

    Hello Experts,

     

    Trying to configure QOS on my EX4500 and stuck. I am hoping that someone will help me as I am new to Junos QOS.

     

    I want a certain traffic (in my case is a udp multicast traffic) to mark it with DSCP EF 46 on Ingress interface and that trafic will exit my switch via Egress interface to the other part of the network. 

     

     

    Ingress Interface -----Switch-----Egress Interface

     

     

    In Cisco world i would configure the following on ingress interface:

     

    ip access-list extended video
    permit ip any 234.5.2.0 0.0.0.255
    !
    class-map match-all VIDEO
    match access-group name video
    !
    policy-map MARK-TRAFFIC
    class VIDEO
    set dscp ef
    !
    interface Port-channel9

    description Ingress Interface
    switchport
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 9,41
    switchport mode trunk
    mtu 9216
    service-policy input MARK-TRAFFIC

     

     

    On my Juniper box am trying to configure the follwing:

     

     

    show interfaces xe-0/0/33
    description Ingress Interface;
    mtu 9216;
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members [ Data Video ];
    }
    }
    }

     

    show | compare
    [edit interfaces xe-0/0/33 unit 0 family ethernet-switching]
    + filter {
    + input VIDEO-MARKING;
    + }
    [edit]
    + class-of-service {
    + classifiers {
    + dscp MARK-VIDEO-TRAFFIC {
    + forwarding-class expedited-forwarding {
    + loss-priority low code-points ef;
    + }
    + }
    + }
    + }
    [edit firewall family ethernet-switching]
    filter TEST_FILTER { ... }
    + filter VIDEO-MARKING {
    + term VIDEO {
    + from {
    + destination-address {
    + 234.5.2.0/24;
    + }
    + }
    + then {
    + accept;
    + forwarding-class expedited-forwarding;
    + }
    + }
    + term Rest_of_the_Traffic {
    + then accept;
    + }
    + }

     

    and getting a warning as follow while checking with "commit check":

     

    [edit firewall family ethernet-switching filter VIDEO-MARKING term VIDEO then forwarding-class]
    'forwarding-class expedited-forwarding'
    To configure forwarding-class, loss-priority must be set
    error: configuration check-out failed: (statements constraint check failed)

     

     

    So my question is - am I on the right direction? I cant seem to figure out where should i configure forwarding-class, loss-priority.

     

    Many Thanks



  • 2.  RE: Juniper ex4500 QOS configuration
    Best Answer

     
    Posted 04-09-2015 21:16

    Hi Jeronimo777,

     

    Please add the below line to your config and try commit again.

     

    set firewall family ethernet-switching filter VIDEO-MARKING term VIDEO then loss-priority low

    commit



  • 3.  RE: Juniper ex4500 QOS configuration

    Posted 04-10-2015 11:30

    Thanks rsuraj, successfully configured. Do you know how can I view QOS statistics? Particularly I am interested that switch is indeed marking traffic with dscp(dec) value 46. So far I was able to find the below command

     

    show class-of-service classifier type dscp

     

    Classifier: MARK-VIDEO-TRAFFIC, Code point type: dscp, Index: 29220
    Code point Forwarding class Loss priority
    101110 expedited-forwarding low

    {master:0}

     

    it indeed shows that I have configured classsifier but what other show commands will be helpfull?

     

    Many Thanks



  • 4.  RE: Juniper ex4500 QOS configuration

     
    Posted 04-10-2015 19:04
    ">Show interface queues " will show the queues and packets falling into them