Ethernet Switching
Showing results for 
Search instead for 
Do you mean 
Reply
Visitor
Posts: 1
Registered: ‎03-09-2016
0 Kudos

L2PT on QFX5100 and EX4300

 

Hi,

 

does anybody know if L2PT is supported on QFX5100 and EX4300? I'am trying to configure it but it dosn't work for.  QinQ working fine. protocols layer2-control mac-rewrite not.

 

I have very simple lab topology:

 

cisco-------ex4300------qfx500-----cisco

 

On Ex4300 and QFX configuration is similar:

 

client ports:

interfaces xe-0/0/47
flexible-vlan-tagging;
native-vlan-id 50;
encapsulation extended-vlan-bridge;
unit 50 {
vlan-id-list 1-4094;
input-vlan-map push;
output-vlan-map pop;
}

 

Uplink Port:

 

xe-0/0/46
flexible-vlan-tagging;
mtu 9000;
encapsulation extended-vlan-bridge;
ether-options {
ethernet-switch-profile {
tag-protocol-id 0x88a8;
}
}
unit 50 {
vlan-id 50;
}

 

 

AND L2PT

protocols{

layer2-control {
mac-rewrite {
interface xe-0/0/47 {
protocol {
cdp;
}
}
}
}

 

 

Please Help

 

Bukke

 

 

 

Highlighted
Recognized Expert
Posts: 184
Registered: ‎01-06-2016
0 Kudos

Re: L2PT on QFX5100 and EX4300

Hi buke,

 

L2PT is not supported on QFX5100. There you need til ACX5000 series to handle this.

 

Regarding EX4300 it should be supported when looking in the feature explorer for L2PT: https://pathfinder.juniper.net/feature-explorer/feature-info.html?fKey=1133&fn=Layer+2+protocol+tunn...) - also note that QFX5100 is missing from this list.

 

 

--
Best regards,

Jonas Hauge Jensen
Systems Engineer, SEC Datacom A/S (Denmark)
Trusted Contributor
Posts: 98
Registered: ‎03-10-2009
0 Kudos

Re: L2PT on QFX5100 and EX4300

HI Jonas

 

For one of the cases where we had to transport LACP packets which we could not do through QinQ we did it through pseudowire. 

 

Config Example.

 

LACP packets----xe-0/0/10---> QFX1--xe-0/0/19--------------l2circuit------xe-0/0/19---->QFX 2--xe-0/0/10----> receiving LACP packets


Configuration used on QFX1:



set interfaces xe-0/0/10 encapsulation ethernet-ccc
set interfaces xe-0/0/10 unit 0 family ccc
set interfaces xe-0/0/19 unit 0 family inet address 10.10.10.20/24
set interfaces xe-0/0/19 unit 0 family mpls
set interfaces em0 unit 0 family inet address 10.85.20.235/24
set interfaces lo0 unit 0 family inet address 4.4.4.4/32
set routing-options static route 0.0.0.0/0 next-hop 10.85.20.1
set protocols mpls label-switched-path PE1-to-PE2 to 1.1.1.1
set protocols mpls interface xe-0/0/19.0
set protocols ospf area 0.0.0.0 interface xe-0/0/19.0 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface xe-0/0/19.0
set protocols ldp interface lo0.0
set protocols l2circuit neighbor 1.1.1.1 interface xe-0/0/10.0 virtual-circuit-id 1


Configuration used on QFX2:



set interfaces xe-0/0/10 encapsulation ethernet-ccc
set interfaces xe-0/0/10 unit 0 family ccc
set interfaces xe-0/0/19 unit 0 family inet address 10.10.10.10/24
set interfaces xe-0/0/19 unit 0 family mpls
set interfaces em0 unit 0 family inet address 10.85.20.234/24
set interfaces lo0 unit 0 family inet address 1.1.1.1/32
set routing-options static route 0.0.0.0/0 next-hop 10.85.20.1
set protocols mpls label-switched-path PE2-to-PE1 to 4.4.4.4
set protocols mpls interface xe-0/0/19.0
set protocols ospf area 0.0.0.0 interface xe-0/0/19.0 interface-type p2p
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ldp interface xe-0/0/19.0
set protocols ldp interface lo0.0
set protocols l2circuit neighbor 4.4.4.4 interface xe-0/0/10.0 virtual-circuit-id 1


Please note that the above configuration would be supported on the latest code 14.1X53-D30.3. I had tested


 

 

 

 

Trusted Contributor
Posts: 98
Registered: ‎03-10-2009
0 Kudos

Re: L2PT on QFX5100 and EX4300

Please try the pseudowire config. It would help.