Switching

last person joined: 16 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  MX80 Bridge-Domain IRB question

    Posted 06-23-2011 06:10

    Hi all

     

    I have a basic setup with two MX80s.  These are connected via an AE0

    I have created a single vlan and IRB interface on each MX80.

    They can see the MAC of the remote IRB over the ae0 interface, but neither ping or ISIS comes up?

     

    bridge-domains {
        MX80-LAG {
            domain-type bridge;
            vlan-id 5;
            routing-interface irb.5;
        }
    }
    interfaces {
    irb {
            unit 5 {
                description "MX80-1 <--> MX80-2";
                family inet {
                    address a.a.a.a/31;
                }
                family iso;            
                family mpls;
            }       
        }  
    ae0 {
            description "MX80 ae0";
            mtu 9192;
            unit 0 {
                family bridge {
                    interface-mode trunk;
                    vlan-id-list [ 10 5 ];
                }
            }
        }
    }
    
    
    > show bridge mac-table           
    
    MAC flags (S -static MAC, D -dynamic MAC,
               SE -Statistics enabled, NM -Non configured MAC)
    
    Routing instance : default-switch
     Bridging domain : MX80-LAG, VLAN : 5
       MAC                 MAC      Logical
       address             flags    interface 
       5c:5e:ab:08:8b:f0   D        ae0.0   
    
    
    

     ?



  • 2.  RE: MX80 Bridge-Domain IRB question
    Best Answer

    Posted 06-23-2011 07:43

    Hello, 

     

    The modular MX80 is base on Trio chipset and on this routers you have to use the old style configuration(access and trunk is not supported)

    For example:

     

      ae0 {

     

            vlan-tagging;

            encapsulation flexible-ethernet-services;

            aggregated-ether-options {

                lacp {

                    active;

                }

            }       

            unit 3030 {

                description "yyy";

                encapsulation vlan-bridge;

                vlan-id 3030;

            }

            unit 3031 {

                description "xxx";

                encapsulation vlan-bridge;

                vlan-id 3031;

            }

    .....................................................................

    bridge-domains {

    Vlan3030 {

            description " yyy";

            domain-type bridge;

            vlan-id 3030;

            interface ae0.3030;

            interface ae1.3030;

            routing-interface irb.3030;

        }

        Vlan3031 {

            description " xxx";

            domain-type bridge;

            vlan-id 3031;

            interface ae0.3031;

            interface ae1.3031;

            routing-interface irb.3031;

    }

     

    You can use other incapsulation types but each Vlan should be configured sparatelly with an logical unit associated



  • 3.  RE: MX80 Bridge-Domain IRB question

    Posted 10-08-2011 19:51

    Hi Dumitru,

     

     

    "The modular MX80 is base on Trio chipset and on this routers you have to use the old style configuration(access and trunk is not supported)

    For example:"

     

    What do you mean with Trio chipset and "old style configuration(access and trunk is not supported)"? In other word, can you explain or show me the new style configuration? and where can we apply those new style configuration.

     

     

    Very appreciate for your response and thanks in advance. I am now try to get the purpose of IRB, bridge domain.

     

     

    Thanks,

    Niko Sianipar



  • 4.  RE: MX80 Bridge-Domain IRB question

    Posted 10-17-2011 11:24

    Hello Niko,

     

    There are 2 types of MX80:

    1. Fixed 48x1G non-Modular one that has the same internals as the DPC card and therefore supports "trunk, access" stile interface configuration.

    2. Modular MX80 is based on Trio chipset(the same one that's used on MPCs) and it doesn't support "trunk, access" stile interface configuration, instead you should break it in multiple units...



  • 5.  RE: MX80 Bridge-Domain IRB question

    Posted 10-20-2011 20:47

    Hi Dumitru,

     

     

    In case of fixed mode of MX80, let take this configuration as example:

     

    bridge-domains {
        MX80-LAG {
            domain-type bridge;
            vlan-id 5;
            routing-interface irb.5;
        }
    }
    interfaces {
    irb {
            unit 5 {
                description "MX80-1 <--> MX80-2";
                family inet {
                    address a.a.a.a/31;
                }
                family iso;            
                family mpls;
            }       
        }  
    ae0 {
            description "MX80 ae0";
            mtu 9192;
            unit 0 {
                family bridge {
                    interface-mode trunk;
                    vlan-id-list [ 10 5 ];
                }
            }
        }
    }
    
    
    > show bridge mac-table           
    
    MAC flags (S -static MAC, D -dynamic MAC,
               SE -Statistics enabled, NM -Non configured MAC)
    
    Routing instance : default-switch
     Bridging domain : MX80-LAG, VLAN : 5
       MAC                 MAC      Logical
       address             flags    interface 
       5c:5e:ab:08:8b:f0   D        ae0.0



    Can/should we put interface ae0 altogether irb.5 in the bridge domain confugaration?

    2nd question:
    for modular mode, with the configuration you gave as the example, can we put interface with different vlan-id in same bridge domain (configured with irb of course.)


  • 6.  RE: MX80 Bridge-Domain IRB question

    Posted 10-24-2011 01:59

    Hello,

     

    Regarding 1st question, you can bind IRB to bridge-domain only if one vlan is specified.

    Regarding 2nd question, it's possible, this feature is called "Normalized Vlan" or you could do the "Vlan Translation" on a per unit basis.