Ethernet Switching
Reply
Visitor
shrikant
Posts: 2
Registered: ‎09-21-2010
0

Taking too much time for failover in Juniper EX4200-24T

[ Edited ]
Hello guys, We have 2 Nos. Juniper EX4200-24T in the virtual Chassis. we are testing switches failover by powering-Off. when we are powering-off primary switch at that time it takes bit more time to take over another switch, around 20 to 25 RTO & same in vice-versa condition. Is there any configuration, where we can reduce the failover time. Thank you, Shrikant Desai.
Trusted Contributor
jozef.klacko
Posts: 142
Registered: ‎07-19-2010
0

Re: Taking too much time for failover in Juniper EX4200-24T

[ Edited ]

Hi

You should configure virtual-chassis like this:

set chassis redundancy graceful-switchover

I reduced failover to 7-8 second with this

 

you can then check with this command if v-c is ready to transfer mastership (routing engine) between routing engine and backup routing engine (whether they are synchronized). In operating mode:

request chassis routing-engine master switch check 

 

there are also other subcommands in request chassis routing-engine master

 

 

Visitor
simon.begin@institutsmq.qc.ca
Posts: 2
Registered: ‎09-15-2011
0

Re: Taking too much time for failover in Juniper EX4200-24T

Warning if you are NOT at JunOS 12.2, this command will DO the failover!

 

request chassis routing-engine master switch check

On JunOS 12.1, the option CHECK is not supported, hence without syntax error, Junos will DO the failover.

 

Super Contributor
terosa
Posts: 174
Registered: ‎10-26-2010
0

Re: Taking too much time for failover in Juniper EX4200-24T

Make sure you are running Junos 12.1 or above with NSSU and have the following configuration:

 

set chassis redundancy graceful-switchover
set ethernet-switching-options nonstop-bridging
set routing-options nonstop-routing
set virtual-chassis no-split-detection

 

Also make sure both roles are routing-engines (show virtual-chassis).

Regards,
Tero S
Contributor
slindermann
Posts: 11
Registered: ‎02-17-2011
0

Re: Taking too much time for failover in Juniper EX4200-24T

I'm running 12.2R2.5 and still this command causes the REs to failover, without any query before :smileysad:

Contributor
Onno
Posts: 11
Registered: ‎06-27-2011
0

Re: Taking too much time for failover in Juniper EX4200-24T

Hi all,

 

I can confirm that even in version 12.3R2.5 the "check" option causes a RE failover without question.

 

- Onno

- Onno

[Click the "Star" for Kudos if you think I earned it!
If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]
Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.