Switching

last person joined: 9 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  VMWARE ESXi NIC Teaming Configuration

    Posted 06-10-2010 13:39

    Hello all,

     

    We have a small scale VMWare ESXi deployment where we have multiple NIC's in the host server.  We have implemented NIC teaming for dual homed connections to a cisco switch using Ether-Channel, utilizing available documentation online.  We cannot however find such documentation pertaining to our Juniper EX series switches for the other connections to the server.  VMWare doesn't support LACP so we are kind of at a loss as to what we need to do to get this configured correctly.  We made an attempt at configuration, posted below, for your review.  The first snippet is the Cisco configuration, the second is our attempted JUNOS config.

    The JUNOS switch shows the LAG UP/UP and the VMWare server shows everything set correctly, we were hoping for verificationm especially with the load balancing config utilizing IP Hash (and src-dst-ip):

     

    port-channel load-balance src-dst-ip
    
    interface FastEthernet1/0/9
     description OpsBlade05 - Eth1/2
     switchport access vlan 33
     switchport mode access
     channel-group 2 mode on
     spanning-tree portfast trunk
    
    interface FastEthernet1/0/11
     description OpsBlade05 - Eth1/3
     switchport access vlan 33
     switchport mode access
     channel-group 2 mode on
     spanning-tree portfast trunk
    
    

     

        ge-0/0/14 {
            description "Ops Blade 4 - Eth1/1";
            ether-options {
                802.3ad ae1;
            }
        }
        ge-0/0/16 {
            description "Ops Blade 4 - Eth1/0";
            ether-options {
                802.3ad ae1;
            }
        }
    
        ae1 {
            description "Aggregrate Interface to BL4 MGMT Domain";
            unit 0 {
                family ethernet-switching {
                    port-mode trunk;
                    vlan {
                        members [ Management OPS-Servers ];
                    }
                    native-vlan-id Management;
                }
            }
        }

     

     



  • 2.  RE: VMWARE ESXi NIC Teaming Configuration

    Posted 06-14-2010 05:22

    Everything looks okay except for the VLAN membership.. Juniper does it a weird way.. Whatever is in the VLAN member lists gets 'tagged' even though you say to have one of those members also be the native vlan.. The key is... put what you want tagged in the member command, but leave out your native vlan if you have/want one.. Weird, yes I know.. 

     

    The second thing is to modify your forwarding options.. "set forwarding-options load-balance"   there aren't many choices on the EX series I believe so check up on the documentation.



  • 3.  RE: VMWARE ESXi NIC Teaming Configuration

    Posted 06-14-2010 12:21

    Yep, I had to fix my VLAN's and set the fowarding options, but other than that it seems to work well.



  • 4.  RE: VMWARE ESXi NIC Teaming Configuration

    Posted 09-01-2010 18:45

    Make sure when doing nic teams in VMWare that you disable beaconing on active/active links in a vSwitch.

     

    -Adam



  • 5.  RE: VMWARE ESXi NIC Teaming Configuration

    Posted 10-12-2012 06:47

    We had similar issues to above with ESXi and we needed 'force-up' option as described here:

    http://www.juniper.net/techpubs/en_US/junos10.3/topics/concept/interfaces-lag-overview.html?searchid=1350049223315

     

     

    On the interfaces that didn't support lacp I used the force-up option and this worked for me:

     

    set interfaces ge-0/0/4 ether-options 802.3ad lacp force-up
    set interfaces ge-0/0/4 ether-options 802.3ad ae2
    set interfaces ge-0/0/5 ether-options 802.3ad lacp force-up
    set interfaces ge-0/0/5 ether-options 802.3ad ae2

    on those that worked with lacp we left out the lacp force up option:

     

    set interfaces ge-0/0/0 ether-options 802.3ad ae0
    set interfaces ge-0/0/1 ether-options 802.3ad ae0

    I think an alternative and perhaps better approach is described here:

    http://kb.juniper.net/InfoCenter/index?page=content&id=KB12262&actp=search&viewlocale=en_US&searchid=1350049223315