Switching

last person joined: 13 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  irb .vs l3-interface

    Posted 10-19-2016 12:32

    We have the following config working on EX2200, but now we have EX2300, which requires irb instead of l3-interface data.

    Can someone show me what lines to change to make the config work on an EX2300.  thanks

     

    system {
        host-name 075;
        domain-name mass.com;
        time-zone GMT-5;
        authentication-order password;
        root-authentication {
            encrypted-password "; ## SECRET-DATA
        }
        name-server {
            10.10.10.10;
            10.20.10.10;
        }
        scripts {
            op {
                file LLDPNeighbors.slax;
            }
        }
        login {
            user admin {
                full-name admin;
                uid 2000;
                class super-user;
                authentication {
                    encrypted-password ""; ## SECRET-DATA
                }
            }
        }
        services {
            ssh {
                protocol-version v2;
                max-sessions-per-connection 32;
            }
            telnet;
            netconf {
                ssh;
            }
            web-management {
                http;
            }
            dhcp {
                traceoptions {
                    file dhcp_logfile;
                    level all;
                    flag all;
                }
            }
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any notice;
                authorization info;
            }
            file interactive-commands {
                interactive-commands any;
            }
            file default-log-messages {
                any any;
                match "(requested 'commit' operation)|(copying configuration to juniper.save)|(commit complete)|ifAdminStatus|(FRU power)|(FRU removal)|(FRU insertion)|(link UP)|transitioned|Transferred|transfer-file|(license add)|(license delete)|(package -X update)|(package -X delete)|(FRU Online)|(FRU Offline)|(plugged in)|(unplugged)|cm_device|(Master Unchanged, Members Changed)|(Master Changed, Members Changed)|(Master Detected, Members Changed)|(vc add)|(vc delete)|(Master detected)|(Master changed)|(Backup detected)|(Backup changed)|(interface vcp-)|(AIS_DATA_AVAILABLE)";
                structured-data;
            }
        }
        ntp {
            server 10.10.10.10;
            server 10.20.10.10;
        }
    }
    chassis {
        auto-image-upgrade;
    }
    interfaces {
        ge-0/0/0 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/1 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/2 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/3 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/4 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/5 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/6 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/7 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/8 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/9 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/10 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/11 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/12 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/13 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/14 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/15 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/16 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/17 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/18 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/19 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/20 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/21 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/22 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/0/23 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/1/0 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/1/1 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/1/2 {
            unit 0 {
                family ethernet-switching;
            }
        }
        ge-0/1/3 {
            unit 0 {
                family ethernet-switching;
            }
        }
        vlan {
            unit 0 {
                family inet {
                    address 10.100.75.10/24;
                }
            }
        }
    }
    }
    routing-options {
        static {
            route 0.0.0.0/0 next-hop 10.100.75.1;
        }
    }
    protocols {
        igmp-snooping {
            vlan all;
        }
        rstp;
        lldp {
            interface all;
        }
        lldp-med {
            interface all;
        }
    }
    ethernet-switching-options {
        storm-control {
            interface all;
        }
    }
    vlans {
        default {
            l3-interface vlan.0;
        }
    }


  • 2.  RE: irb .vs l3-interface
    Best Answer

     
    Posted 10-19-2016 15:50

    Hi,

     

    Lines that need to be adapted are:

     vlan irb {
            unit 0 {
                family inet {
                    address 10.100.75.10/24;
                }
            }
        }


    vlans {
        default {
            l3-interface vlan.0 irb.0;
        }
    }

    http://www.juniper.net/documentation/en_US/junos15.1/topics/task/configuration/bridging-integrated-routing-briding-interfaces-ex-series-cli-els.html

     

    You can also use the ELS translator here:

    https://www.juniper.net/customers/support/configtools/elstranslator/index.jsp

     

    Cheers,

    Ashvin



  • 3.  RE: irb .vs l3-interface

    Posted 10-21-2016 06:03

    Thanks, I found that mistake yesterday, good to know.



  • 4.  RE: irb .vs l3-interface

    Posted 10-25-2016 06:36
      |   view attached

    I also have an out of box config. but I cannot assign the default vlan to irb.0

     

    mbila@ex2300# set vlans default l3-interface irb.0

    {master:0}[edit]
    mbila@ex2300# commit
    [edit vlans default l3-interface]
    'l3-interface irb.0'
    l3-interface can be configured only under vlans with 'vlan-id'/'vlan-tags'
    error: commit failed: (statements constraint check failed)

    {master:0}[edit]
    mbila@ex2300#

     

    mbila@ex2300> show interfaces irb terse
    Interface Admin Link Proto Local Remote
    irb up up
    irb.0 up down inet 192.168.168.70/24

     

     

     

     

    Attachment(s)

    txt
    ex2300config.txt   7 KB 1 version


  • 5.  RE: irb .vs l3-interface

     
    Posted 10-25-2016 07:10

    irb is configured under interfaces

     

    set interface irb.0

     

    look below.  Although this is for MX should equally apply to newer EX models.

     

    http://www.juniper.net/documentation/en_US/junos15.1/topics/example/layer-2-bridge-domain-environment-example-integrated-routing-and-bridging-mx-solutions.html

     



  • 6.  RE: irb .vs l3-interface

    Posted 10-25-2016 07:45

    in my config, I do have interface irb defined. I am not sure what to do with the article you state. do I need a bridge domain? I just want to route on the default vlan using all ports for ethernet switching? is there an example of this?



  • 7.  RE: irb .vs l3-interface

     
    Posted 10-25-2016 08:21

    Checked deeper and looked at your config.  You have no vlans configured under

    set vlans vlan-name vlan-id vlan-id

     

    Once done, and you can call the name Default if you like, then you can add l3-interface irb.0 to the new vlan name or id

     

    http://www.juniper.net/documentation/en_US/junos15.1/topics/task/configuration/bridging-integrated-routing-briding-interfaces-ex-series-cli-els.html



  • 8.  RE: irb .vs l3-interface

    Posted 10-25-2016 09:37

    That worked! Thank you very much. Just some feedback. The ezsetup does not work (command line or web). you will receive errors when trying to use the default vlan for management or dedicated management port setup. Seems strange you have to redefine the "default" vlan and manually add the ports.  I hope Juniper fixes these bugs in EZsetup. 



  • 9.  RE: irb .vs l3-interface

    Posted 03-03-2017 08:46

    Hello,

    I am new to this forum and i bought my first Juniper Switch (EX2300-C).

     

    I wanted to configure it using J-Web:

    http://www.juniper.net/techpubs/test/en_US/release-independent/junos/topics/task/configuration/ex-series-initial-configuration-setting-up-j-web.html

     

    I configured In-Band Management with the default VLAN.

     

    When I want to submit the configuration, I get this error:

    There were error(s) delivering the configuration.
    
    Error(s): 
    'l3-interface irb.0'
    
    1) l3-interface can be configured only under vlans with 'vlan-id'/'vlan-tags'
    2) commit failed: (statements constraint check failed)

    What can I do? In the EZ-Setup of J-Web I don't see where I can do anything to prevent this error.

     

    Can anyone please help me?

     

    Thanks and kind regards

    gp83.



  • 10.  RE: irb .vs l3-interface

    Posted 03-06-2017 12:16

    I just set this switch up for testing , had the the same error, try my config, and just change what you need to. NETWORK-9 is the vlan we are using to access the switch, on ge-0/0/23

     

     

    admin@CORPTEST> show configuration |display set |no-more
    set version 15.1X53-D50.2
    set system host-name CORPTEST
    set system auto-snapshot
    set system domain-name masseyservices.com
    set system time-zone US/Eastern
    set system root-authentication encrypted-password ""
    set system name-server 10.10.10.10
    set system name-server 10.20.10.10
    set system login user admin full-name Administrator
    set system login user admin uid 2000
    set system login user admin class super-user
    set system login user admin authentication encrypted-password ""
    set system login user itnotify full-name ITNOTIFY
    set system login user itnotify uid 2001
    set system login user itnotify class read-only
    set system login user itnotify authentication encrypted-password ""
    set system services ssh protocol-version v2
    set system services ssh max-sessions-per-connection 32
    set system services telnet
    set system services netconf ssh
    set system services web-management http
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system syslog file default-log-messages any any
    set system syslog file default-log-messages match "(requested 'commit' operation)|(copying configuration to juniper.save)|(commit complete)|ifAdminStatus|(FRU power)|(FRU removal)|(FRU insertion)|(link UP)|transitioned|Transferred|transfer-file|(license add)|(license delete)|(package -X update)|(package -X delete)|(FRU Online)|(FRU Offline)|(plugged in)|(unplugged)|CFMD_CCM_DEFECT| LFMD_3AH | RPD_MPLS_PATH_BFD|(Master Unchanged, Members Changed)|(Master Changed, Members Changed)|(Master Detected, Members Changed)|(vc add)|(vc delete)|(Master detected)|(Master changed)|(Backup detected)|(Backup changed)|(interface vcp-)|(AIS_DATA_AVAILABLE)|BR_INFRA_DEVICE"
    set system syslog file default-log-messages structured-data
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag all
    set system ntp server 10.10.10.10
    set system ntp server 10.20.10.10
    set chassis alarm management-ethernet link-down ignore
    set interfaces ge-0/0/0 speed 100m
    set interfaces ge-0/0/0 link-mode full-duplex
    set interfaces ge-0/0/0 ether-options no-auto-negotiation
    set interfaces ge-0/0/0 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/1 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/2 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/3 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/4 speed 100m
    set interfaces ge-0/0/4 link-mode full-duplex
    set interfaces ge-0/0/4 ether-options no-auto-negotiation
    set interfaces ge-0/0/4 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/5 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/6 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/7 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/8 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/9 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/10 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/11 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/12 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/13 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/14 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/15 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/16 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/17 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/18 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/19 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/20 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/21 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/22 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members NETWORK-9
    set interfaces ge-0/0/23 unit 0 family ethernet-switching native-vlan-id default
    set interfaces ge-0/1/0 unit 0 family ethernet-switching storm-control default
    set interfaces xe-0/1/0 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/1/1 unit 0 family ethernet-switching storm-control default
    set interfaces xe-0/1/1 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/1/2 unit 0 family ethernet-switching storm-control default
    set interfaces xe-0/1/2 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/1/3 unit 0 family ethernet-switching storm-control default
    set interfaces xe-0/1/3 unit 0 family ethernet-switching storm-control default
    set interfaces irb unit 0 family inet
    set interfaces irb unit 9 family inet address 10.11.9.10/24
    set snmp description CORPTEST
    set snmp contact "MASSEY IT"
    set snmp community Public authorization read-only
    set snmp trap-group space targets 10.10.10.6
    set forwarding-options storm-control-profiles default all
    set routing-options static route 0.0.0.0/0 next-hop 10.11.9.254
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set protocols rstp interface ge-0/0/0
    set protocols rstp interface ge-0/0/1
    set protocols rstp interface ge-0/0/2
    set protocols rstp interface ge-0/0/3
    set protocols rstp interface ge-0/0/4
    set protocols rstp interface ge-0/0/5
    set protocols rstp interface ge-0/0/6
    set protocols rstp interface ge-0/0/7
    set protocols rstp interface ge-0/0/8
    set protocols rstp interface ge-0/0/9
    set protocols rstp interface ge-0/0/10
    set protocols rstp interface ge-0/0/11
    set protocols rstp interface ge-0/0/12
    set protocols rstp interface ge-0/0/13
    set protocols rstp interface ge-0/0/14
    set protocols rstp interface ge-0/0/15
    set protocols rstp interface ge-0/0/16
    set protocols rstp interface ge-0/0/17
    set protocols rstp interface ge-0/0/18
    set protocols rstp interface ge-0/0/19
    set protocols rstp interface ge-0/0/20
    set protocols rstp interface ge-0/0/21
    set protocols rstp interface ge-0/0/22
    set protocols rstp interface ge-0/0/23
    set protocols rstp interface ge-0/1/0
    set protocols rstp interface xe-0/1/0
    set protocols rstp interface ge-0/1/1
    set protocols rstp interface xe-0/1/1
    set protocols rstp interface ge-0/1/2
    set protocols rstp interface xe-0/1/2
    set protocols rstp interface ge-0/1/3
    set protocols rstp interface xe-0/1/3
    set vlans NETWORK-9 vlan-id 9
    set vlans NETWORK-9 l3-interface irb.9
    set vlans default vlan-id 1
    
    {master:0}
    admin@CORPTEST>