Ethernet Switching
Reply
Visitor
grint
Posts: 2
Registered: ‎05-21-2008
0
Accepted Solution

link aggregation between EX 4200 and Cisco 3550 with LACP

Hello,

I'm trying configure link aggregation with LACP beetwen Juniper EX4200 and Cisco 3550(Llink aggregation works without LACP).

Juniper config:

 

 

ge-0/0/2 {
ether-options {
802.3ad ae0;
}
}
ge-0/0/3 {
ether-options {
802.3ad ae0;
}
}

.....

ae1 {
aggregated-ether-options {
minimum-links 1;
link-speed 1g;
lacp {
passive;
periodic fast;
}
}
unit 0 {
family ethernet-switching;
}
}

 

 

 

Cisco config:

 

interface Port-channel1
switchport mode dynamic desirable

....

interface GigabitEthernet0/11
switchport mode dynamic desirable
channel-group 1 mode active
!
interface GigabitEthernet0/12
switchport mode dynamic desirable
channel-group 1 mode active

 

 

And cisco says:

 

May 21 18:30:06.033: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
Cat3550-12G#sh lacp internal
May 21 18:30:07.033: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
May 21 18:30:08.305: %ETHCNTR-3-LOOP_BACK_DETECTED: Keepalive packet loop-back detected on GigabitEthernet0/12.
May 21 18:30:08.305: %PM-4-ERR_DISABLE: loopback error detected on Gi0/12, putting Gi0/12 in err-disable state
Cat3550-12G#sh lacp internal
May 21 18:30:08.337: %EC-5-COMPATIBLE: Gi0/11 is compatible with port-channel members
May 21 18:30:09.309: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/12, changed state to down
May 21 18:30:09.329: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down

 

 

Output from cisco:

 

Cat3550-12G#show lacp 1 neighbor
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 1 neighbors

Partner's information:

LACP port Oper Port Port
Port Flags Priority Dev ID Age Key Number State
Gi0/11 SP 0 0000.0000.0000 138s 0x0 0x0 0x0
Gi0/12 SP 127 0019.e250.f900 132s 0x2 0x203 0x34



Cat3550-12G#show lacp 1 internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode

Channel group 1
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/11 SA indep 32768 0x1 0x1 0xC 0x7D
Gi0/12 SA down 32768 0x1 0x1 0xD 0x5

 

 

From Juniper:

 

root@sw1# run show lacp interfaces
.....
Aggregated interface: ae1
LACP state: Role Exp Def Dist Col Syn Aggr Timeout Activity
ge-0/0/2 Actor No Yes No No No Yes Slow Passive
ge-0/0/2 Partner No Yes No No No Yes Fast Passive
ge-0/0/3 Actor No Yes No No No Yes Slow Passive
ge-0/0/3 Partner No Yes No No No Yes Fast Passive
LACP protocol: Receive State Transmit State Mux State
ge-0/0/2 Defaulted No periodic Detached
ge-0/0/3 Port disabled No periodic Detached

 

 

Link aggregation between two EX 4200 work with LACP.

Please help me,

 

sorry for my bad english.

 

Visitor
grint
Posts: 2
Registered: ‎05-21-2008

Re: link aggregation between EX 4200 and Cisco 3550 with LACP

Cisco command "channel-protocol lacp"solved my problem
Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.