Ethernet Switching
Reply
Visitor
serwatt@hotmail.com
Posts: 4
Registered: ‎01-10-2011
0

logical unit is not allowed on aggregated links

#set interfaces ge-0/0/44 unit 0 family ethernet-switching port-mode trunk

#set interfaces ge-0/0/45 unit 0 family ethernet-switching port-mode trunk

#commit check

[edit interfaces ge-0/0/44]

     'unit 0'

          logical unit is not allowed on aggregated links

error: configuration check-out failed

 

why do it?

 

moreover, can you send configuration for lacp? ex 4200-

 

thnx.

servet

Distinguished Expert
aarseniev
Posts: 1,704
Registered: ‎08-21-2009
0

Re: logical unit is not allowed on aggregated links

Hello,

Are ge-0/0/44 and ge-0/0/45 already members of AggEth bundle? Then you can't configure units on them.

Below is the example config You asked:

 

 

interfaces {
    ge-1/0/0 {
        description DESCRIPTION1;
        ether-options {
            802.3ad ae0;
        }
    }
    ge-1/0/1 {
        description DESCRIPTION2;
        ether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        description DESCRIPTION3;
        aggregated-ether-options {
            lacp {
                active;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members all;
                }
            }
        }
    }
}

 

 

HTH

Rgds

Alex

___________________________________
Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Visitor
serwatt@hotmail.com
Posts: 4
Registered: ‎01-10-2011
0

Re: logical unit is not allowed on aggregated links

 Thank you my friend but i want etherchanel with two ports(ge44-ge45) end with two ex4200. 

 

1.EX 4200          2.EX 4200

ge-0/0/44------->ge-0/0/44

ge-0/0/45------->ge-0/0/45

 

can i understood? :smileyhappy:

 

by.

 

Distinguished Expert
aarseniev
Posts: 1,704
Registered: ‎08-21-2009
0

Re: logical unit is not allowed on aggregated links

Yes you can :smileyvery-happy:

Only change the interface numbering

 

interfaces {
    ge-0/0/44 {
        description DESCRIPTION1;
        ether-options {
            802.3ad ae0;
        }
    }
    ge-0/0/45 {
        description DESCRIPTION2;
        ether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        description DESCRIPTION3;
        aggregated-ether-options {
            lacp {
                active;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members all;
                }
            }
        }
    }
}

 

 

HTH

Alex

___________________________________
Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Visitor
serwatt@hotmail.com
Posts: 4
Registered: ‎01-10-2011
0

Re: logical unit is not allowed on aggregated links

Alex, so thnx. If i have questions again, i going to your questions. :smileyhappy: See you later, bb.

 

Visitor
serwatt@hotmail.com
Posts: 4
Registered: ‎01-10-2011
0

Re: logical unit is not allowed on aggregated links

Hi Alex,

 

interfaces {

    ge-0/0/44 {

        description DESCRIPTION1;

        ether-options {

            802.3ad ae0;

 

so wrote but it's not to be.

 

#set chassis aggregated-devices ethernet device-count 2

#set interfaces ae0 aggregated-ether-options minimum-links 2

#set interfaces ae0 aggregated-ether-options link-speed 10g

#set interfaces ge-0/0/44 ether-options 802.ad ae0

#set interfaces ge-0/0/45 ether-options 802.ad ae0

 

 

 'system'

missing mandatory  statement: 'root authentication

error: commit failed.

 

i am not understood. Can you send me syntax? Thnx. bb.

Distinguished Expert
aarseniev
Posts: 1,704
Registered: ‎08-21-2009

Re: logical unit is not allowed on aggregated links

It looks like you are configuring a factory-defaulted switch. Root has to have a password otherwise commit fails:

 

 

set system root-authentication plain-text-password <whatever>

 

 

And then there are VLANs, spanning-tree, etc.

I'd suggest you contact your Juniper account team to see if Juniper Professional Service can help.

Otherwise it is very easy to shoot self in the foot so to speak (I am joking, EX is not a firearm :smileyvery-happy:)

HTH

Alex

___________________________________
Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.