Ethernet Switching
Reply
Trusted Contributor
jozef.klacko
Posts: 142
Registered: ‎07-19-2010
0

multicast routing with virtual-router instances

Hi,

 

I have two ex4200, two ex2200 as access switches, one stream server and several settopboxes. I want to run routed multicast video in routing-instances.

see configs and attached diagram

 

two ex2200 are basic layer2 switches with junos recommended 10.4R4.5. Only advanced feature on them is igmp-snooping.

 

root@EX2200J# show interfaces ge-0/0/23 
description uplink;
unit 0 {
    proxy-arp restricted;
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ vIPTV vVOIP vINTERNET vMANAGMENT ];
        }
    }
}



[edit]
root@EX2200J# show interfaces ge-0/0/1    
description "jozo notebook";
unit 0 {
    family ethernet-switching {
        port-mode access;
        vlan {
            members vIPTV;
        }
    }
}


[edit]
root@EX2200J# show protocols igmp-snooping 
vlan vIPTV {
    interface ge-0/0/23.0 {
        multicast-router-interface;
    }
}

 

 

root@ex4200-1# show video 
instance-type virtual-router;
interface lo0.2;
interface vlan.1401;
interface vlan.1402;
interface vlan.1403;
protocols {
    ospf {
        area 0.0.0.0 {
            interface vlan.1401 {
                passive;
            }
            interface vlan.1402 {
                passive;
            }
            interface vlan.1403;
            interface lo0.2 {
                passive;
            }
        }
    }
    pim {
        rp {
            local {
                address 192.168.40.1;
            }
        }
        interface vlan.1401 {
            mode sparse;
        }
        interface vlan.1403 {
            mode sparse;
        }
    }
}

show interfaces lo0
unit 2 {
    family inet {
        address 192.168.40.1/32;
    }
}

show interfaces ge-0/0/0                         
description "to ex4200-2";
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ 3403 44 1403 1503 ];
        }
    }
}


show interfaces ge-0/0/1    
description "STREAM, server";
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ 110 3263 3264 1401 1402 1501 1502 ];
        }
    }
}

 

root@EX4200R# show routing-instances video 
instance-type virtual-router;
interface lo0.2;
interface vlan.1403;
interface vlan.1410;
protocols {
    ospf {
        area 0.0.0.0 {
            interface vlan.1403;
            interface vlan.1410 {
                passive;
            }
            interface lo0.2 {
                passive;
            }
        }
    }
    pim {
        rp {
            static {
                address 192.168.40.1;
            }
        }
        interface vlan.1403 {
            mode sparse;                
        }
        interface vlan.1410 {
            mode sparse;
        }
    }
}


root@EX4200R# show interfaces ge-0/0/23 
description "to sw-dcd-vc ex4200-1";
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ 44 3403 1503 1403 ];
        }
    }
}

{master:0}[edit]
root@EX4200R# show interfaces ge-0/0/0  
description EX2200R;
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ vINTERNET vIPTV vVOIP vMANAGMENT ];
        }
    }
}

{master:0}[edit]
root@EX4200R# show interfaces ge-0/0/1    
description EX2200J;
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ vINTERNET vIPTV vVOIP vMANAGMENT ];
        }
    }
}

root@EX4200R# show interfaces vlan unit 1403 
family inet {
    mtu 1500;
    address 10.40.3.2/30;
}

{master:0}[edit]
root@EX4200R# show interfaces vlan unit 1410    
family inet {
    mtu 1500;
    address 10.40.10.1/24;
}

root@EX4200R# show interfaces lo0 unit 2        
family inet {
    address 192.168.40.8/32 {
        primary;
    }
}
root@EX4200R# show protocols igmp-snooping vlan vIPTV {  
  inactive: no-default-flooding;   
inactive: interface ge-0/0/23.0 {       
multicast-router-interface;    }
}
 root@EX4200R# show vlans vIPTV vlan-id 1410; l3-interface vlan.1410; root@EX4200R# show vlans vlan1403 vlan-id 1403; l3-interface vlan.1403;

 

I think pim is activated automatically. I cannot set statement protocols igmp under routing-instance configuration tree

Unfortunately i cannot also set igmp-snooping under routing-instance

 

{master:0}[edit]
root@EX4200R# show routing-instances video protocols igmp-snooping          
##
## Warning: igmp-snooping configuration is allowed only for 'instance-type vpls'
##
vlan vIPTV;

 

 

{master:0}[edit]
root@EX4200R# run show pim rps instance video extensive 
Instance: PIM.video
Address family INET

RP: 192.168.40.1
Learned via: static configuration
Time Active: 00:26:50
Holdtime: 0
Device Index: 25
Subunit: 32769
Interface: pime.32769
Group Ranges:
        224.0.0.0/4
Active groups using RP:
        239.1.255.1
        224.2.2.2

        total 2 groups active

Address family INET6

### ex2200 ge-0/0/23 connected to ex4200 ge-0/0/1 has no port in "link-up" state except that ge-0/0/23. this is all-right:
root@EX4200R# run show igmp-snooping membership detail 
VLAN: vIPTV Tag: 1410 (Index: 5)
   Group: 224.2.2.2
     ge-0/0/0.0 timeout: 253 Last reporter: 10.40.10.13 Receiver count: 1, Flag>
   Group: 239.1.255.1
     ge-0/0/0.0 timeout: 248 Last reporter: 10.40.10.13 Receiver count: 1, Flag>


But there is still traffic to ge-0/0/1 and I am sure it is multicast 224.2.2.2.  Why ????

 

 

Is there any recommended configuration on to run multicast on ex4200 in routing-instance?

 

 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.