Junos OS

last person joined: 6 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  Can't ping directly connected interface between MX 960 and Cisco ASR 1k.

    Posted 12-18-2016 12:37

    I have tried almost everyting but no luck. This is very simple configuration. On juniper end I have below 

    set interfaces ge-8/3/5 speed 1g
    set interfaces ge-8/3/5 gigether-options auto-negotiation
    set interfaces ge-8/3/5 unit 0 family inet address 10.3.3.81/30
    On Cisco end 

    interface GigabitEthernet0/0/0
    ip address 10.3.3.82 255.255.255.252
    negotiation auto
    end
    ========================T-shooting steps I did=====================
    1: Changed fiber. 2: Change SFPs on both end. 3: Changed speed, negotiation on Juniper as well as on Cisco. 

    Interface is up up on both ends. 
    I can see both guys see MAC address of each other. BUT Cisco end dont see traffic incoming when I ping from Juniper. 

    Only thing I find so far is. Juniper can see traffic from Cisco ping but Cisco can't see traffic from Juniper pings. 
    Policies, security looks good. 



  • 2.  RE: Can't ping directly connected interface between MX 960 and Cisco ASR 1k.

    Posted 12-19-2016 04:06

    It might help if you could post the full configuration to be sure there aren't any firewall filters, different routing-instances, etc. involved on either end.  Also, if this is fiber, why would you be setting negotiation-settings on either end?

     

    -Ron



  • 3.  RE: Can't ping directly connected interface between MX 960 and Cisco ASR 1k.

    Posted 12-20-2016 03:07

    Try specifying the interface when you do the ping on the Juniper to make sure this is sourced correctly.

     

    ping 10.3.3.82 interface ge-8/3/5.0



  • 4.  RE: Can't ping directly connected interface between MX 960 and Cisco ASR 1k.

    Posted 12-20-2016 19:49

    Just adding to what is already suggested. If you have already verified that there are no issues at the physical level then you can probably configure static arp on both ends and then configure a firewall filter on Juniper router to count the ICMP packets in both input and output directions.

    Something like this:

    set firewall family inet filter test term 1 from source-address 10.3.3.81/32
    set firewall family inet filter test term 1 from destination-address 10.3.3.82/32
    set firewall family inet filter test term 1 from protocol icmp
    set firewall family inet filter test term 1 then count icmp-out
    set firewall family inet filter test term 1 then accept
    set firewall family inet filter test term 2 from source-address 10.3.3.82/32
    set firewall family inet filter test term 2 from destination-address 10.3.3.1/32
    set firewall family inet filter test term 2 from protocol icmp
    set firewall family inet filter test term 2 then count icmp-in
    set firewall family inet filter test term 2 then accept
    set firewall family inet filter test term 3 then accept

    set interfaces <interface-name> unit 0 family inet filter input test
    set interfaces <interface-name> unit 0 family inet filter output test

    This will help to understand in which direction the packets are getting dropped and narrow down further.



  • 5.  RE: Can't ping directly connected interface between MX 960 and Cisco ASR 1k.

    Posted 12-21-2016 01:58

    Hi

     

    please Try this on juniper side

    set interfaces ge-8/3/5 speed 1g
    set interfaces ge-8/3/5 gigether-options no-auto-negotiation

    set interfaces ge-8/3/5 link-mode full duplex

     

    Rgds

    Srijith H