Junos
Reply
Trusted Contributor
harrydanger
Posts: 86
Registered: ‎03-13-2009
0
Accepted Solution

Enabling Sflow - configuration error

All,

 

Trying to configure sflow on an EX4200. switch is part of a virtual chassis of two switches.for some reason it wont allow me to enable and in the configuration i get the following output:

 

protocols {
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface vlan.0;
        }
    }
    lldp {
        interface all;
    }
    ##
    ## Warning: configuration block ignored: unsupported platform (ex4200-24t)
    ##
    sflow {
        disable;
        collector 10.253.2.20 {
            udp-port 9996;
        }
        interfaces ge-0/0/10.0;
        interfaces ge-0/0/11.0;
    }
}


output from sh version:

jadmin@OMDS-SW> show version
fpc0:
--------------------------------------------------------------------------
Hostname: <xxxxx>
Model: ex4200-24t
JUNOS Base OS boot [9.2R3.5]
JUNOS Base OS Software Suite [9.2R3.5]
JUNOS Kernel Software Suite [9.2R3.5]
JUNOS Crypto Software Suite [9.2R3.5]
JUNOS Online Documentation [9.2R3.5]
JUNOS Enterprise Software Suite [9.2R3.5]
JUNOS Packet Forwarding Engine Enterprise Software Suite [9.2R3.5]
JUNOS Routing Software Suite [9.2R3.5]
JUNOS Web Management [9.2R3.5]

fpc1:
--------------------------------------------------------------------------
Hostname: <xxxxx>
Model: ex4200-24t
JUNOS Base OS boot [9.2R3.5]
JUNOS Base OS Software Suite [9.2R3.5]
JUNOS Kernel Software Suite [9.2R3.5]
JUNOS Crypto Software Suite [9.2R3.5]
JUNOS Online Documentation [9.2R3.5]
JUNOS Enterprise Software Suite [9.2R3.5]
JUNOS Packet Forwarding Engine Enterprise Software Suite [9.2R3.5]
JUNOS Routing Software Suite [9.2R3.5]
JUNOS Web Management [9.2R3.5]
Recognized Expert
wimclend
Posts: 275
Registered: ‎04-03-2009

Re: Enabling Sflow - configuration error

my best guess is the version of code; I don't know offhand when sFlow was introduced to the EX line code line.

 

 at the very least, 9.5 should get sFlow enabled for you.

 

I would also suggest upgrading to 9.5 or 9.6 because I believe several VC enhancements and improvements were made over earlier versions.

 

Good luck!

 

Will

Distinguished Expert
mikep
Posts: 483
Registered: ‎06-30-2009

Re: Enabling Sflow - configuration error

Hi,

 

just to confirm: yes sFlow support started from from 9.3 on EX32xx/EX4200. 

 

Kind Regards

Michael Pergament

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.