Junos OS

last person joined: 6 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  How to configure encapsulation dot1Q under a routed interface

    Posted 09-24-2011 03:34

    Hi

     

    I need to translate this from IOS into JUNOS

     


    interface GigabitEthernet0/2.2164
     encapsulation dot1Q 2164
     ip address 10.10.10.1 255.255.255.252

     

    Is it enough to set the unit to 2164

     

    Thanks



  • 2.  RE: How to configure encapsulation dot1Q under a routed interface

    Posted 09-24-2011 07:17

    should look like this:

     

        ge-1/0/36 {
            vlan-tagging;
            unit 1000 {
                vlan-id 1000;
                family inet {
                    address 10.0.100.2/24;
                }
            }
        }

     

    Will



  • 3.  RE: How to configure encapsulation dot1Q under a routed interface

    Posted 11-28-2014 23:17

    Hello,

     

    In set format, it is like below:

     

    set interfaces ge-0/0/10 vlan-tagging
    set interfaces ge-0/0/10 unit 1010 vlan-id 1010
    set interfaces ge-0/0/10 unit 1010 family inet address 10.10.29.57/30

     

    Now if we have another vlan in the same port and follow dot1q encapsulation, below command are ok?  Do we need any other thing to do?

    set interfaces ge-0/0/10 unit 1030 vlan-id 1030
    set interfaces ge-0/0/10 unit 1030 family inet address 10.46.252.1/30



  • 4.  RE: How to configure encapsulation dot1Q under a routed interface

     
    Posted 11-29-2014 18:55

    It is important to note that it is not necessary for the unit and vlan-id to match.  You can have "unit 50" with a vlan-id of '3221' if you want.  It's just easier to keep track of if you keep it simple by matching the unit and vlan-id.  Just FYI. 



  • 5.  RE: How to configure encapsulation dot1Q under a routed interface

    Posted 02-24-2016 05:50

    We need to do the same on irb,please support

    set interfaces ge-0/0/10 vlan-tagging
    set interfaces ge-0/0/10 unit 1010 vlan-id 1010
    set interfaces ge-0/0/10 unit 1010 family inet address 10.10.29.57/30

     

    Now if we have another vlan in the same port and follow dot1q encapsulation, below command are ok?  Do we need any other thing to do?

    set interfaces ge-0/0/10 unit 1030 vlan-id 1030
    set interfaces ge-0/0/10 unit 1030 family inet address 10.46.252.1/30