Junos
Reply
Contributor
TravisJohnson
Posts: 116
Registered: ‎12-14-2009
0
Accepted Solution

J2300 Not booting

Hello all,

 

I have a J2300 that I attempted an upgrade on.  I have followed the recovery instructions below:

 

Download install media

Unzip the file

dd if=installmedia of=/dev/device

 

When complete, I get confirmation that 256mb were written to disk, but when I place the CF back in the router, I get

 

Attempt to boot from primary flash recovery partition

Attempt to boot from primary flash

 

After sitting there for a bit, the router reboots and goes through the process again.  I have a 256mb CF, so I used the 256mb install media for 9.6r1.13

 

I have also tried using a 512mb usb drive to no avail. 

 

One question I have on the 512mb USB, does that require a 512mb install media?

 

Also, do I need to somehow also load a junos file on the flash drive?

 

Thanks

Travis

________________________________________________


If my post helped you, please feel free to give me kudos.
Distinguished Expert
Screenie
Posts: 1,076
Registered: ‎01-10-2008
0

Re: J2300 Not booting

I had the same on a 4300 when I wrote the flash with a raw write utilty on windows. No problem when I used dd on a unix machine.

best regards,

Screenie.
Juniper Ambassador,
JNCIA IDP AC WX JNCIS FW SSL JNCIP SEC ENT SP JNCI

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.
Contributor
TravisJohnson
Posts: 116
Registered: ‎12-14-2009
0

Re: J2300 Not booting

Thanks Screenie,

 

I used dd in opensuse with the install media after uncompressed, but no luck.  Do you have to put anything else on it?

 

Going to try from a FreeBSD box here shortly once it finishes downloading.

________________________________________________


If my post helped you, please feel free to give me kudos.
Distinguished Expert
Screenie
Posts: 1,076
Registered: ‎01-10-2008
0

Re: J2300 Not booting

If think I used bs=1024, can't remember. I used a redhat system. I bought an cheap flash, 1 G and download the Gig immage.  Works fine!

best regards,

Screenie.
Juniper Ambassador,
JNCIA IDP AC WX JNCIS FW SSL JNCIP SEC ENT SP JNCI

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.
Contributor
TravisJohnson
Posts: 116
Registered: ‎12-14-2009
0

Re: J2300 Not booting

To fix it I had to go back to 8.4 for some reason.  When I was using 9.anything, it wouldnt load the / (root) It would go into panic mode and reboot.

 

Fixed now

________________________________________________


If my post helped you, please feel free to give me kudos.
Distinguished Expert
aarseniev
Posts: 1,622
Registered: ‎08-21-2009
0

Re: J2300 Not booting

 


TravisJohnson wrote:

 I have a 256mb CF, 


 

Hello,

JUNOS 9.6 require minimum 512MB internal CF, this is documented here

http://www.juniper.net/techpubs/en_US/junos9.6/information-products/topic-collections/release-notes/...

USB drives won't help here, You need to replace internal CF to get the J-series box upgraded to 9.6.

HTH

Rgds
Alex

 

___________________________________
Accept as Solution = cool !
Accept as Solution+Kudo = You are a Star !
Contributor
TravisJohnson
Posts: 116
Registered: ‎12-14-2009
0

Re: J2300 Not booting

While I admit, I didn't read the release notes, there is a 9.6 install media labeled as 256.  See attachment.

 

If 9.6 requires 512mb or higher, why have this software available?

________________________________________________


If my post helped you, please feel free to give me kudos.
Visitor
mylespearson
Posts: 3
Registered: ‎12-29-2010
0

Re: J2300 Not booting

I know this is an old thread, but I thought I would comment anyway (for future viewers).

 

It is possible (need verification) that the "256" you see may denote an encryption level and not the type of CF card installed. (Just a thought)

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.