Junos
Reply
Regular Visitor
skeezix
Posts: 4
Registered: ‎07-15-2011
0

Juniper T1 L2 channel errors: What are they?

Hello, got a question I'm not getting terrific answers to. I have a customer who complains of packet loss on a T1. This is terminated on a Juniper M120's (JUNOS Base OS boot [9.3R4.4]) t1-5/0/0:5:23, parent card is ct3-5/0/0:5.

 

All that's ever seen are L2 channel errors. No CRCs, UAS, nothing else.

 

Input errors:
    Errors: 0, Drops: 0, Framing errors: 0, Runts: 0, Giants: 0, Policed discards: 0, L3 incompletes: 0, L2 channel errors: 5767,
    L2 mismatch timeouts: 0, HS link CRC errors: 0, SRAM errors: 0, Resource errors: 0

 

T1  media:            Seconds        Count  State
    SEF                       0            0  OK
    BEE                       0            0  OK
    AIS                       0            0  OK
    LOF                       0            0  OK
    LOS                       0            0  OK
    YELLOW                    0            0  OK
    CRC Major                 0            0  OK
    CRC Minor                 0            0  OK
    BPV                       0            0
    EXZ                       0            0
    LCV                       0            0
    PCV                       0            0
    CS                        0            0
    CRC                       0            0
    LES                       0
    ES                        0
    SES                       0
    SEFS                      0
    BES                       0
    UAS                       0


Juniper's KB returns "Output Fields L2 channel errors —Counter increments when the software could not find a valid logical interface for an incoming frame. L2 mismatch timeouts ".

 

Um .... ok. 'could not find a valid logical interface'.

 

I ask around and one fellow I respect mused that this is LCP/NCP interpreting, say, CDP (or other proprietary protocols) as unknown traffic, and it notes them as errors, incrementing the counter. Sounds possible. Yet, I can't find any dialogue/discussion on exactly how JUNOS qualifies L2 channel errors.

 

So that's my question. What causes these errors, and can their existence manifest as "packet-loss" experience from a customer's POV? Are they anything to be concerned with? I get conflicting answers.

 

Thanks much,

Eric

Distinguished Expert
Distinguished Expert
pk
Posts: 803
Registered: ‎10-09-2008
0

Re: Juniper T1 L2 channel errors: What are they?

Hi

 

Here is a discussion about those errors

http://forums.juniper.net/t5/Junos/L2-Channel-Errors-Incrementing/td-p/63907

 

I think you can try to use the error rate as a key... Can you measure (approximately)

the rate this error counter increasess (counts per minute, e.g.?)

If this number is stable, then it is likely something like CDP or other protocol Juniper is

not recognizing.

 

Also what do the customers report about the interface? Are they seeing packet loss

all the time, or periodically? Does it correlate with the above errors? You should check

this, but as long as other units on this channelized card are all right, it does not seem

to me that the problem is on the Juniper side...

 

 

Best Regards,
Petr (PK)

Juniper Ambassador, Juniper Networks Certified Instructor,
JNCIE-SEC #98, JNCIE-ENT #393, JNCIE-SP #2253
[Juniper Authorized Education & Support in Russia]
Recognized Expert
benb
Posts: 205
Registered: ‎11-05-2007
0

Re: Juniper T1 L2 channel errors: What are they?

Most likely, this is not something to be concerned about.  Is your encapsulation type frame-relay? It could be that you are receiving frames with an unconfigured dlci.

 

Could you send the entire output of 'show interface <interface> extensive', and 'show configuration <interface>'?

 

Thanks,
Ben

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.