Junos
Reply
Visitor
alexart
Posts: 8
Registered: ‎06-17-2008
0
Accepted Solution

LAG between M7i and Extreme networks switch.

I need configure LAG between M7i and Extreme networks switch.

My ae0 interface is down. Analogical configuration with EX3200 work without problem.

 

Please, give me any information about interoperability with Extreme's switches in mind of LAG.

Thanks!!

Recognized Expert
Loup2
Posts: 301
Registered: ‎04-22-2008
0

Re: LAG between M7i and Extreme networks switch.

Hi,

Here is a config that I did that on the M7i side:
 

chassis {
    aggregated-devices {
        ethernet {
            device-count 1;
        }
    }
}
interfaces {
    ge-0/1/0 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ge-1/3/0 {
        gigether-options {
            802.3ad ae0;
        }
    }
    ae0 {
        vlan-tagging;
        aggregated-ether-options {
            minimum-links 1;
            link-speed 1g;
        }
        unit 0 {   
            vlan-id 1;
            family inet {
                address 10.0.0.1/30;
            }
        }
    }

And on the Extreme side:

enable sharing 1:1 grouping 1:1-2 algorithm port-based

configure vlan Default add ports 1:1 tagged
 
configure vlan Default ipaddress 10.0.0.2 255.255.255.252

 

this config is done with tagging and you can see that I used two different PIC cards on the M7i side.

this was the status of the M7i side:

 

User@M7i_1GE# run show interfaces ae0
Physical interface: ae0, Enabled, Physical link is Up
  Interface index: 143, SNMP ifIndex: 37
  Link-level type: Ethernet, MTU: 1514, Speed: 2000mbps, Loopback: Disabled, Source filtering: Disabled,
  Flow control: Disabled, Minimum links needed: 1, Minimum bandwidth needed: 0
  Device flags   : Present Running
  Interface flags: SNMP-Traps Internal: 0x4000
  Current address: 00:17:cb:c5:d3:f0, Hardware address: 00:17:cb:c5:d3:f0
  Last flapped   : Never
  Input rate     : 0 bps (0 pps)
  Output rate    : 0 bps (0 pps)

  Logical interface ae0.0 (Index 64) (SNMP ifIndex 40)
    Flags: SNMP-Traps Encapsulation: ENET2
    Statistics        Packets        pps         Bytes          bps
    Bundle:
        Input :           752          0         62436            0
        Output:           740          0         72464            0
    Protocol inet, MTU: 1500
      Flags: None
      Addresses, Flags: Is-Preferred Is-Primary
        Destination: 10.0.0.0/30, Local: 10.0.0.1, Broadcast: 10.0.0.3

 

Visitor
alexart
Posts: 8
Registered: ‎06-17-2008
0

Re: LAG between M7i and Extreme networks switch.

[ Edited ]

Thanks!! But we need configure on Extreme x650.

Quote from documentation:

  "You cannot configure port-based load sharing on the Summit X450a, X450e, X350, X250e, and X150 series

switches (whether or not included in a SummitStack). "

 

x650 has not this configuration option also. 

 

We have configured your solution on the module Extreme switch. It work without problem. But, when we have configured

enable sharing 2:1 grouping 2:1-2 algorithm address-based

Juniper's side interface ae0 have went to down. 

We have solved this issue. 
On the Extreme switch (non - modular) need type command: enable sharing 17 grouping 16-18 algorithm address-based L3_L4 lacp
"lacp" - is needed. 
Thanks for all 
Message Edited by alexart on 07-30-2009 08:50 AM
Visitor
alexart
Posts: 8
Registered: ‎06-17-2008
0

Re: LAG between M7i and Extreme networks switch.

We have solved this issue. 

On the Extreme's non-modular  switch need type 

enable sharing 17 grouping 16-18 algorithm address-based L3_L4 lacp

"lacp" - is key word

 

Thanks for all. 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.