Junos
Reply
Contributor
Zlatko
Posts: 24
Registered: ‎11-26-2009
0
Accepted Solution

Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

What is this alarm? I upgraded 2 Juniper EX3200s to 11.4R4.4 and I got this alarm.

 

Working on isolating the trouble right now. If anyone has crossed this bridge, please let me know what the solution is.

Contributor
Zlatko
Posts: 24
Registered: ‎11-26-2009
0

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

I rolled the 2 devices down to JUNOS 11.4R2.14

 

jinstall-ex-3200-11.4R2.14-domestic-signed.tgz

 

This cleared the alarms on the EX3200s, I then upgraded back to 11.4R4.4 and the alarm appeared again.

Contributor
Zlatko
Posts: 24
Registered: ‎11-26-2009
0

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

root@ex3200> show version
Hostname: ex3200
Model: ex3200-24t
JUNOS Base OS boot [11.4R4.4]
JUNOS Base OS Software Suite [11.4R4.4]
JUNOS Kernel Software Suite [11.4R4.4]
JUNOS Crypto Software Suite [11.4R4.4]
JUNOS Online Documentation [11.4R4.4]
JUNOS Enterprise Software Suite [11.4R4.4]
JUNOS Packet Forwarding Engine Enterprise Software Suite [11.4R4.4]
JUNOS Routing Software Suite [11.4R4.4]
JUNOS Web Management [11.4R4.4]
JUNOS FIPS mode utilities [11.4R4.4]

root@ex3200>

Contributor
Zlatko
Posts: 24
Registered: ‎11-26-2009

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

[ Edited ]

Ok, so I figured it out. If anyone ever has this problem in the future, follow these steps to correct:

 

1) Load the latest JLoader for EX3200, you can find it here:

 

https://download.juniper.net/software/junos/specials/jloader/jloader-ex-3242-11.3I20110326_0802_hmer...

 

2) Load the JUNOS Image, in my case it was 11.4R4.4, you can find it here:

 

http://www.juniper.net/support/downloads/?p=ex3200#sw

 

3) Do the whole requesy system add validate /var/tmp/ procedure, in my case it was as follows:

 

root@ex3200> request system software add validate /var/tmp/jloader-ex-3242-11.3I20110326_0802_hmerge-signed.tgz
Verified jloader-ex-3242-11.3I20110326_0802_hmerge.tgz signed by PackageDevelopment_11_3_0
Pre-checking requirements for jloader-ex-3242...
Auto-deleting old jloader-ex-3242...
Unmounted /packages/mnt/jloader-ex-3242-11.3I20110326_0802_hmerge ...
Adding jloader-ex-3242...
Installation in progress, please wait...
Mounted jloader-ex-3242 package on /dev/md12...
Verified manifest signed by PackageDevelopment_11_3_0
Verified jloader-ex-3242-11.3I20110326_0802_hmerge signed by PackageDevelopment_11_3_0
Registering jloader-ex-3242 as unsupported
##############################
################################################################
Installation finished successfully.
Please reboot to activate the package
Saving package file in /var/sw/pkg/jloader-ex-3242-11.3I20110326_0802_hmerge-signed.tgz ...
Saving state for rollback ...

root@ex3200>

root@ex3200> request system software add validate /var/tmp/jinstall-ex-3200-11.4R4.4-domestic-signed.tgz
WARNING: A reboot is required to install the software
WARNING:     Use the 'request system reboot' command immediately

root@ex3200>

root@ex3200> request system reboot
Reboot the system ? [yes,no] (no) yes

Shutdown NOW!
[pid 1453]

root@ex3200>
*** FINAL System shutdown message from root@ex3200 ***

System going down IMMEDIATELY

login as: root
root@ex3200's password:
--- JUNOS 11.4R4.4 built 2012-06-28 08:35:13 UTC
root@ex3200> show system alarms
No alarms currently active

root@ex3200>

Problem fixed.

 

New User
chimera
Posts: 1
Registered: ‎06-30-2008
0

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

Legend thanks, had the same issue with 3 x EX4200 switches in a VC. Did as you've outlined above and solved my issue too. Thanks

Trusted Contributor
JunosChris
Posts: 152
Registered: ‎10-02-2010
0

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

I just ran into this in a lab. I actually thought you only needed a new jloader when going from before pre-dual root partitions came out (10.4). 

 

Maybe I should make it a habit to install a new jloader every time I upgrade whether it needs it or not. 

--
Chris Jones
Juniper Ambassador
JNCIE-ENT #272
JNCIP-SP
CCIE #25655
GCK
Regular Visitor
GCK
Posts: 6
Registered: ‎02-09-2009
0

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

thank you from here as well.

Visitor
trodrigues
Posts: 1
Registered: ‎11-10-2011
0

Re: Upgrade bank is empty or corrupted for FPC 0, please do standard upgrade sequence

This problem is resolved with Jloader, used before install the Junos Software.



 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.