Junos
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 3
Registered: ‎09-01-2017
0 Kudos
Accepted Solution

Weird error log

Hi 
I received the error log recently. I try to google it, but can't find any clue. 

 

Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[0] Invalid Speed[4699507019709153456]
Sep 1 23:00:01 mx960-2 fpc0 ge-0/0/2: error=7 :xeth_an_set_rgmii_rate
Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/0/2, err=7 :an_periodic_run
Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[1] Invalid Speed[4699507019709153456]
Sep 1 23:00:01 mx960-2 fpc0 ge-0/1/2: error=7 :xeth_an_set_rgmii_rate
Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/1/2, err=7 :an_periodic_run
Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[0] Invalid Speed[4699507019709153456]
Sep 1 23:00:01 mx960-2 fpc0 ge-0/0/2: error=7 :xeth_an_set_rgmii_rate
Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/0/2, err=7 :an_periodic_run
Sep 1 23:00:01 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[1] Invalid Speed[4699507019709153456]
Sep 1 23:00:01 mx960-2 fpc0 ge-0/1/2: error=7 :xeth_an_set_rgmii_rate
Sep 1 23:00:01 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/1/2, err=7 :an_periodic_run
Sep 1 23:00:02 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[0] Invalid Speed[4699507019709153456]
Sep 1 23:00:02 mx960-2 fpc0 ge-0/0/2: error=7 :xeth_an_set_rgmii_rate
Sep 1 23:00:02 mx960-2 fpc0 AN: Set rgmii_rate ifd=ge-0/0/2, err=7 :an_periodic_run
Sep 1 23:00:02 mx960-2 fpc0 EZ: ezchip_xeth_set_rgmii_rate[867] Channel[1] Invalid Speed[4699507019709153456]
Sep 1 23:00:02 mx960-2 fpc0 ge-0/1/2: error=7 :xeth_an_set_rgmii_rate

Trusted Contributor
Posts: 106
Registered: ‎04-26-2015
0 Kudos

Re: Weird error log

What config you have on ge-0/0/2?
New User
Posts: 3
Registered: ‎09-01-2017
0 Kudos

Re: Weird error log

general configuration, like other interface. the configuration run 2~3 years.

 

show interfaces ge-0/0/2
speed auto;
link-mode full-duplex;
gigether-options {
auto-negotiation;
}
unit 0 {
family inet {
filter {
input-list DEFAULT-ACL;
}
sampling {
input;
output;
}
address x.x.x.x/30;
}
}

 

show interfaces ge-0/1/2
speed auto;
link-mode full-duplex;
gigether-options {
auto-negotiation;
}
unit 0 {
family bridge {
interface-mode access;
vlan-id 16;
}
}

Trusted Contributor
Posts: 106
Registered: ‎04-26-2015
0 Kudos

Re: Weird error log

It looks like interface is not calculating the speed. Please check the "show interface ge-0/0/2" and check in output for Speed.

It seems to me that it is not calculating the speed because of the "speed auto" and "gigether-options auto-negotiation" knobs under the interface configuration. Please remove it and test

 

[KUDOS PLEASE! If you think I earned it!

If this solution worked for you please flag my post as an "Accepted Solution" so others can benefit..]

 

 

Highlighted
Regular Visitor
Posts: 9
Registered: ‎10-12-2014
0 Kudos

Re: Weird error log

You can always have a look on logs via "System log Explorer", below is the link to it:

 

https://apps.juniper.net/syslog-explorer/

 

P.S.: There might be a possibility that you dont find few of the logs in this tool.

 

 

Furthermore, 

Link to your error log:

 

https://apps.juniper.net/syslog-explorer/#msg=CHASSISD_PIC_SPEED_INVALID&sw=Junos%20OS&rel=17.2R1

 

 

Regards,
Nupur Kanoi
Juniper Ambassador
JNCIE-ENT#520, JNCIP-SP, JNCDS-DC
Distinguished Expert
Posts: 5,121
Registered: ‎03-30-2009
0 Kudos

Re: Weird error log

I suspect the link is at half duplex check this in operational mode to get the link actual negociation status.

 

show interfaces ge-0/0/2 media

 

If it is half duplex the turn off auto-neg in configuration mode.  This will bounce the port so should be in a maintenance window.

 

set interface ge-0/0/2 gigether-options no-auto-negotiation

Steve Puluka BSEET
Juniper Ambassador
Senior IP Engineer - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
JNCIA-Junos JNCIS-SEC JNCIP-SEC JNCSP-SEC
JNCIS-FWV
JNCDA JNCDS-DC JNCDS-SEC
JNCIS-SP
ACE PanOS 6 ACE PanOS 7
http://puluka.com/home
New User
Posts: 3
Registered: ‎09-01-2017
0 Kudos

Re: Weird error log

Hi 
thank your suggestion. after removing it then works.