Management
Reply
Contributor
Bart
Posts: 48
Registered: ‎08-21-2009
0
Accepted Solution

NSM2010.1: re-import srx 240 fails

Hi,

 

Has anybody have experienced this error while re-importing a srx device (device -> import config):

Error Code:

Error Text:
   Fail to get the connection state from the device - Object Not Found

Error Details:
    No Details Available.

 

I cannot see errors in deviceDaemon log.

Update device still works

config delta still works

logs still arrive on nsm

..

 

srx version is 10.0R3.10.

 

Tnx

 

Bart

 

Contributor
Bart
Posts: 48
Registered: ‎08-21-2009
0

Re: NSM2010.1: re-import srx 240 fails

Should somebody care, I applied the latest schema (I need this for SA7), Gui & Device server restarted, and i could reimport the srx again..

 

I found an annoying issue on nsm installed on WIN2K8, apparently the schema download does not complete with a non-administrator account, causing the device list to appear empty.

 

I logged in with Administrator, started NSM, schema was updated and devices appeared again.

I copied the file from c:\users\Administrator\.nsm\schemas-nsm\<version>\nsm.schema.bin to c:\users\<user>\.nsm\schemas-nsm\<version>\nsm.schema.bin and then the device list was displaying correctly!

 

Cheers

Dil
Contributor
Dil
Posts: 26
Registered: ‎01-20-2011
0

Re: NSM2010.1: re-import srx 240 fails

Hi Bart,

 

In this case, if you are facing issue like failt to get connection state from the device - Object not found ,

 

you need to check the status of the devSvr 

/etc/init.d/devSvr status

 

Most probably u'll see deviceDirectiveHandler process in not ON.

 

after that u need to remove the large backup files from the /var directory i.e, creating enough space in /var directory

 

after that you need to reboot the NSM appliance.

 

hope this would solve your problem

 

 

Regards,

 

Dilmani 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.