Pulse Secure formerly SSL VPN
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 2
Registered: ‎03-22-2010
0
Accepted Solution

JuniperSetupClientInstaller.exe Groundhog Day

Hello

 

I have Windows7 Ultimate running 64bit running on an AMD twin core laptop. My logon has local admin rights to the laptop.

 

Previously, I was able to connect to my companie's network by opening a remote desktop session via my browser. Last week I installed VMWare player. Since then, I've not been able to use the Juniper service. The VMWare installation may be a coincidence?

 

When I enter the https address to the companies server I get a message requesting that JuniperSetupClientInstaller.exe is downloaded and run. I accept, then click the run button. It seems to download and install ok. I then get the message on the web page "Once the setup client is installed, please click here to continue". I click the link and I get another page - Please wait whilst host checker is installed. The browser downloads [1]Juniper Setup Client[1].cab. Then it requests to download JuniperSetupClientInstaller again. This process the repeats

 

Can anyone please help?

 

Thanks

 

Rob.

Distinguished Expert
Posts: 2,400
Registered: ‎01-29-2008

Re: JuniperSetupClientInstaller.exe Groundhog Day

There was a Juniper Knowledge Base article that dealt with an issue that may be what you are running into. Check this out.

 

Hope it helps!

http://kb.juniper.net/index?page=content&id=KB15862&actp=search&searchid=1269269426022

Kevin Barker
JNCIP-SEC
JNCIS-ENT, FWV, SSL, WLAN
JNCIA-ER, EX, IDP, UAC, WX
Juniper Networks Certified Instructor
Juniper Networks Ambassador

Juniper Elite Reseller
J-Partner Service Specialist - Implementation

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.
New User
Posts: 2
Registered: ‎03-22-2010
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

That's great thanks. The problem was easily solved once I had the reply - just use a 32bit browser.

 

I'm not sure why the 64bit browser stopped working, but life's too short to worry about that!

Juniper Employee
Posts: 15
Registered: ‎11-11-2009
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

You may use firefox as a workaound

Trusted Contributor
Posts: 154
Registered: ‎07-04-2008
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

Hey,

 

same issue here and I didnt find a solution yet. Does anybody know how to solve this? The above mentioned KB article says:

Article is in review and not yet ready for viewing

 

Any help would be appreciated!

New User
Posts: 1
Registered: ‎10-02-2012
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

Hi,

 

Can anymore provide me the solution?

 

Regards,

terence

Moderator
Posts: 2,347
Registered: ‎11-19-2007
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

make sure to be using 32-bit browser.

does uac enabled/disabled make a difference?

Contributor
Posts: 12
Registered: ‎10-19-2013
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

Hello. Still have the same issue. Windows 8. Using 32bit browser (was trying with firefox and ie). Java is updated. Enable/Disable - no difference.

Contributor
Posts: 33
Registered: ‎01-10-2012
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

I've seen this happen as well on a few computers that had different virtual machine software installed (VMware / Virtualbox etc). It turned out that the maximum number of virtual network interfaces was reached. I tried to look in my archives to see if I could find the exact registry key to fix this, but didn't find it unfortunately.

 

I remember that the MSI installed did give some warnings that helped us troubleshoot further and googling for that helped us find the exact registry key. Make sure you download the Pulse MSI to the local computer manually and execute the msi from the command line making sure it does log debug level to a log file: http://www.advancedinstaller.com/user-guide/qa-log.html

 

Hope this helps,

 

-JH

New User
Posts: 1
Registered: ‎01-20-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

Hi,

 

I'm using Windows 8.1 and I'm having the same "Groundhog Day" problem.

I've tried using a 32-bit browser but had no luck.

 

I see the muttbarker suggested a fix in the post : http://kb.juniper.net/index?page=content&id=KB15862&actp=search&searchid=1269269426022

but this post doesn't seem to be available.

 

Does anyone know what is written in this post?

 

Thanks,

 

Ciprian

New User
Posts: 1
Registered: ‎01-21-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

[ Edited ]

I am having the same problem. Does anybody have an actual solution for this issue. I am running Windows 7 with no VM's or anything.

 

Found the issue. It's the lovely JAVA. You need to add the URL that you are trying to access to the JAVA security list.

New User
Posts: 1
Registered: ‎01-22-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

[ Edited ]

None of the above worked for me. 

 

Here is the errors I see.

"In order to continue the operation you need to install a setup client. Please click here to install setup package. You must enable either ActiveX or Java to run the downloaded setup client.

Once the setup client is installed, please click here to continue.

Please click here to login to the realms without Host Checker.
If you do not want to proceed, please click here to go back.

"

And I clicked:

"Please click here to login to the realms without Host Checker."

I get this message: "Your computer's security is unsatisfactory

Host Checker did not get installed properly. Your computer does not meet the security requirements."

with 2 buttons "Try Again" or "Continue". I click the Try Again button and get this message:

"If this page has an yellow bar on top prompting for the installation of Active-X control, Click on the Yellow Bar and proceed with the installation of the Active-X control."

But there is no yellow bar.

 

Followed the recommended solutions mentioned above.

I dowloaded FireFox -  Doesn't work.

I added my company's VPN URL to my JAVA's security list. - Doesn't work.

 

My system configuration:

Windows 7 Professional - Service Pac 1,

64-bit OS,

Intel Processsor,

IE 11,

JAVA 1.7.0_51

 

Our company recently upgrated to using Juno Pulse, but I can't get it installed on this laptop because of the original issue with JuniperSetupClientInstaller.exe

 

I've talked to my company's Sys Admins and they are stumped.

Is there a workaround for installing Junos Pulse Version 4.0 

I think if I can install that then I can use the VPN again. 

Contributor
Posts: 70
Registered: ‎02-27-2009
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

"C:\Program Files (x86)\Internet Explorer\iexplore.exe" https://<your-IVE-URL>

 

As workaround create a Link on Users desktop that starts IE 32bit and opens your IVE login URL.

 

 

Moderator
Posts: 2,347
Registered: ‎11-19-2007
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

can they put the installer on a share that you can access to download and run manually?
Visitor
Posts: 8
Registered: ‎10-15-2011
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

i am also having the same issue. the network connect client fails to install. im just curious why does it happen only on x64 bit systems. in my control panel i can find only juniper network setup client and activex control client. i am unable to find

1. cache cleaner

2. network connect

 

juniper is updating the kb mentioned in the post and potentially my clients cannot connect to my corporate office now. need a fix asap

Visitor
Posts: 2
Registered: ‎02-05-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

I have the same problem currently on Windows 7 X64 with iexplorer / chrome and firefox. Even running iexplorer 32 bits did not resolv the issue. Java 7 Update 51, We are running 7.4R4 on the SA.

New User
Posts: 1
Registered: ‎02-06-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

I am newly experiencing a similar problem, running Vista Home Premium. Things worked fine for years, until I removed & recreated my username (big mistake), in an effort to recover from a crash..

  • I have uninstalled & re-installed JuniperNetworks et. al. numerous times.
  • I've removed all java & installed 1.7.51
  • I removed IE-9 reverting to IE-8
  • I've verified ActiveX and Java are enabled
  • I've verified my component download site is trusted
  • I've run everything as administrator
  • I've found some messages in log files, but nothing consistent or intelligible
  • my corporate support gave up because this is a personal tower rather than a corporate machine


 

Visitor
Posts: 2
Registered: ‎02-05-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

Like a few post earlier,  adding our environment to the JAVA security list solved my issue. Never had this before however.

Contributor
Posts: 106
Registered: ‎05-25-2011
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

How do you add the URL to the Java security list?

New User
Posts: 1
Registered: ‎02-15-2014
0

Re: JuniperSetupClientInstaller.exe Groundhog Day

[ Edited ]

This is what worked for me I had to manually install the client on my machine and login to my VPN through there. Read through this article: Rid of Groundhog day

Windows 7 32-bit:
http://helpdesk.cwsl.edu/Software/JuniperVPN/Windows/NCInst.exe

Windows 7 64-bit and all Windows 8:
http://helpdesk.cwsl.edu/Software/JuniperVPN/Windows/NCInst64.exe

Mac OSX:
http://helpdesk.cwsl.edu/Software/JuniperVPN/MacOSX/NetworkConnect.zip

Linux:
http://helpdesk.cwsl.edu/Software/JuniperVPN/Linux/ncui-8.0R1.1.i386.rpm