Pulse Secure formerly SSL VPN
Showing results for 
Search instead for 
Do you mean 
Posts: 13
Registered: ‎03-19-2009
0 Kudos

RDP for Linux/Mac

I have installed successfully for ProperJava. However, wheneve I access RDP via

Linux/Mac, I will get the error message "This terminal session is not supported on your computer." message.


Anyone has any idea?  The Linux computer passed the Java validation test on Sun website.

Posts: 5
Registered: ‎03-20-2009
0 Kudos

Re: RDP for Linux/Mac

what version of Java Run Time enviroment are you running on the client machines?


Distinguished Expert
Posts: 2,405
Registered: ‎01-29-2008
0 Kudos

Re: RDP for Linux/Mac

I run ProperJava on both Linux and MAC with no problems. I would look at making sure you have a very current version of Java run-time. You can also turn on client logging within the SSL box to see, or of course, turn on the Java Console (on MAC - Applications / Utilities / Java / Java Preferences / Advanced). This will let you see what is happening from a Java perspective when you launch the RDP session.
Kevin Barker
Juniper Networks Certified Instructor
Juniper Networks Ambassador

Juniper Elite Reseller
J-Partner Service Specialist - Implementation

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.
Posts: 1
Registered: ‎05-14-2009
0 Kudos

Re: RDP for Linux/Mac

I am replying to this thread because I have the same question. I searched and found this as the only thread. My company is switching over to the sslvpn as a replacement for the cisco vpn client.


I have tried to connect to my workstations - xp and vista and openSUSE but have been unable. I setup rdp connections for the xp and vista workstataions so far. When I try and launch, I get the same message - this terminal session is not supported on your computer.


I am running Ubuntu 9.04 with Gnome 2.26.1 on this computer. I tried also from my other home workstation, running openSUSE 10.3 with KDE. In both cases, I'm running Firefox 3.0.x as teh browser and have Java  1.6 installed...


kai@r2d2:~$ java -version
java version "1.6.0_13"
Java(TM) SE Runtime Environment (build 1.6.0_13-b03)
Java HotSpot(TM) Server VM (build 11.3-b02, mixed mode)

I have tested and can run JWS apps without a problem on both workstations. 


On this workstation, I fired up Windows 7 in VirtualBox and ran with IE8. It did launch the  terminal session and seemed to launch it as rdesktop.exe.  On both my laptop and desktop I have grdc and krdc, which I often use to connect after runnign the cisco vpn client.




kai ponte, manager
los angeles county registrar recorder
www.lavote.net || www.ecmplace.com

a turn signal is a statement, not a request
Regular Visitor
Posts: 6
Registered: ‎01-22-2010
0 Kudos

Re: RDP for Linux/Mac


I have opened a case to the TAC Juniper.

See what was their answer :


I understand that you wanted to use RDP for Ubuntu and JTAC has informed you that this Ubuntu version is not qualified to work with 6.2R5, however Ubuntu 7.10: Firefox 2.0.Sun JRE 6 is supported to work.


You will see the attachement that i have put in my reply, there is no specification written for MAC, for terminal services.


I suggest you to open a case to the tac if it's possible.



Posts: 2,347
Registered: ‎11-19-2007
0 Kudos

Re: RDP for Linux/Mac

Do you have the option on the terminal service bookmark enabled to allow Java fallback (supported) or are users creating their own bookmarks (not supported for Java fallback).