Routing

last person joined: 4 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  BGP state IDLE

    Posted 04-11-2015 11:34

    Hello! I Cannot understand where is mistake in configuration? Maybe there is another resone???

     

    There is no BGP connection !  why?

     

    root# run show bgp summary 
    Groups: 1 Peers: 1 Down peers: 1
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    inet.0                 0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    192.168.92.1            200          0          0       0       0        9:59 Idle  

     

     

    The schema:

    123.png

     

    juniper-1:

     

    root# show | no-more 
    ## Last changed: 2015-04-11 21:17:00 UTC
    version 12.1R1.9;
    system {
        root-authentication {
            encrypted-password "$1$Rx9soMEq$d8gjD5GwidGh9uHtamij81"; ## SECRET-DATA
        }
    }
    interfaces {
        em0 {
            unit 0 {
                family inet {
                    address 10.255.255.1/24;
                }
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    address 192.168.93.1/24;
                }
            }
        }
    }
    routing-options {
        static {
            route 192.168.92.0/24 next-hop 10.255.255.2;
            route 5.5.5.0/24 discard;
        }
        router-id 192.168.93.1;
        autonomous-system 100;
    }
    protocols {
        bgp {
            traceoptions {
                file BGP_LOG;
            }
            group eBGP {
                type external;
                local-address 192.168.93.1;
                export 5.5.5.0/24;
                neighbor 192.168.92.1 {
                    peer-as 200;
                }
            }
        }
        ospf {
            area 0.0.0.0 {
                interface lo0.0;
                interface em0.0;
            }
        }
    }
    policy-options {
        policy-statement 5.5.5.0/24 {
            term 1 {
                from {
                    route-filter 5.5.5.0/24 exact;
                }
                then accept;
            }
            term 2 {
                then reject;
            }
        }
    }

     

     

    juniper-2:

     

    root# show | no-more 
    ## Last changed: 2015-04-11 21:13:25 UTC
    version 12.1R1.9;
    system {
        root-authentication {
            encrypted-password "$1$kLP9U4yd$CCnMK3CQe5cWeEo6xB9vh."; ## SECRET-DATA
        }
        syslog {
            user * {
                any emergency;
            }
            file messages {
                any notice;
                authorization info;
            }
            file interactive-commands {
                interactive-commands any;
            }
        }
    }
    interfaces {
        em0 {
            unit 0 {
                family inet {
                    address 10.255.255.2/24;
                }
            }
        }
        lo0 {
            unit 0 {
                family inet {
                    address 192.168.92.1/24;
                }
            }
        }
    }
    routing-options {
        autonomous-system 200;
    }
    protocols {
        bgp {
            group eBGP {
                type external;
                local-address 192.168.92.1;
                neighbor 192.168.93.1 {
                    peer-as 100;
                }
            }
        }
        ospf {
            area 0.0.0.0 {
                interface lo0.0;
                interface em0.0;
            }
        }
    }

     

     

    More information:

    juniper-1:

    [edit]
    root# run ping 192.168.92.1 source 192.168.93.1 rapid 
    PING 192.168.92.1 (192.168.92.1): 56 data bytes
    !!!!!

     

    root# run show route | no-more 
    
    inet.0: 8 destinations, 9 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    5.5.5.0/24         *[Static/5] 00:57:58
                          Discard
    10.255.255.0/24    *[Direct/0] 01:07:03
                        > via em0.0
    10.255.255.1/32    *[Local/0] 01:29:33
                          Local via em0.0
    192.168.92.0/24    *[Static/5] 00:19:46
                        > to 10.255.255.2 via em0.0
                        [OSPF/10] 00:19:14, metric 1
                        > to 10.255.255.2 via em0.0
    192.168.92.1/32    *[OSPF/10] 00:52:32, metric 1
                        > to 10.255.255.2 via em0.0
    192.168.93.0/24    *[Direct/0] 00:19:46
                        > via lo0.0
    192.168.93.1/32    *[Local/0] 00:19:46
                          Local via lo0.0
    224.0.0.5/32       *[OSPF/10] 00:55:53, metric 1
                          MultiRecv

     

     

     



  • 2.  RE: BGP state IDLE
    Best Answer

    Posted 04-11-2015 12:35

    Configure your eBGP neighbors as multihop, it will work then.

    By default TTL value carried in the IP header of BGP packets is set to 1, you are trying to form neighborship between Loopback interfaces (not the directly connected interfaces) so you need to configure the eBGP multihop which will set new TTL value (which is 64) else you have the option to specify the TTL value as you wish.

     

    set protocols bgp group eBGP multihop

    or

    set protocols bgp group eBGP multihop ttl 2



  • 3.  RE: BGP state IDLE

    Posted 04-11-2015 12:46

    Right on target! Thank U!