Routing
Reply
Contributor
GeorgeKamel82
Posts: 20
Registered: ‎07-31-2011
0
Accepted Solution

Dynamic LSP with RSVP

Hi All ,

              I am trying to configure dynamic LSP with RSVP , network is  very simple just 4 cascaded routers .

 

 

This is the config on the ingress router 

 

 

rsvp {
traceoptions {
file Sherry_RSVP;
flag packets detail;
}
interface all;
interface em0.0 {
disable;
}
}
mpls {
label-switched-path Sherry-to-Char {
to 192.168.32.1;
bandwidth 24m;
no-cspf;
 }

interface all;
interface em0.0 {
disable;
}
}
ospf {
area 0.0.0.0 {
interface all;
}
}

 

 

On all the other routers , this is the config 

 

rsvp {
traceoptions {
file Char_RSVP;
flag packets detail;
}
interface all;
interface em0.0 {
disable;
}
}
mpls {
interface all;
interface em0.0 {
disable;
}
}
ospf {
area 0.0.0.0 {
interface all;
}
}

 

And of coarse  the mpls family is configured on all the interfaces (expect for the Loopback interfaces)

=====================================================

The LSP never goes up , it only goes up only if I use a strict list of Hops , thanks



Contributor
PerG
Posts: 54
Registered: ‎01-13-2011
0

Re: Dynamic LSP with RSVP

Hi,

 

Under 'label-switched-path' add

 

primary path-sherry;

 

 

and under 'protocol mpls' add

 

path path-sherry;

 

 

It needs a name to refer to.

 

Cheers.

Trusted Expert
Surya
Posts: 262
Registered: ‎08-25-2009
0

Re: Dynamic LSP with RSVP

Hi,

 

Can you please provide the output of below:

 

show mpls lsp extensive

show route 192.168.32.1 extensive

show rsvp interface

show mpls interface

 

Regards

Surya Prakash

 

Contributor
GeorgeKamel82
Posts: 20
Registered: ‎07-31-2011
0

Re: Dynamic LSP with RSVP

Here you are the outputs that you asked for 


Trusted Expert
Surya
Posts: 262
Registered: ‎08-25-2009
0

Re: Dynamic LSP with RSVP

[ Edited ]

Hi,

 

I believe you need to include em0 under RSVP and MPLS.

 

Since you have not enabled CSPF and don't have defined ERO path, the LSP tries hop-by-hop based on IGP path.

For the 192.168.32.1, the OSPF points to em0 as your egress interface

 

KRT in-kernel 192.168.32.1/32 -> {10.0.1.5}
        *OSPF   Preference: 10
                Next hop type: Router, Next hop index: 464
                Next-hop reference count: 8
                Next hop: 10.0.1.5 via em0.0, selected
                State: <Active Int>
                Age: 10:10      Metric: 1
                Area: 0.0.0.0
                Task: OSPFv2
                Announcement bits (1): 0-KRT
                AS path: I

 

 

and since this interface is not enabled with RSVP and MPLS, the LSP doesn't come Up.


 

George@Sherry> show rsvp interface
RSVP interface: 2 active
                  Active Subscr- Static      Available   Reserved    Highwater
Interface   State resv   iption  BW          BW          BW          mark
em1.0       Up         0   100%  1000Mbps    1000Mbps    0bps        0bps
em3.0       Up         0   100%  1000Mbps    1000Mbps    0bps        24Mbps

George@Sherry> show mpls interface
Interface        State       Administrative groups
em1.0            Up         <none>
em3.0            Up         <none>

 

I hope when you tried with strict ERO path, it would have been a either through em1 or em3.

 

Regards

Surya Prakash

Contributor
GeorgeKamel82
Posts: 20
Registered: ‎07-31-2011
0

Re: Dynamic LSP with RSVP

Yea this solved the problem , in fact em0 was meant to be used as an admin port of the lab this why I was disabling the MPLS and RSVP on it but I forgot to disable the OSPF as well . It is now working fine after I had disabled the OSPF on em0 

 

 

Thanks for your help

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.