Routing

last person joined: 4 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  L3VPN not advertising routes

     
    Posted 10-14-2015 11:34

    Hi All,

     

    I've labbed up a very basic L3VPN in GNS3, everything is working fine except the PEs are not advertising the VPN4 routes to each other.

     

    Setup is as follows

     

    CE1>>PE1>P<<PE2<<CE2

     

    Config attached.  I don't think I've missed anything out on the config. 

     

    ***CE1***
    set version 12.1R1.9
    set system host-name Cust-CE
    set system root-authentication encrypted-password "$1$htl843is$7w5xbBBhxgVDbAfJGztN6/"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces em0 unit 0 family inet address 192.168.10.1/30
    set routing-options autonomous-system 65001
    set protocols bgp group TO-ISP type external
    set protocols bgp group TO-ISP export RED-DIR-BGP
    set protocols bgp group TO-ISP peer-as 65000
    set protocols bgp group TO-ISP neighbor 192.168.10.2
    set policy-options policy-statement RED-DIR-BGP term 1 from protocol direct
    set policy-options policy-statement RED-DIR-BGP term 1 then accept
    set policy-options policy-statement RED-DIR-BGP term 2 then reject

    ***PE1***
    set version 12.1R1.9
    set system host-name PE1
    set system root-authentication encrypted-password "$1$adGFXex7$TAP8IufZ9cNMOUi6e1.Q50"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces em0 unit 0 family inet address 192.168.10.2/30
    set interfaces em1 unit 0 family inet address 10.10.10.0/31
    set interfaces em1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 2.2.2.2/32
    set routing-options autonomous-system 65000
    set protocols mpls interface em1.0
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 2.2.2.2
    set protocols bgp group iBGP family inet-vpn any
    set protocols bgp group iBGP export iBGP
    set protocols bgp group iBGP neighbor 4.4.4.4
    set protocols ospf area 0.0.0.0 interface em1.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp interface em1.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement Customer1 term 1 from protocol bgp
    set policy-options policy-statement Customer1 term 1 from community Customer1
    set policy-options policy-statement Customer1 term 1 then accept
    set policy-options policy-statement Customer1 term 2 then reject
    set policy-options policy-statement iBGP then accept
    set policy-options community Customer1 members target:65000:1
    set routing-instances Customer1 instance-type vrf
    set routing-instances Customer1 interface em0.0
    set routing-instances Customer1 route-distinguisher 3.3.3.3:1
    set routing-instances Customer1 vrf-import Customer1
    set routing-instances Customer1 vrf-export Customer1
    set routing-instances Customer1 vrf-target target:65000:1
    set routing-instances Customer1 vrf-table-label
    set routing-instances Customer1 protocols bgp group Customer1 type external
    set routing-instances Customer1 protocols bgp group Customer1 family inet unicast
    set routing-instances Customer1 protocols bgp group Customer1 peer-as 65001
    set routing-instances Customer1 protocols bgp group Customer1 neighbor 192.168.10.1

    ***P***
    set version 12.1R1.9
    set system host-name P1
    set system root-authentication encrypted-password "$1$adGFXex7$TAP8IufZ9cNMOUi6e1.Q50"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces em1 unit 0 family inet address 10.10.10.1/31
    set interfaces em1 unit 0 family mpls
    set interfaces em2 unit 0 family inet address 10.10.10.2/31
    set interfaces em2 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 3.3.3.3/32
    set protocols mpls interface em1.0
    set protocols mpls interface em2.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ospf area 0.0.0.0 interface em1.0
    set protocols ospf area 0.0.0.0 interface em2.0
    set protocols ldp interface em1.0
    set protocols ldp interface em2.0
    set protocols ldp interface lo0.0

    ***PE2***
    set version 12.1R1.9
    set system host-name PE2
    set system root-authentication encrypted-password "$1$adGFXex7$TAP8IufZ9cNMOUi6e1.Q50"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces em0 unit 0 family inet address 192.168.20.2/30
    set interfaces em2 unit 0 family inet address 10.10.10.3/31
    set interfaces em2 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 4.4.4.4/32
    set routing-options autonomous-system 65000
    set protocols mpls interface em2.0
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 4.4.4.4
    set protocols bgp group iBGP family inet-vpn any
    set protocols bgp group iBGP export iBGP
    set protocols bgp group iBGP neighbor 2.2.2.2
    set protocols ospf area 0.0.0.0 interface em2.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ldp interface em2.0
    set protocols ldp interface lo0.0
    set policy-options policy-statement Customer1 term 1 from protocol bgp
    set policy-options policy-statement Customer1 term 1 from community Customer1
    set policy-options policy-statement Customer1 term 1 then accept
    set policy-options policy-statement Customer1 term 2 then reject
    set policy-options policy-statement iBGP then accept
    set policy-options community Customer1 members target:65000:1
    set routing-instances Customer1 instance-type vrf
    set routing-instances Customer1 interface em0.0
    set routing-instances Customer1 route-distinguisher 4.4.4.4:1
    set routing-instances Customer1 vrf-import Customer1
    set routing-instances Customer1 vrf-export Customer1
    set routing-instances Customer1 vrf-target target:65000:1
    set routing-instances Customer1 vrf-table-label
    set routing-instances Customer1 protocols bgp group Customer1 type external
    set routing-instances Customer1 protocols bgp group Customer1 family inet unicast
    set routing-instances Customer1 protocols bgp group Customer1 peer-as 65002
    set routing-instances Customer1 protocols bgp group Customer1 neighbor 192.168.20.1

    ***CE2***
    set version 12.1R1.9
    set system host-name Cust-CE2
    set system root-authentication encrypted-password "$1$adGFXex7$TAP8IufZ9cNMOUi6e1.Q50"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces em0 unit 0 family inet address 192.168.20.1/30
    set routing-options autonomous-system 65002
    set protocols bgp group TO-ISP type external
    set protocols bgp group TO-ISP export RED-DIR-BGP
    set protocols bgp group TO-ISP peer-as 65000
    set protocols bgp group TO-ISP neighbor 192.168.20.2
    set policy-options policy-statement RED-DIR-BGP term 1 from protocol direct
    set policy-options policy-statement RED-DIR-BGP term 1 then accept
    set policy-options policy-statement RED-DIR-BGP term 2 then reject




    ***Show Outputs***
    root@PE1# run show bgp summary
    Groups: 2 Peers: 2 Down peers: 0
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    bgp.l3vpn.0            0          0          0          0          0          0
    bgp.l3vpn.2            0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    4.4.4.4               65000          5          5       0       0        1:13 Establ
      bgp.l3vpn.0: 0/0/0/0
      bgp.l3vpn.2: 0/0/0/0
    192.168.10.1          65001         20         20       0       0        7:47 Establ
      Customer1.inet.0: 0/1/1/0

    root@PE2# run show bgp summary
    Groups: 2 Peers: 2 Down peers: 0
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    bgp.l3vpn.0            0          0          0          0          0          0
    bgp.l3vpn.2            0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    2.2.2.2               65000          7          6       0       0        1:27 Establ
      bgp.l3vpn.0: 0/0/0/0
      bgp.l3vpn.2: 0/0/0/0
    192.168.20.1          65002          7          6       0       0        1:44 Establ
      Customer1.inet.0: 0/1/1/0


    Do not see bgp.l3vpn.0 as a route table

    root@PE1# run show route table ?
    Possible completions:
      <table>              Name of routing table
      Customer1.inet.0
      inet.0
      inet.3
      mpls.0



  • 2.  RE: L3VPN not advertising routes

     
    Posted 10-14-2015 14:27
    Hi,

    Looks like your customer bgp learnt route is not active on the PE. Must be the direct route from the emX interface on each PE that is active in the table. First put a static route on the CE and redist, then check again.

    Tim


  • 3.  RE: L3VPN not advertising routes

     
    Posted 10-15-2015 03:39

    I created some loopbacks on CE and advertised them n BGP, the routes are showing as active on PEs now, but still no L3VPN advertisements.

     

    root@PE1# run show bgp summary
    Groups: 2 Peers: 2 Down peers: 0
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    bgp.l3vpn.0            0          0          0          0          0          0
    bgp.l3vpn.2            0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    4.4.4.4               65000         36         36       0       0       15:06 Establ
      bgp.l3vpn.0: 0/0/0/0
      bgp.l3vpn.2: 0/0/0/0
    192.168.10.1          65001         44         38       0       0       16:17 Establ
      Customer1.inet.0: 1/1/1/0

     

    root@PE2> show bgp summary
    Groups: 2 Peers: 2 Down peers: 0
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    bgp.l3vpn.0            0          0          0          0          0          0
    bgp.l3vpn.2            0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    2.2.2.2               65000         36         36       0       0       14:59 Establ
      bgp.l3vpn.0: 0/0/0/0
      bgp.l3vpn.2: 0/0/0/0
    192.168.20.1          65002         43         39       0       0       16:29 Establ
      Customer1.inet.0: 1/1/1/0

     

    Thanks.



  • 4.  RE: L3VPN not advertising routes

    Posted 10-15-2015 04:43

    Most likely you still have a problem with the BGP next-hop now that you have resolved the first problem. The BGP prefix announced by CE1 has CE1 as BGP next-hop. So, you have to set the BGP next-hop to self before advertising the prefix to PE2. Thus, you need to Customer policies (one for import and one for export) and add the next-hop self to the export version.

     

    Cheers,

    Carsten



  • 5.  RE: L3VPN not advertising routes
    Best Answer

     
    Posted 10-15-2015 10:25

    Fixed the issue, I deleted the vrf-import and vrf-export, just left the vrf-target in.  I can see the routes being advertised.

     

    Will do some more reading up on exports and imports to get a better idea of it.