Routing

last person joined: 4 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  L3VPN with LSYS

    Posted 03-04-2013 13:15

    Hi all,

     

    I got a problem with a simple L3VPN setup in LSYS environment.

    And I can't figure out what i miss in my configuration..

     

     

    root@mx240:AAA> ping 10.10.10.5 routing-instance L3VPN
    PING 10.10.10.5 (10.10.10.5): 56 data bytes
    ^C
    --- 10.10.10.5 ping statistics ---
    12 packets transmitted, 0 packets received, 100% packet loss
    
    root@mx240:AAA>
    

     

     

    Design: http://s15.postimage.org/qhpkjwmez/l3vpn.jpg

     

    Conf:

     

    ##### AAA
    interfaces {
        ge-0/1/0 {
            unit 100 {
                vlan-id 100;
                family inet {
                    address 1.1.1.1/30;
                }
                family mpls;
            }
            unit 200 {
                vlan-id 200;
                family inet {
                    address 10.10.10.1/30;
                }
            }
        }
        lo0 {
            unit 11 {
                family inet {
                    address 11.11.11.11/32;
                }
            }
        }
    }
    protocols {
        mpls {
            interface all;
        }
        bgp {
            group INTERNAL {
                type internal;
                local-address 11.11.11.11;
                family inet {
                    any;
                }
                family inet-vpn {
                    any;
                }
                neighbor 22.22.22.22;
                neighbor 33.33.33.33;
            }
        }
        ospf {
            area 0.0.0.0 {
                interface lo0.11 {
                    passive;
                }
                interface all;
            }
        }
        ldp {
            interface all;
        }
    }
    routing-instances {
        L3VPN {
            instance-type vrf;
            interface ge-0/1/0.200;
            route-distinguisher 100:100;
            vrf-target target:100:100;
            vrf-table-label;
        }
    }
    routing-options {
        autonomous-system 65000;
    }
    
    
    ################################# CORE
    
    interfaces {
        ge-0/1/1 {
            unit 100 {
                vlan-id 100;
                family inet {
                    address 1.1.1.2/30;
                }
                family mpls;
            }
            unit 300 {
                vlan-id 300;
                family inet {
                    address 1.1.1.5/30;
                }
                family mpls;
            }
        }
        lo0 {
            unit 33 {
                family inet {
                    address 33.33.33.33/32;
                }
            }
        }
    }
    protocols {
        bgp {
            group INTERNAL {
                type internal;
                local-address 33.33.33.33;
                family inet {
                    any;
                }
                family inet-vpn {
                    any;
                }
                neighbor 11.11.11.11;
                neighbor 22.22.22.22;
            }
        }
        ospf {
            area 0.0.0.0 {
                interface all;
            }
        }
        ldp {
            interface all;
        }
    }
    routing-options {
        autonomous-system 65000;
    }
    
    
    
    ################################## BBB
    
    interfaces {
        ge-0/1/0 {
            unit 300 {
                vlan-id 300;
                family inet {
                    address 1.1.1.6/30;
                }
                family mpls;
            }
        }
        ge-0/1/1 {
            unit 200 {
                vlan-id 200;
                family inet {
                    address 10.10.10.5/30;
                }
                family mpls;
            }
        }
        lo0 {
            unit 22 {
                family inet {
                    address 22.22.22.22/32;
                }
            }
        }
    }
    protocols {
        mpls {
            interface all;
        }
        bgp {
            group INTERNAL {
                type internal;
                local-address 22.22.22.22;
                family inet {
                    any;
                }
                family inet-vpn {
                    any;
                }
                neighbor 11.11.11.11;
                neighbor 33.33.33.33;
            }
        }
        ospf {
            area 0.0.0.0 {
                interface lo0.22 {
                    passive;
                }
                interface all;
            }
        }
        ldp {
            interface all;
        }
    }
    routing-instances {
        L3VPN {
            instance-type vrf;
            interface ge-0/1/1.200;
            route-distinguisher 100:100;
            vrf-target target:100:100;
            vrf-table-label;
        }
    }
    routing-options {
        autonomous-system 65000;
    }

     

    Thanks in advance



  • 2.  RE: L3VPN with LSYS

    Posted 03-04-2013 13:27

    Hey there,

     

     Unless you have physical (back-to-back) cabling, I think you're missing the connection between the LS.

     

     Cheers,



  • 3.  RE: L3VPN with LSYS

    Posted 03-04-2013 13:33

    I have connection between the LSYS.

     

    root@mx240:AAA> show ospf neighbor
    Address          Interface              State     ID               Pri  Dead
    1.1.1.2          ge-0/1/0.100           Full      33.33.33.33      128    39
    
    root@mx240:AAA> show ldp session
      Address           State        Connection     Hold time
    33.33.33.33         Operational  Open             20
    
    root@mx240:AAA> show bgp summary
    Groups: 1 Peers: 2 Down peers: 0
    Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
    inet.0                 0          0          0          0          0          0
    inet.2                 0          0          0          0          0          0
    bgp.l3vpn.0            1          1          0          0          0          0
    bgp.l3vpn.2            0          0          0          0          0          0
    Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
    22.22.22.22           65000       3397       3397       0       2     7:40:16 Establ
      inet.0: 0/0/0/0
      inet.2: 0/0/0/0
      bgp.l3vpn.0: 1/1/1/0
      bgp.l3vpn.2: 0/0/0/0
      L3VPN.inet.0: 1/1/1/0
    33.33.33.33           65000       1059       1066       0       3     7:40:38 Establ
      inet.0: 0/0/0/0
      inet.2: 0/0/0/0
      bgp.l3vpn.0: 0/0/0/0
      bgp.l3vpn.2: 0/0/0/0
    
    root@mx240:AAA>
    

     



  • 4.  RE: L3VPN with LSYS

    Posted 03-04-2013 13:37
    I suggest to remove vrf-table-label and use vt- interface instead


    set chassis fpc 1 pic 0 tunnel-services bandwidth 10g
    set interfaces vt-1/0/0 unit 0 family inet
    set interfaces vt-1/0/0 unit 1 family inet

    Assign vt-1/0/0 units to each VRF


  • 5.  RE: L3VPN with LSYS

    Posted 03-04-2013 13:48

    I would like to get it to work with "ge-" interface since i want to add two CE.

     



  • 6.  RE: L3VPN with LSYS

    Posted 03-04-2013 14:01

    The suggestion is to replace vrf-table-label (required for IP lookup on top of label lookup) knob with using vt-interfaces.

     

    vrf-table-label (which is a very popular topic in this forum :)) is essentially a software implementation of vt-interfaces.

     

    Cheers,



  • 7.  RE: L3VPN with LSYS

    Posted 03-04-2013 19:24

    if you have tunnel services pic then enable the tunnel services under

     

    set chassis fpc x pic x tunnel-bandwidth 1g/10g

     

    then pute the vt-x/x/x interface under vrf. 

     

    check the forwarding table also that is "show route forwarding-table that vpn lable is associated with vt interface with label action POP.

     

    Regards

     

    Muhammad Rehan



  • 8.  RE: L3VPN with LSYS

    Posted 03-04-2013 19:35

    if you have tunnel services pic then enable the tunnel services under

     

    set chassis fpc x pic x tunnel-bandwidth 1g/10g

     

    put the vt interface under the vrf & check the forwarding table after commiting the config ,

     

    that is "show route forwarding-table that vpn lable is associated with vt interface with label action POP.

     

    Regards

     

    Muhammad Rehan



  • 9.  RE: L3VPN with LSYS
    Best Answer

    Posted 03-05-2013 00:31

    Good morning all,

     

    Ok you can use vt interface but I have choosed another way to do it.

    Since there are some limitations with vrf-table-label in LSYS i have done it with static routes and the CE's are 

    now as a virtual router in the PE.

     

    Case closed. thanks