Routing
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 11
Registered: ‎06-17-2014
0 Kudos

QFX VRF route leaking

Hello,

I have a litte a problem with route leaking between a VRF and the inet.0 with QFX 5100

My configuration: 

Vlan interface: 

 

set interfaces irb unit 1215 family inet address 172.31.1.5/30

 

My VRF:

set routing-instances CUST_A instance-type vrf
set routing-instances CUST_A interface irb.1215
set routing-instances CUST_A route-distinguisher 65000:1
set routing-instances CUST_A vrf-target target:65000:1
set routing-instances CUST_A routing-options interface-routes rib-group inet CUST_A
set routing-instances CUST_A routing-options static route 0.0.0.0/0 next-table inet.0
set routing-instances CUST_A protocols bgp group CUSTA type external
set routing-instances CUST_A protocols bgp group CUSTA family inet unicast rib-group CUST_A
set routing-instances CUST_A protocols bgp group CUSTA export export-default-vrf
set routing-instances CUST_A protocols bgp group CUSTA as-override
set routing-instances CUST_A protocols bgp group CUSTA neighbor 172.31.1.6 peer-as 65002

 

Policy we export a default gw in the VRF to the customer

set policy-options policy-statement export-default-vrf term t1 from route-filter 0.0.0.0/0 exact
set policy-options policy-statement export-default-vrf term t1 then accept
set policy-options policy-statement export-default-vrf term t2 then reject

 

Rib-group:

set routing-options rib-groups CUST_A import-rib CUST_A.inet.0
set routing-options rib-groups CUST_A import-rib inet.0
set routing-options rib-groups CUST_A import-policy CUST_A-IP-PUB

Rib-group import policy:

set policy-options policy-statement CUST_A-IP-PUB term 1 from route-filter 1.1.1.1/32 exact
set policy-options policy-statement CUST_A-IP-PUB term 1 then accept
set policy-options policy-statement CUST_A-IP-PUB term 2 then reject

 

OSPF: 

set protocols ospf export ospfbgp

 

set policy-options policy-statement ospfbgp term 2 from protocol bgp
set policy-options policy-statement ospfbgp term 2 from route-filter 1.1.1.1/32 exact
set policy-options policy-statement ospfbgp term 2 then accept

 

Route CUST_A.inet.0:

show route table CUST_A.inet.0

CUST_A.inet.0: 13 destinations, 15 routes (13 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0 *[Static/5] 05:00:56
to table inet.0

172.31.1.4/30 *[Direct/0] 05:01:45
> via irb.1215
[BGP/170] 01:37:54, localpref 100
AS path: 65002 ?, validation-state: unverified
> to 172.31.1.6 via irb.1215

1.1.1.1/32 *[BGP/170] 00:40:25, localpref 100
AS path: 65002 I, validation-state: unverified
> to 172.31.1.6 via irb.1215

192.168.3.0/24 *[BGP/170] 01:37:54, localpref 100
AS path: 65002 ?, validation-state: unverified
> to 172.31.1.6 via irb.1215

 

Route 1.1.1.1 in global: 

show route 1.1.1.1

inet.0: 170 destinations, 174 routes (169 active, 0 holddown, 1 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[BGP/170] 00:42:38, localpref 100
AS path: 65002 I, validation-state: unverified
> to 172.31.1.6 via irb.1215

CUST_A.inet.0: 13 destinations, 15 routes (13 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[BGP/170] 00:42:38, localpref 100
AS path: 65002 I, validation-state: unverified
> to 172.31.1.6 via irb.1215

 

ping 172.31.1.6 routing-instance CUST_A
PING 172.31.1.6 (172.31.1.6): 56 data bytes
64 bytes from 172.31.1.6: icmp_seq=0 ttl=64 time=17.307 ms

 

ping 1.1.1.1 routing-instance CUST_A
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: icmp_seq=0 ttl=64 time=23.155 ms

From the global i can't ping 1.1.1.1 

 

from R2:

 sh ip route 1.1.1.1
Routing entry for 1.1.1.1/32
Known via "ospf 1", distance 110, metric 0, type extern 2, forward metric 2000
Last update from 1.1.1.1 on Port-channel1.14, 00:00:21 ago
Routing Descriptor Blocks:
* 1.1.1.1, from 2.2.2.2, 00:00:21 ago, via Port-channel1.14
Route metric is 0, traffic share count is 1

I see the route to 1.1.1.1 but i can't ping 1.1.1.1

I dont' see where is the problem ...

 

I attach the schema

Thks for your help !

Highlighted
Contributor
Posts: 11
Registered: ‎06-17-2014
0 Kudos

Re: QFX VRF route leaking

No idea ?!

Visitor
Posts: 8
Registered: ‎04-05-2017
0 Kudos

Re: QFX VRF route leaking