Routing

last person joined: 2 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  QoS scheduler on MX80

    Posted 12-09-2016 05:04

    Hello forum guys, 

     

    I would like to implement qos scheduler but I am not very familiar with junos in regards qos config. What I would like to do, it is bacis like this config I would on cisco: 

     

    1.classify packets

     

    class-map match-any dscp_EF
    match dscp af41 af42 cs7
    class-map match-any dscp_AF
    match dscp af31 af32 af43
    class-map match-any dscp_BE
    match dscp default af11 af13 af21 af22 af23 af33

     

    2. create priority que for sensitive trafic and assign bw for it

     

    policy-map LTE_QoS
     class dscp_EF
      priority level 1 percent 20
     class dscp_AF
      priority level 2 percent 20
     class dscp_BE
    

    3.assign policy to interface in output direction

     

    interface GigabitEthernet1/0/1
     service-policy output LTE_QoS
    

    anybody could help me to convert that to junos? 



  • 2.  RE: QoS scheduler on MX80
    Best Answer

    Posted 12-09-2016 06:15

    Hi,

     

     

    Maybe you should habve a look on this Day One book "Day One: Junos QoS for IOS Engineers"

    http://www.juniper.net/us/en/training/jnbooks/day-one/fundamentals-series/junos-qos/

     

     

    --
    If this post solves your problem, please mark this post as "Accepted Solution".
    Kudos are appreciated



  • 3.  RE: QoS scheduler on MX80

    Posted 12-19-2016 04:20

    Hi 

     

     

     

     

    forwarding-classes {
        class EF queue-num 1 priority high;
        class BE queue-num 3 priority low;
        class AF queue-num 2 priority low;
    

     

    classifiers {
        dscp LTE_DSCP_Classfier {
            import default;
            forwarding-class EF {
                loss-priority high code-points [ af41 af42 cs7 ];
            }
            forwarding-class AF {
                loss-priority high code-points [ af31 af32 af43 ];
            }
            forwarding-class BE {
                loss-priority low code-points [ af11 af13 af21 af22 af23 af33 ];
    

     

    schedulers {
        EF-sched {
            buffer-size percent 20;
            priority strict-high;
        }
        AF-sched {
            transmit-rate percent 50;
            buffer-size percent 50;
            priority low;
        }
        BE-sched {
            priority low;
    

     

    scheduler-maps {
        LTE_DSCP_Scheduler {
            forwarding-class EF scheduler EF-sched;
            forwarding-class AF scheduler AF-sched;
            forwarding-class BE scheduler BE-sched;
    

    However I have issue with apllying forwarding-class  into interface - I do not have that option available: 

     

    admin@MX-80-1-Feve3-Rack-21# set interfaces xe-0/0/1 unit 0 class
                                                                ^
    syntax error.
    admin@MX-80-1-Feve3-Rack-21# set interfaces xe-0/0/1 unit 0 class

    I have oprtion for scheduler-map: 

     

    set class-of-service interfaces xe-0/0/1 scheduler-map ?
    Possible completions:
      <scheduler-map>      Output scheduler map
      LTE_DSCP_Scheduler
    

    So I do not know, is it necesaryl to apply both - forwarding class and scheduler map to interface? 

     

    The other question - if I apply scheduler map or forwarding class to interface, will it drop connectivity? 

     



  • 4.  RE: QoS scheduler on MX80

    Posted 12-19-2016 04:46

    Now you need to apply the classifier to the interface unit at the ingress:

     

    set class-of-service interfaces xe-0/0/1 unit 0 classifiers dscp LTE_DSCP_Classfier

     

     

    You also need to apply the scheduler map to the physical physical interface at the egress:

    set class-of-service interfaces xe-0/0/1 scheduler-map LTE_DSCP_Scheduler

     

     

    If you wish you can also rewrite the DSCP fields. In that case you will need to define a rewrite-rule and apply it  to the egress interface unit.

     

     

     

     

     

     

     

     



  • 5.  RE: QoS scheduler on MX80

    Posted 12-21-2016 02:25

    Thanks