Routing
Reply
Contributor
kruger
Posts: 120
Registered: ‎12-10-2008
0

Route table does not return anything

hello,

 

Im having trouble viewing a routing table on a specific vpn.

 

when I run - sho route table vpnxxx

I receive the following  - no routing tables matching specifications

 

I can see it importing routes and exporting routes.. But why would I receive no routing tables matching?

 

Thanks

Distinguished Expert
mikep
Posts: 483
Registered: ‎06-30-2009
0

Re: Route table does not return anything

Hi,

 

it seems that you do not have routing-instance with such a name:

 

[edit]                                  
lab@test# run show route table ljl
error: No routing tables matching specification.

 

lab@test# show routing-instances ?
Possible completions:
  <[Enter]>            Execute this command
  <instance_name>      Routing instance name
  Test10               Routing instance name
+ apply-groups         Groups from which to inherit configuration data
+ apply-groups-except  Don't inherit configuration data from these groups
  test20               Routing instance name
  |                    Pipe through a command

 

lab@test# run show route table test20

test20.l2vpn.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

100:1:2:1/96                
                   *[L2VPN/170/-65536] 06:11:48, metric2 1
                      Indirect

 

Kind Regards

Michael Pergament

 

If this worked for you please flag my post as an "Accepted Solution" so others can benefit. A kudo would be cool if you think I earned it.

 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.