SRX

last person joined: yesterday 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  Internet link configured as vlan

    Posted 09-02-2015 03:43

    Hi,

     

    I have 1 link from ISP that configured as vlan.

    How do I configure on my side using SRX220?

     

    Thanks. 



  • 2.  RE: Internet link configured as vlan

     
    Posted 09-02-2015 03:56

    Hello,

    Let us suppose ISP's interface is in L2 access mode with vlan-id 100 & it terminates on ge-0/0/1 interface on SRX, you can configure something like below:

    set vlans ISP vlan-id 100
    set interface ge-0/0/1.0 family ethernet-switching vlan members ISP
    commit.

    Regards,

    Rushi



  • 3.  RE: Internet link configured as vlan

     
    Posted 09-02-2015 04:05

    Hi,

     

    That depends a little.... how does the ISP assign you an IP-address ? Static / DHCP of PPPoE ?

     

    I will give you some examples below:

     

    PPPoE config:

     

    marcel@srx00> show configuration interfaces ge-0/0/0
    description "Internet to ISP";
    vlan-tagging;
    speed 1g;
    mtu 1514;
    link-mode full-duplex;
    gigether-options {
        no-auto-negotiation;
    }
    unit 0 {
        description "Internet to ISP";
        encapsulation ppp-over-ether;
        vlan-id 128 (You have to put your vlan-id here);
    }

     

    pp0 interface config:

    marcel@srx00> show configuration interfaces pp0
    unit 0 {
        point-to-point;
        ppp-options {
            pap {
                access-profile ppp-profile;
                local-name isp-username;
                local-password "isp-password"; ## SECRET-DATA
                passive;
            }
        }
        pppoe-options {
            underlying-interface ge-0/0/0.0;
            idle-timeout 0;
            auto-reconnect 10;
            client;
        }
        family inet {
            mtu 1492;
            primary;
            negotiate-address;
        }
    }

     

    You have to set a default route for the connection

     

    set routing-options static route 0.0.0.0/0 next-hop pp0.0

     

    Dhcp config:

     

    marcel@srx00> show configuration interfaces ge-0/0/0
    description "Internet to ISP";
    vlan-tagging;
    speed 1g;
    mtu 1514;
    link-mode full-duplex;
    gigether-options {
        no-auto-negotiation;
    }
    unit 0 {
        description "Internet to ISP";
        vlan-id 128 (You have to put your vlan-id here);

        family inet {
            primary;
            dhcp-client;
        }
    }

     

    set routing-options static route 0.0.0.0/0 next-hop ge-0/0/0.0

     

    Static config:

     

    marcel@srx00> show configuration interfaces ge-0/0/0
    description "Internet to ISP";
    vlan-tagging;
    speed 1g;
    mtu 1514;
    link-mode full-duplex;
    gigether-options {
        no-auto-negotiation;
    }
    unit 0 {
        description "Internet to ISP";
        vlan-id 128 (You have to put your vlan-id here);

        family inet {
            primary;
            address ip.you.get.fromyourisp/xx;
        }
    }

     

    set routing-options static route 0.0.0.0/0 next-hop gateway address of your isp

     

    Hope this helps a bit

     



  • 4.  RE: Internet link configured as vlan

    Posted 09-03-2015 05:42

    Hi,

     

    Thanks for the reply.

    I will try and let you know.

     

     



  • 5.  RE: Internet link configured as vlan
    Best Answer

    Posted 09-28-2015 01:08

    Just to add working config: 

     

     

    root# show interfaces ge-0/0/1
    flexible-vlan-tagging;
    native-vlan-id 1;
    unit 0 {
    vlan-id 1;
    }
    unit 200 {
    vlan-id 200;
    family inet {
    address 10.10.1.1/24;
    }
    }

     

     

    root# show interfaces ge-0/0/1 | display set
    set interfaces ge-0/0/1 flexible-vlan-tagging
    set interfaces ge-0/0/1 native-vlan-id 1
    set interfaces ge-0/0/1 unit 0 vlan-id 1
    set interfaces ge-0/0/1 unit 200 vlan-id 200
    set interfaces ge-0/0/1 unit 200 family inet address 10.10.1.1/24