SRX

last person joined: 19 hours ago 

Ask questions and share experiences about the SRX Series, vSRX, and cSRX.
  • 1.  Multiple GRE tunnel interface and multiple loopback interface

    Posted 02-13-2013 07:16

    Hi Experts 

     

    As I am new to Juniper world, I want know how can configure multiple GRE tunnel interface and multiple loopback interface on Juniper SRX 240.

     

    GRE tunnel problem:

     

    I have tried using unit 0 and 1 as below:

     

    gr-0/0/0 {

    unit 0 {
    tunnel {
    source 193.x.x.x;
    destination 193.x.x.x;
    }
    family inet {
    mtu 1400;
    address 1.1.1.2/30;
    }
    }
    unit 1 {
    tunnel {
    source 193.x.x.x;
    destination 193.x.x.x;
    }
    family inet {
    address 2.2.2.2/30;
    }

     

    after the above configuration, I am uanble to see the gr-0/0/0 unit 1 interface in "show interface terse" and neither ping works on this interface and same happens when I create a seperate GRE interface like gr-0/0/1 

     

    But I can see gr-0/0/0 unit 0 and its working fine... 

     

    Second question: 

     

    How can I created multiple loopback address as I have configured already lo0 but juniper does not allow me create lo1 and If I create unit 0 and 1 then it say as below:

     

    set interfaces lo0 unit 1 family inet address 193.x.x.x/32

     

    Result: 

     

    [edit interfaces lo0]
    'unit 1'
    if_instance: Multiple loopback interfaces not permitted in master routing instance
    error: configuration check-out failed

     

    Your prompt help would highly apperciated....

     

    Regards

     

    Faz



  • 2.  RE: Multiple GRE tunnel interface and multiple loopback interface
    Best Answer

     
    Posted 02-14-2013 00:51

    Hi,

     

    Multiple gr-0/0/0 units works fine for me.

    Example:

     

    gr-0/0/0 {
        unit 0 {
            tunnel {
                source 192.168.110.1;
                destination 192.168.100.1;
                routing-instance {
                    destination 1;
                }
            }
            family inet {
                address 1.2.3.1/24;
            }
        }
        unit 1 {
            tunnel {
                source 192.168.110.1;
                destination 192.168.100.100;
                routing-instance {
                    destination 1;
                }
            }
            family inet {
                address 2.3.4.1/24;
            }
        }
    }
    

    In my case I have my gr-0/0/0 units in a routing-instance called 1, hence that configuration line under tunnel.

    Add both units to a zone, add routes to the other side.

                route 3.4.5.0/24 next-hop gr-0/0/0.0;
                route 4.5.6.0/24 next-hop gr-0/0/0.1;
    

    And do the opposite on the other device.

    show interfaces terse:

    gr-0/0/0                up    up  
    gr-0/0/0.0              up    up   inet     1.2.3.1/24      
    gr-0/0/0.1              up    up   inet     2.3.4.1/24      
    

    and ping tests:

    adam@second> ping 4.5.6.1 routing-instance 1 detail verbose count 3    
    PING 4.5.6.1 (4.5.6.1): 56 data bytes
    64 bytes from 4.5.6.1 via gr-0/0/0.1: icmp_seq=0 ttl=64 time=4.073 ms
    64 bytes from 4.5.6.1 via gr-0/0/0.1: icmp_seq=1 ttl=64 time=3.913 ms
    64 bytes from 4.5.6.1 via gr-0/0/0.1: icmp_seq=2 ttl=64 time=4.077 ms
    
    --- 4.5.6.1 ping statistics ---
    3 packets transmitted, 3 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 3.913/4.021/4.077/0.076 ms
    
    adam@second> ping 3.4.5.1 routing-instance 1 detail verbose count 3    
    PING 3.4.5.1 (3.4.5.1): 56 data bytes
    64 bytes from 3.4.5.1 via gr-0/0/0.0: icmp_seq=0 ttl=64 time=5.166 ms
    64 bytes from 3.4.5.1 via gr-0/0/0.0: icmp_seq=1 ttl=64 time=4.126 ms
    64 bytes from 3.4.5.1 via gr-0/0/0.0: icmp_seq=2 ttl=64 time=4.182 ms

     

    On loopback however, you can only have one unit per routing instance, so you could have lo0.0 in master, and lo0.1 in a different one.

     

    Interface config:

    lo0 {
        unit 0 {
            family inet {
                address 10.1.0.2/32;
            }
        }
        unit 1 {
            family inet {
                address 10.2.0.2/32;
            }
        }
    }
    

     Add them to different routing instances, commit and you're left with this show interfaces terse:

    lo0                     up    up  
    lo0.0                   up    up   inet     10.1.0.2            --> 0/0
    lo0.1                   up    up   inet     10.2.0.2            --> 0/0