SRX Services Gateway
Reply
Visitor
Ryan.Thrift
Posts: 1
Registered: ‎10-25-2011
0

Newbie Help - SRX100 Untrust DHCP or Static Config

Hi,

 

I have a dynamic ip assigned by my ISP. It changes in typically every month or so. I use dyn.com for my DNS. The fe-0/0/0 interface was configured for DHCP. My ip recently changed and DHCP did not propagate. I've tried to delete and re-enter the DHCP config on the interface (don't know how to release/renew). I've tried to configure a static ip with my new leased ip. No other configuration has been changed. I use the show config | compare rollback and nothing change which makes sense because I didn't change anything...


I don't know why I can't bring my firewall up with a static or why DHCP isn't working??? I've verified the my internet is up and that I can get out by plugging directly into the modem. I am really new to JUNOS and networking in general but can navigate fairly well and use the help command.

 

Can figure this one out. Any help would be appreciated!!!

Juniper Employee
wandererjs
Posts: 34
Registered: ‎08-27-2009
0

Re: Newbie Help - SRX100 Untrust DHCP or Static Config

Hi Ryan,

 

When you say that the "IP address does not propagate", do you mean that the SRX never sees the updated IP address (as seen by show interfaces terse fe-0/0/*), or it receives the IP address but some part of those settings (i.e, DNS servers) are not propagated back to other DHCP clients of the SRX?

 

Are you using dhcp on an fe interface, or does your ISP use PPPoE?

 

My configuration using Comcast as a ISP is below (a gig interface on my SRX).  

 

joel@chilis220> show configuration interfaces ge-0/0/7  
unit 0 {
    description Comcast;
    family inet {
        }
        dhcp {
            update-server;
        }
    }
}

 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.