SRX Services Gateway
Reply
jec
Visitor
jec
Posts: 4
Registered: ‎06-26-2012
0

[SRX240 DHCP Server] Error: the dhcp subsystem is not running

[ Edited ]

Hi,

 

Does somebody already encountered the error in the subject despite all the configuration is done like it is on other SRX? The fact is that I don't find any way to solve this issue.

 

adm@FW# run show configuration system services dhcp
maximum-lease-time 86400;
default-lease-time 86400;
domain-name net.grp;
router {
    172.18.100.254;
}
pool 172.18.100.0/24 {
    address-range low 172.18.100.50 high 172.18.100.200;
    default-lease-time 1440;
    name-server {
        208.67.222.222;
        208.67.220.220;
    }
    router {
        172.18.100.254;
    }
    propagate-settings ge-0/0/4.0;
}

[edit]
adm@FW# run show system services dhcp global
error: the dhcp subsystem is not running

[edit]
adm@FW# run restart dhcp-service
warning: dhcp-service subsystem not running - not needed by configuration.

[edit]
adm@FW#

 

Distinguished Expert
MMcD
Posts: 628
Registered: ‎07-20-2010
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

Weird,

 

Try

 

user@srx>restart dhcp gracefully

MMcD [JNCIP-SEC, JNCIS-ENT, CCNA, MCP]
____________________________________________________

[Please Mark My Solution Accepted if it Helped, Kudos are Appreciated Too]
jec
Visitor
jec
Posts: 4
Registered: ‎06-26-2012
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

Thanks MMcD for your advise.

 

Unfortunately, it doesn't work better.

 

Here are the result:

adm@FW> restart dhcp gracefully
error: Dynamic Host Configuration Protocol process is not running
Dynamic Host Configuration Protocol process started, pid 30926

adm@FW> show system services dhcp global
error: the dhcp subsystem is not running

adm@FW> restart dhcp-service gracefully
warning: dhcp-service subsystem not running - not needed by configuration.

adm@FW>

Distinguished Expert
MMcD
Posts: 628
Registered: ‎07-20-2010
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

You may need to reboot the device if restart dhcp-service is not working.  :-s

MMcD [JNCIP-SEC, JNCIS-ENT, CCNA, MCP]
____________________________________________________

[Please Mark My Solution Accepted if it Helped, Kudos are Appreciated Too]
jec
Visitor
jec
Posts: 4
Registered: ‎06-26-2012
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

Thanks again!

 

Already rebooted when upgraded to JUNOS Software Release 11.4R2.16 last week. But it haven't resolved though.

 

Any other idea?

Contributor
ed_gpc
Posts: 194
Registered: ‎09-21-2010
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

1 - Do you have interfaces in the 172.18.100.0/24 subnet?

2 - Have you enabled DHCP in the security zone configuration?

jec
Visitor
jec
Posts: 4
Registered: ‎06-26-2012
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

Yes I confirm for both your questions. As we can see:

 

adm@FW# run show interfaces ge-0/0/4
Physical interface: ge-0/0/4, Enabled, Physical link is Up
  Interface index: 138, SNMP ifIndex: 528
  Description: Guest
  Link-level type: Ethernet, MTU: 1514, Link-mode: Full-duplex, Speed: 1000mbps, BPDU Error: None, MAC-REWRITE Error: None, Loopback: Disabled, Source filtering: Disabled, Flow control: Enabled, Auto-negotiation: Enabled,
  Remote fault: Online
  Device flags   : Present Running
  Interface flags: SNMP-Traps Internal: 0x0
  Link flags     : None
  CoS queues     : 8 supported, 8 maximum usable queues
  Current address: 64:87:88:4e:0c:04, Hardware address: 64:87:88:4e:0c:04
  Last flapped   : 2012-06-19 08:10:24 BST (1w0d 09:39 ago)
  Input rate     : 232 bps (0 pps)
  Output rate    : 0 bps (0 pps)
  Active alarms  : None
  Active defects : None
  Interface transmit statistics: Disabled

  Logical interface ge-0/0/4.0 (Index 76) (SNMP ifIndex 529)
    Flags: SNMP-Traps 0x0 Encapsulation: ENET2
    Input packets : 342367
    Output packets: 0
    Security: Zone: GUEST
    Allowed host-inbound traffic : bootp bfd bgp dns dvmrp igmp ldp msdp nhrp ospf ospf3 pgm pim rip ripng router-discovery rsvp sap vrrp dhcp finger ftp tftp ident-reset http https ike netconf ping reverse-telnet reverse-ssh rlogin rpm
    rsh snmp snmp-trap ssh telnet traceroute xnm-clear-text xnm-ssl lsping ntp sip dhcpv6 r2cp
    Protocol inet, MTU: 1500
      Flags: Sendbcast-pkt-to-re, Sample-input, Sample-output
      Addresses, Flags: Is-Preferred Is-Primary
        Destination: 172.18.100/24, Local: 172.18.100.254, Broadcast: 172.18.100.255

[edit]
adm@FW#

Regular Visitor
mholden@datanetworksolutions.c
Posts: 2
Registered: ‎08-11-2011
0

Re: [SRX240 DHCP Server] Error: the dhcp subsystem is not running

adm@FW# run show configuration system services dhcp
maximum-lease-time 86400;
default-lease-time 86400;
domain-name net.grp;
router {
172.18.100.254;
}
pool 172.18.100.0/24 {
address-range low 172.18.100.50 high 172.18.100.200;
default-lease-time 1440;
name-server {
208.67.222.222;
208.67.220.220;
}
router {172.18.100.254;} <-- Remove Already defined
propagate-settings ge-0/0/4.0; <-- Remove This says ge-0/0/4.0 is a dhcp client and you want to pass the setting that it gets in where you have not defined the setting. 
}

 

Also do you have DHCPv6 enabled? I've had issues with the jdhcpd deamon preventing the dhcpd deamon from starting. 

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.