SRX Services Gateway
Showing results for 
Search instead for 
Do you mean 
Reply
New User
Posts: 3
Registered: ‎03-17-2017
0 Kudos
Accepted Solution

SRX300 - DHCP and IP phone

I have an SRX300 and with DHCP configured.  When I connect my laptop to the SRX, it happily receives an IP address with all the options I have associated with the config.  If I connect an IP phone, it will not get an address.  I have tried this with 2 different phones from 2 different manufactures with the same result.  The same phones connected to a different network and router receive an IP address.

Trusted Expert
Posts: 493
Registered: ‎08-23-2015
0 Kudos

Re: SRX300 - DHCP and IP phone

Hello,

 

 

I suspect IP Phones are expecting certain DHCP options from the server like Option 66 or Option 120 etc.

You can check the Manual of IP Phones you have tried so far to know such requirements.

 

Regards,

 

Rushi

New User
Posts: 3
Registered: ‎03-17-2017
0 Kudos

Re: SRX300 - DHCP and IP phone

Rushi, this isn't about options.  As I stated above, the phones don't even get an IP address.  

Highlighted
Distinguished Expert
Posts: 1,015
Registered: ‎08-29-2013
0 Kudos

Re: SRX300 - DHCP and IP phone

are you using dhcp or jdhcp? i have seen similar issues with dhcp . you can use "show system process extensive | match dhcp" to confirm the process.

if you are already using jdhcp then please enable dhcp traceoptions on srx.
can you collect "show dhcp server statistics" during problem state
Thanks,
Suraj
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too
Trusted Expert
Posts: 493
Registered: ‎08-23-2015
0 Kudos

Re: SRX300 - DHCP and IP phone

Hello,

 

Can you let me know the Vendor name of IP Phones (any one) that you have tried so far in addition to the traceoptions that rsuraj has suggested?

 

Regards,

 

Rushi

 

New User
Posts: 3
Registered: ‎03-17-2017
0 Kudos

Re: SRX300 - DHCP and IP phone

It is now working.  I tried dhcp and jdhcp and both failed.  I then upgraded to 15.1X49-D75.5 and it is now working with jdhcp.

 

Thanks for your help!