SRX Services Gateway
Showing results for 
Search instead for 
Do you mean 
Reply
Contributor
Posts: 16
Registered: ‎12-27-2013
0 Kudos

issue with OSPF neighbor relationship

I am unable to peer OSPF relationship between Cisco and Juniper SRX 4100, SRX are in cluster connected back to two Cisco switches in a stack.

 

here are my configuration:

 

SRX 4100:

set interfaces reth4 vlan-tagging
set interfaces reth4 redundant-ether-options redundancy-group 1
set interfaces reth4 unit 1229 vlan-id 1229
set interfaces reth4 unit 1229 family inet address 10.112.29.254/24
set protocols ospf area 0.0.0.0 interface reth4.1229

 

set security zones security-zone INTERNET interfaces reth4.1229
set interfaces xe-0/0/4 gigether-options redundant-parent reth4
set interfaces xe-7/0/4 gigether-options redundant-parent reth4

set security zones security-zone INTERNET host-inbound-traffic protocols ospf

 

Cisco 3850:

router ospf 100
router-id 100.100.100.100
network 10.112.29.0 0.0.0.255 area 0.0.0.0

 

all links are up but still no joy, any help please....

 

Distinguished Expert
Posts: 1,098
Registered: ‎08-29-2013
0 Kudos

Re: issue with OSPF neighbor relationship

Are you able to Ping each other?

And whats the OSPF state now?

Can you run "monitor traffic interface reth4.1229 no-resolve matching ospf" and see if we see any OSPF exchange?

Make sure there is no firewall filters/ACL on loopback blocking OSPF?
Thanks,
Suraj
Please Mark My Solution Accepted if it Helped, Kudos are Appreciated too
Distinguished Expert
Posts: 5,029
Registered: ‎03-30-2009
0 Kudos

Re: issue with OSPF neighbor relationship

The configuration looks correct.  Would you be able to add some trace options and capture the results.  these will give the specific reasons that the neighbor won't come up full.

 

https://www.juniper.net/documentation/en_US/junos/topics/topic-map/ospf-traceoptions.html

Steve Puluka BSEET
Juniper Ambassador
Senior IP Engineer - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
JNCIA-Junos JNCIS-SEC JNCIP-SEC JNCSP-SEC
JNCIS-FWV
JNCDA JNCDS-DC JNCDS-SEC
JNCIS-SP
ACE PanOS 6 ACE PanOS 7
http://puluka.com/home