SRX Services Gateway
Reply
Contributor
paulkil
Posts: 127
Registered: ‎11-05-2010
0
Accepted Solution

static route into ospf from srx240

Hi guys,

I thought this would be easy but it's not working :-(

 

All I want to do is redistribute a static route as follows into ospf:

 

set routing-options static route 0.0.0.0/0 next-hop 62.x.x.x

 

Here's my ospf config:

 


set protocols ospf area 0.0.0.0 interface reth1.0

set protocols ospf export ospf-redistribute


set policy-options policy-statement ospf-redistribute term direct from protocol direct
set policy-options policy-statement ospf-redistribute term direct then accept


set policy-options policy-statement ospf-redistribute term static from protocol static
set policy-options policy-statement ospf-redistribute term static then accept


set security zones security-zone trust host-inbound-traffic protocols ospf

 

Am I missing anything?

 

Thanks,

 

Paul

Contributor
paulkil
Posts: 127
Registered: ‎11-05-2010
0

Re: static route into ospf from srx240

Anyone.....? :smileyhappy:

Trusted Expert
Trusted Expert
jtb
Posts: 312
Registered: ‎08-26-2009
0

Re: static route into ospf from srx240

hi paulkil,

 

your config seems to fine. How do your verify it's not working ? Please check in order:

 

  • static route is present in SRX RIB (show route terse 0/0 exact)
  • external LSA present in SRX OSPF LSDB (show ospf database external lsa-id 0.0.0.0 detail)
  • LSDB on OSFP neighbor  (show ospf database)

jtb

Contributor
paulkil
Posts: 127
Registered: ‎11-05-2010
0

Re: static route into ospf from srx240

Hi JTB,

here are the outputs you requested:

 

pkil@f1-jx1> show route terse 0/0 exact

{primary:node0}
pkil@f1-jx1> show ospf database external lsa-id 0.0.0.0 detail

 

No results for both of these>

 

pkil@f1-jx1> show ospf database

 

for the one there is quite a verbose output but no mention of the 0.0.0.0/0 route.

 

Lastly:

 

pkil@f1-jx1> show route forwarding-table
Routing table: default.inet
Internet:
Destination        Type RtRef Next hop           Type Index NhRef Netif
default            perm     0                    rjct    36     2
0.0.0.0/32         perm     0                    dscd    34     1
10.0.0.0/8         user     0 a8:b1:d4:3c:b4:47  ucst   554   375 reth1.0

 

 

Does this mean anything?

 

Thanks,

 

Paul

Super Contributor
motd
Posts: 221
Registered: ‎12-16-2008
0

Re: static route into ospf from srx240

You're static route should be in the routing table but isn't. Check if that next hop 62.x.x.x is reachable.

Contributor
paulkil
Posts: 127
Registered: ‎11-05-2010
0

Re: static route into ospf from srx240

Hi there,

the hop to 62.x.x.x is not reachable, is this why it's not showing in the routing table then?

 

Thanks,

 

Paul

 

 

Trusted Expert
Trusted Expert
jtb
Posts: 312
Registered: ‎08-26-2009
0

Re: static route into ospf from srx240

hi,

 

your policy redistributes direct+static routes from RIB to OSPF. There is no 0.0.0.0/0 static route in RIB. What about 62.x.x.x, is it direct/interface route ? Without active route to 62.x.x.x, the  'static route 0.0.0.0/0' will not work.

jtb

Contributor
paulkil
Posts: 127
Registered: ‎11-05-2010
0

Re: static route into ospf from srx240

ok, I get it.

 

At the moment the next hop in the static route is down, it will be up soon when we cut over networks. This explains the lack of default route advertising.

 

Thanks for your responses, should have realise this myself.

 

Paul

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.