SSL VPN
Reply
Contributor
r_j_velazquez
Posts: 15
Registered: ‎03-31-2010
0

BUG With Juniper SSL VPN code?

I am running a SSL VPN box 6000 with System Ver. 6.4R4.1 build 14919.  I have several VLANs and having issues with the VLAN being tagged.  I took a TCP dump of one of the VLAN ports and used the RAW data in Wire Shark and looked at the data and I saw NO tagging of VLAN 512 (the vitural port VLAN #).  Is there any issues with VLAN tagging with this OS build or verison?

Contributor
r_j_velazquez
Posts: 15
Registered: ‎03-31-2010
0

Re: BUG With Juniper SSL VPN code?

Just got off the phone with Juniper TAc and he confirmed that after viewing the TCP Dump that VLAN tagging was NOT taking place.  JTAC is looking into the situation further.

 

UPdated 4:17PM EST 03/31/2010

Moderator Moderator
Moderator
ruc
Posts: 223
Registered: ‎11-06-2007
0

Re: BUG With Juniper SSL VPN code?

If you capture the tcpdump on the SSL VPN device you may not see the tagging related info (its due to the tcpdump drivers logging packets before the tagging happens). If you can capture a tcpdump on the destination device and still dont see tagging then it may be an issue. However dont go by the tcpdump captured on SSL VPN device for VLAN tagging related info.

Contributor
gamer004
Posts: 29
Registered: ‎06-11-2009
0

Re: BUG With Juniper SSL VPN code?

[ Edited ]

Hi,

 

Please note that IVE OS uses the untagged internal interface for box initiated traffic like SCP,Syslog, SNMP trap etc. We tried to have the OS changed on this item but received a clear no.  Reply was that this behaviour was too deep in sourcecode to have changed.

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.