SSL VPN
Reply
Visitor
MarcL
Posts: 8
Registered: ‎02-04-2009
0
Accepted Solution

Error Outlook Web App when opening other user's mailbox

Hi,

 

I have an active/passive SA4000 cluster running firmware 7.0R7.

I created a MS OWA 2010 SSO web profile which works perfectly.

The problem is when i try to open another user's mailbox, an error is generated:

"There was a problem opening your mailbox. You may have already signed in to Outlook Web App on a different browser tab. If so, close this tab and return to the other tab."

 

When I access my mailbox through the "direct" OWA URL (https://mail.domain.com/owa) it works as it should.

Any help would be appreciated. Thanks in advance.

 

Regards,

 

Marc,

Visitor
davido140
Posts: 6
Registered: ‎12-18-2008
0

Re: Error Outlook Web App when opening other user's mailbox

Hi,

 

Did you ever get anywhere with this issue? I'm seeing exactly the same at a couple of client locations.

 

Thanks

 

Dave

Moderator
zanyterp
Posts: 2,317
Registered: ‎11-19-2007
0

Re: Error Outlook Web App when opening other user's mailbox

That function does some special actions with the connection and I am not sure if the rewriter is able to handle it.

Please open a case with JTAC so they can look at the logs (http://www.juniper.net/techpubs/software/ive/guides/troubleshooting/RewriteTroubleshootingandLogColl... I will also check internally to see if I can find more about this and will update you.

Trusted Contributor
mattspierce
Posts: 107
Registered: ‎07-27-2010
0

Re: Error Outlook Web App when opening other user's mailbox

Was there ever any solution to this.. I've also run into this problem.

 

SA4500 and DTE.  Both running 7.2r1.1

Using the standard OWA Resource Policy and Singe Sign on with Form fill.

 

Connecting to an Exchange 2010 sp1 environement.

 

When opening another mailbox the user sees the other mailbox for a split second and then get the following error.

 

There was a problem opening your mailbox. You may have already signed in to Outlook Web App on a different browser tab. If so, close this tab and return to the other tab. If that doesn't work, you can try:

- Closing your browser window and signing in again.
- Deleting cookies from your browser and signing in again.

Visitor
MarcL
Posts: 8
Registered: ‎02-04-2009
0

Re: Error Outlook Web App when opening other user's mailbox

Hi,

 

Never found a solution for it. Still looking for 1 though.

I have lowered the priority for this issue, as there are just a few persons who need this functionality.

But it needs to be solved in time :smileywink:

 

In the mean time i will keep looking and testing for a solution. If i find one, i will post it in this topic.

 

Regards,

 

Marc.

Trusted Contributor
mattspierce
Posts: 107
Registered: ‎07-27-2010
0

Re: Error Outlook Web App when opening other user's mailbox

I was able to work around the issue by setting up a Pass Through Proxy rule to bounce the traffic up to port 1100x.  I was supprised that our single sign on continued to work.  We are running 7.2 so that my be a new feature.

Moderator Moderator
Moderator
AJA
Posts: 130
Registered: ‎05-07-2010

Re: Error Outlook Web App when opening other user's mailbox

Hello All,

 

There is a KB for this already on kb.juniper.net

 

KB ID - KB22821

 

You have a filter which needs to be installed on your IVE for this to work.

 

Note: This filter is applicable for all IVE OS versions and currently there is no ETA on a code fix or merging the same filter in an upcoming code. Additionally remove browser cache/ cookies, when testing any filter for the first time.

 

 

Please mark this post as 'accepted solution' if this answers your question that way it might help others as well, a kudo would be a bonus thanks

 

Moderator Moderator
Moderator
AJA
Posts: 130
Registered: ‎05-07-2010

Re: Error Outlook Web App when opening other user's mailbox

REMEMBER:

 

When you go to -

 

  • Go to Resource Policies > Web > Rewriting Filters.

If you are not seeing "Rewriting Filters" under "Web", please get in touch with the JTAC as you may need a rewrite filter license for the same.

 

 

 

 

 

Please mark this post as 'accepted solution' if this answers your question that way it might help others as well, a kudo would be a bonus thanks

Visitor
MarcL
Posts: 8
Registered: ‎02-04-2009
0

Re: Error Outlook Web App when opening other user's mailbox

Hello AJA,

 

Thanks for pointing me to this KB article! Works like a charm!

I didnt find it when I posted this problem on the forum. The article is posted on 3 Feb 2012 and i didnt check the KB articles again and again on this issue :smileywink:

 

Anyway: it works now, thanks to this rewrite filter.

 

Regards,

 

Marc.

 

 

Moderator Moderator
Moderator
AJA
Posts: 130
Registered: ‎05-07-2010
0

Re: Error Outlook Web App when opening other user's mailbox

Hello Marc,

 

It's my pleasure in helping you.

 

Regards,

AJA

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.