SSL VPN
Reply
Visitor
CamMcKay
Posts: 2
Registered: ‎05-15-2008
0

Network Connect App Very Slow to Load

Hi - I'm hoping someone her can help me out before I go prematurely grey.

 

Over the last two days we've had about 20 users complain that they are failing to connect to the VPN. They seem to authenticate OK but Network Connect fails to launch so despite them being visible in the console they are never assigned an IP address. As a work around we can get them to log on if they start Network Connect from the start menu (usually they access via a website) but it takes somewhere between 1 and 3 minutes for the Network Connect Sign In screen to appear   This is only effecting the users who cannot connect - for a majority of users this will launch in a few seconds.

 

We are using an SA-4000 and are still on 5.3R1 but are looking to upgrade in the near future. Does anyone have any idea why this would issue will have suddenly occured? I suspect it may have something to do with our proxy settings - we currently use an automatic configuration script pointing to a pac file but I can't work out why this is only failing for some users.

 

Thanks for any help! 

Contributor
Paul_Slager
Posts: 15
Registered: ‎01-29-2008
0

Re: Network Connect App Very Slow to Load

Hey There,

 

Its kind of hard to say without knowing your environment.  I know I always look at what changed first(perhaps you are right with the proxy).  It sounds like when they use the Web to Launch network connect you have it set to autolaunch network connect?  Check the user logs and perform a policy trace when one of the bad users logs in to see if you can find any additional information.  Are all the users signing into the same realm and page and getting the same NC connect IP range?  Try deleting cookies and cache. 

 

Good luck and feel free to post any logs you would like me to review. 

Contributor
alan
Posts: 96
Registered: ‎11-20-2007
0

Re: Network Connect App Very Slow to Load

This is a known issue with Firefox. You can downgrade Firefox to 2.0.0.9 or upgrade the IVE.

Of course, I'm assuming this is Firefox here. 

New User
vpnjunkie
Posts: 9
Registered: ‎05-13-2008
0

Re: Network Connect App Very Slow to Load

I have seen it happening when client firewall/AV/IPS is blocking NC and it works fine when user invokes it from Start button.
ADG
Visitor
ADG
Posts: 7
Registered: ‎05-01-2008
0

Re: Network Connect App Very Slow to Load

We are running on SA-2000, upgraded to IVE 6.1R2 for over a month now.

 

The Network Connect application has become extremely slow (5-6 minutes from launch to VPN tunnel establishment) when launched from the Start Menu, but very speedy (under 15 seconds) when users launch it from the "Start" button within the portal.

 

Until recently the NC application previously took 1-2 minutes to connect, which is understandable since it has to download and lauch Host Checker and Cache Cleaner.

 

The slow-down started when we changed IP addresses on the SA-2000 cluster for a network reorg; however, 5-6 minutes is not acceptable...

 

Anyone else experience something similar?

 

ADG

 

 

New User
UndoMiel
Posts: 2
Registered: ‎10-20-2008
0

Re: Network Connect App Very Slow to Load

Hello!

 

Did you manage to solve this issue? We are currently experiencing the same issue.

 

thanks for the reply.

JWM
New User
JWM
Posts: 2
Registered: ‎01-08-2009
0

Re: Network Connect App Very Slow to Load

Anyone come up with a solution for this?  I'm experiencing the same issue of it taking a very long time to launch Network Connect from the Start Menu, but it runs quickly when going through IE.  We are running 6.2R3.1 on SA4500s.
New User
mrblue
Posts: 2
Registered: ‎03-11-2009
0

Re: Network Connect App Very Slow to Load

Experienced the same problem on a few computers. Tried 6.1R7, 6.2R1 and 6.3R3. Same problem. Started uninstalling applications, then it dawned on me, disabled the built in HSDPA adapter and it worked like a charm. Load time is normal and it connects instantly.
Visitor
xyonjnet
Posts: 1
Registered: ‎03-18-2009
0

Re: Network Connect App Very Slow to Load

Did you already get some feedback about that problem? We also have this issue that it takes about 60-70 seconds to launch NC on a Lenovo Notebook with integrated Ericsson F3507g Broadband Minicard (HSPA, EDGE, GPRS). As soon as I disable the card, everything works fine again...I opened a ticket for that problem but got no solution until now.
New User
mrblue
Posts: 2
Registered: ‎03-11-2009
0

Re: Network Connect App Very Slow to Load

I must admit I didn't even bother opening a ticket. It seems to me that NC checks connection to all network adapters, which must be why I had the problem with HSDPA (without a SIM card, it just sits there). So I guess the more NICs the longer it takes to connect... but I am guessing here.
Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.