SSL VPN
Reply
Visitor
Protax
Posts: 5
Registered: ‎04-18-2012
0

SA2500 - OWA 2010 - Red crosses in newsletters

[ Edited ]

We had problems with opening external links in our OWA environment that is running via our SA2500. 

I solved this issue with the following solution:

 

http://kb.juniper.net/InfoCenter/index?page=content&id=KB17986&cat=SSL_VPN_IVE_OS&actp=LIST

 

Only now we still have problem with newsletters, the images in this newsletter are displayed as red crosses. 

 

http://imgbox.com/aaf8VkEV

 

Anybody knows how I can fix this issue?

 

Thanks in advance!

 

Best regards,

Danny

Moderator
zanyterp
Posts: 2,263
Registered: ‎11-19-2007
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

What does your policy trace show for those images? Is the location hosting the images rewritten & allowed?
Visitor
Protax
Posts: 5
Registered: ‎04-18-2012
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

[ Edited ]

Ok, I've checked the logging and I see the following (see attachment). 

Can somebody please check my log and see where it's going wrong?

 

Thanks in advance!

 

 

Visitor
Protax
Posts: 5
Registered: ‎04-18-2012
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

Anyone?

Moderator
zanyterp
Posts: 2,263
Registered: ‎11-19-2007
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

is this where the newsletter is stored: 

[WEBURL/REWRITING] evaluation for resource https://vm-3503.brg.local:443/owa/redir.aspx?C=e6f9b932a69a4752a08a41074f663078&URL=http://mailings....
info - [10.120.155.226] - BRG\danntest(Wachtwoord)[Webtoegang,XenApp BRG Webinterface,Meeting] - 2012/05/01 13:35:35 - Applying Policy [OWA ReWriting policy]...
info - [10.120.155.226] - BRG\danntest(Wachtwoord)[Webtoegang,XenApp BRG Webinterface,Meeting] - 2012/05/01 13:35:35 - Action [Do not rewrite Content (without Redirect)] is returned
info - [10.120.155.226] - BRG\danntest(Wachtwoord)[Webtoegang,XenApp BRG Webinterface,Meeting] - 2012/05/01 13:35:35 - Policy [OWA ReWriting policy] applies to resource
 
if yes, please change this to allow rewriting. Do you know why it is configured to not e rewritten?
Visitor
Protax
Posts: 5
Registered: ‎04-18-2012
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

Hello Zanyterp,

 

Thanks for your reply!

 

https://vm-3503.brg.local/owa/redir.aspx?C=e6f9b932a69a4752a08a41074f663078&URL=http://mailings.cend...

 

The first part of this URL, is the address of our Exhange 2010 Hub/Cas server, the second part is the URL of the newsletter images.

 

"Please change this to allow rewriting. Do you know why it is configured to not e rewritten?"

 

Where do I need to change this? I allready reconfigured something to let external links in emails work, see my first post.

 

Regards,

Danny

 

Trusted Contributor
SonicBoom
Posts: 195
Registered: ‎07-06-2009
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

are you allowing access to the resource

 

 https://vm-3503.brg.local:*  ?

Power On
http://vology.com
Visitor
Protax
Posts: 5
Registered: ‎04-18-2012
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

[ Edited ]

I looks like this, hopefully someone has a idea (see attachment).

Performance of OWA 2010 is also really BAD!

Moderator
zanyterp
Posts: 2,263
Registered: ‎11-19-2007
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters


Protax wrote:

Hello Zanyterp,

 

Thanks for your reply!

 

https://vm-3503.brg.local/owa/redir.aspx?C=e6f9b932a69a4752a08a41074f663078&URL=http://mailings.cend...

 

The first part of this URL, is the address of our Exhange 2010 Hub/Cas server, the second part is the URL of the newsletter images.

 

"Please change this to allow rewriting. Do you know why it is configured to not e rewritten?"

 

Where do I need to change this? I allready reconfigured something to let external links in emails work, see my first post.

 

Regards,

Danny

 


you are welcome. the screenshot you show of your configuration has this not being rewritten, which means the traffic will be used directly and if it is internal, it will not work.

 

Recognized Expert
jayLaiz
Posts: 389
Registered: ‎11-25-2009
0

Re: SA2500 - OWA 2010 - Red crosses in newsletters

Can you access the newsletters directly in LAN and point/hover the mouse over the images that display a red cross through the rewriter and check where those images are actually hosted, we can try creating a selective rewrite policy to not rewrite but redirect to target web server for those URL's if they are external URL's

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.