SSL VPN
Reply
Visitor
cacid
Posts: 4
Registered: ‎03-03-2013
0
Accepted Solution

Security Error while launching WSAM on ERROR 7.3R1

[ Edited ]

Hi Guys,

 

all the users are experiencing issue while launching WSAM. I have already gone through famous article [KB25798] about "remove browser session cookie" and this option is DISABLED. However, when I login to SSL gateway, symptoms are same.

 

  1. I can successfully login to SSL gateway
  2. But when I click on START for WSAM [Windows Secure Application Manager], the browser kicks me out from the session and displays below error message

                                        

For security reasons, your session is no longer accessible from this web browser.

 

3. I can see on my system tray that WSAM service is established so there is no issue with WSAM server

4. When I relogin to the same SSL gateway then immediately it display below error from WSAM dialog

       "Your Network seession has ended. Windows Secuire Application Manager will exit now"

 

So far only disabling "remove browser session cookie" was the solution I found from the internet. The software version is 7.3R1.

 

Can someone please help? Please see attached.

 

Regarding "sam.windows.app.23800" I know that it gives as WSAM is already running and it's expected error after relogin. But not having clue what's the root cause?

 

Thanks in advance

 

 

 

 

 

 

Moderator Moderator
Moderator
SVK
Posts: 193
Registered: ‎08-22-2011
0

Re: Security Error while launching WSAM on ERROR 7.3R1

Hi,

 

from the screenshot provided $RZ7079S.jpg after the user logs in when he is about to start WSAM there is note below which states

"note that launching windows secure application manager will terminate your browser sessionb because of the security policy specified by your administrator."

 

Could you confirm if the user is mapped to only one role are multiple roles?

Regards,

Vijay

Visitor
cacid
Posts: 4
Registered: ‎03-03-2013
0

Re: Security Error while launching WSAM on ERROR 7.3R1

Hi Vijay,

 

We have different roles for all users. In this case, users are belong to "WSAMUSERS" so they have access to applications via WSAM at client site. Same uesrs are mapped to different role for NETCONNET and when they work from HOME or OFFICE.

 

Users may belong or mapped to different roles and that's quite normal right? Is there any specific suggestion with this?

 

Thanks

Recognized Expert
jayLaiz
Posts: 416
Registered: ‎11-25-2009
0

Re: Security Error while launching WSAM on ERROR 7.3R1

Hi,

 

Since the user is mapped to multiple roles, disable this option from all the user roles that this users gets and you will not get this error.

 

Thanks,

Jay

Moderator Moderator
Moderator
SVK
Posts: 193
Registered: ‎08-22-2011
0

Re: Security Error while launching WSAM on ERROR 7.3R1

Hi,

 

user can be mapped to multiple roles no issue, I was trying to find out if the settings was getting merged from other roles.

 

Seems the settings are getting merged from a differnt role.

 

Please check with the other roles for the settings Remove Browser Session Cookie

 

Regards,

Vijay

Visitor
cacid
Posts: 4
Registered: ‎03-03-2013
0

Re: Security Error while launching WSAM on ERROR 7.3R1

[ Edited ]

@Jay

I am not sure which option you are talking about. Could you pleaes explain with snapshot? I am using SA-VPE 4500 7.3R1

 

 

@Vijay

There are only three groups - 1.internal users 2.netconnect users 3.wsam users and they are all ENABLED for "

 

for, Remove Browser Session Cookie options

1.internal users = DISABLED

2.netconnect users = ENABLED

3.wsam users = DISABLED

 

Interestingly, when users tries to connect using netconnect, there are no issue. the option for wsam users was enabled and i disabled in hoping that it might fix issue for wsam users. but it's not. i reckoned even if I disable option for netconnect users, it might not make any difference. so, it seems that something is wrong on ssl gateway which is only affecting wsam users

 

more inputs please?:smileyhappy:

 

Visitor
cacid
Posts: 4
Registered: ‎03-03-2013
0

Re: Security Error while launching WSAM on ERROR 7.3R1

RESOLVED: the option has to disable for all the user roles. that is, if there are four user roles belong to SAM [secure application manager], the "Remove Browser Session Cookie" option has to be DISABLE on all four of them. Go to SESSION -> EDIT.

 

Jay, I think you have suggested same solution.

 

Thanks Vijay.

Recognized Expert
jayLaiz
Posts: 416
Registered: ‎11-25-2009
0

Re: Security Error while launching WSAM on ERROR 7.3R1

Hi,

 

Glad to know that it worked.

 

Regards,

Jay

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.