SSL VPN
Reply
Contributor
tmull60
Posts: 53
Registered: ‎11-17-2010
0
Accepted Solution

Web Resource

I have a web resource configured on my SA6500 series, which works very well. Users log into the site and are directed to the main web page without a problem.The site name is address.mydomain.com.

 

The initial login is using AD authentication. The web page is using a different login for security purposes so we cannot use SSO.

 

The issue I am having is that in order for users to log into the web page, they must first click a link that is sent via email. The link then directs them to the Juniper login screen, but they get a page not found error after logging in using their AD account.

 

The web link that is sent to the users is address.mydomain.com/portal which is different than the default home page that is used after the account is setup.

 

I prefer not to use JSAM, WSAM or NC for this setup. Has anyone else seen this and have a possible fix?

Recognized Expert
Kita
Posts: 489
Registered: ‎12-23-2010
0

Re: Web Resource

Is the email only simply redirecting users to the SA login page or is the email trying to point end users to the login page behind the SA device?  I am assuming it is the login page behind the SA and the reason why when the click on it, they are getting a page cannot be displayed.  If this is the case, is this portal only accessed through the SA and would it be possible to change the web link in the email?

Contributor
tmull60
Posts: 53
Registered: ‎11-17-2010
0

Re: Web Resource

It is a link that sits behind the SA and when they click it brings them to the login page for the SA. Users can log in, but then get page cannot be displayed.It is only accessible through the SA and is not an external facing web server.

 

Sometmes I am just brought to the page that users would normally be directed to, which is how it is designed.

 

We cannot change the account setup login page as far as I know, but I can check on that.

Recognized Expert
Kita
Posts: 489
Registered: ‎12-23-2010
0

Re: Web Resource

I have two questions:

 

What is the url in the email?

What is the url when the end user receives the 'page cannot be displayed' message?

Moderator
zanyterp
Posts: 2,317
Registered: ‎11-19-2007
0

Re: Web Resource

With the resource being only behind the SA, is it correct that the email is in the form of https://<your-ive>/path,DanaInfo,<internal-server>? If yes, this should work if, and only if, you have browser request follow through on the role. This allows expired, or in this case not-yet-authenticated, links behind the SA to be accessed. Without these being true, it will fail and you will see what you are seeing.
Contributor
tmull60
Posts: 53
Registered: ‎11-17-2010
0

Re: Web Resource

If I modify the link that is sent to my users it does work. So, I am going to see if their application will do that and get it off my plate.

 

Thanks

Moderator
zanyterp
Posts: 2,317
Registered: ‎11-19-2007
0

Re: Web Resource

Glad to hear this may work for you.

Good luck!

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.