ScreenOS Firewalls (NOT SRX)
Reply
Visitor
Sapperchi
Posts: 6
Registered: ‎09-02-2008
0

SSG firewall and ALG not working with SQL ports TCP-1521

Hello,

I've gone through this with the Juniper TAC. I'm having problems with my SSG-520M and SSG-550M running OS 6.2.0r4. I upgraded from 6.1.0.r3. I have a client and server using SQLv2 tcp port 1521. ALG seems to not be working. We reverted to 6.1.0r3 and everything is back to normal. After countless days researching and getting the TAC to come up with an answer they gave me KB article 491466 and confirmed there is an issue with ALG and SQLv2.

 

When I try to find the article it doesn't exist for public viewing and TACs response only solution: "there is a known issue with the 6.2 firmware. It is documented. it would be resolved in version 6.2.0r6 or upgrade to OS 6.3 version or stay on the older version 6.1.0r3". The PR is confidential right now so they couldn't provide me with any details. Why wouldn't this issue be disclosed publicly or in release notes? I don't understand their resistance to publishing the KB unless it also highlights security vulnerability but even so wouldn't they want their customers know they're at risk?

 

Anybody gone through this type of issue before?

Contributor
Rontu
Posts: 17
Registered: ‎12-15-2009
0

Re: SSG firewall and ALG not working with SQL ports TCP-1521

You got to take this issue with the Manager in the Juniper-TAC to really get an ETA on the publishing of the KB

 

rest assured Juniper will publish a brief description of the bug , however pls note not all bugs cant be disclosed for security reasons.

as when a bug is reported they will fix it and release a new ScreenOS revision.

Cheers,
Rog
New User
cfyeung
Posts: 3
Registered: ‎12-29-2009
0

Re: SSG firewall and ALG not working with SQL ports TCP-1521

Just hit the same bug and downgraded to 5.1.0r7 ............................

Copyright© 1999-2013 Juniper Networks, Inc. All rights reserved.