vMX

last person joined: 4 days ago 

Ask questions and share experiences about vMX.
  • 1.  Unable to use Dynamic Profile on vMX Evaluation License

    Posted 08-28-2016 16:14

    We are looking at using the vMX as a BRAS to terminate PPPoE sessions via the Dynamic Profile, I have beenfollowing the steps outlines in the juniper guide guide, but it's unable to create a dynamic profile due to a "ADD from daemon pppoed because enhanced-universal-edge is disabled" error.

    Configuration
    dynamic-profiles {
        basic-pppoe-profile {
            interfaces {
                pp0 {
                    unit "$junos-interface-unit" {
                        ppp-options {
                            chap;
                            pap;
                            authentication [ pap chap ];
                        }
                        pppoe-options {
                            underlying-interface "$junos-underlying-interface";
                            server;
                        }
                        keepalives interval 15;
                        family inet {
                            unnumbered-address lo0.0;
                        }
                    }
                }
            }
        }
    }
    
    interfaces ge-0/0/0
        vlan-tagging;
            unit 3500 {
                encapsulation ppp-over-ether;
                vlan-id 3500;
                pppoe-underlying-options {
                    access-concentrator server-vMX-1;
                    dynamic-profile basic-pppoe-profile;
                }
            }
        }
    }

    Checking the pppoe debuging

    Aug 29 08:18:53.603147 Discovery Input: PADR packet UIFL:ge-0/0/0.3500 (337)
    Aug 29 08:18:53.603230 addDuplicateProtectionClient:
    mac=00:17:A4:E7:A6:7A useCount=1
    Aug 29 08:18:53.603260 createSdbEntry: Pre-booked SDB ID is zero failed,
    iflName=
    Aug 29 08:18:53.603288 sdb_create_extended_client_session: 10581: subs
    count:0 on ifl:��
    Aug 29 08:18:53.603305 liblic_get_license_data: total active licensed
    subs = 0 inflight subs:0
    Aug 29 08:18:53.603319 liblic_subs_limit_valid 685 total subs:0
    state:0x0 limit valid
     
    Aug 29 08:18:53.603479 if ge-0/0/0.3500 add, mem 0xcb463194 sid:8
    Aug 29 08:18:53.603508 if ge-0/0/0.3500 add sub cnt 0 uifl cnt 1
    licensed count 0
    Aug 29 08:18:53.603532 if ge-0/0/0.3500 session id 8 add, mem 0xcb4631f4
    Aug 29 08:18:53.603568 state:0 to index:2
    Aug 29 08:18:53.603582 sdb_summary_counter_increment: sdb counter for
    index:2 changed to:1
    Aug 29 08:18:53.603594 sdb_summary_counter_increment: sdb counter for
    index:9 changed to:1
    Aug 29 08:18:53.603606 sdb_create_extended_client_session 11252:
    incremented counter for state:0 for sid:8
    Aug 29 08:18:53.603618 client type:0 to index:17
    Aug 29 08:18:53.603630 sdb_summary_counter_increment: sdb counter for
    index:17 changed to:1
    Aug 29 08:18:53.603642 sdb_summary_counter_increment: sdb counter for
    index:29 changed to:1
    Aug 29 08:18:53.603653 sdb_summary_counter_increment: sdb counter for
    index:0 changed to:1
    Aug 29 08:18:53.603665 sdb_create_extended_client_session 11276:
    incremented total counter for sid:8
    Aug 29 08:18:53.603677 sdb_summary_counter_increment: sdb counter for
    index:1 changed to:1
    Aug 29 08:18:53.603689 sdb_create_extended_client_session 11291:
    incremented counter for legacy for session id 8
    Aug 29 08:18:53.603713 Created SDB entry iflName= iflIndex=0 sdbId=8
    Aug 29 08:18:53.603730 Add filter entry Success for sdbId=8
    Aug 29 08:18:53.603755 eraStartEvent: eraStartEvents=8
    Aug 29 08:18:53.603771 sendDynamicProfileRequest: Dynamic Profile Add
    request for sdbId=8 profile=basic-pppoe-profile
    Aug 29 08:18:53.603790 config_bits=0x1 0 0 0 0 0
    Aug 29 08:18:53.603904 sendDynamicProfileRequest: Dynamic Profile Add
    request FAILED for sdbId=8 result=107, err=Operation not permitted
    Aug 29 08:18:53.603925 terminateSession: iflName= Terminate Reason=6
    Aug 29 08:18:53.603947 eraStopEvent: eraStopEvents=8
    Aug 29 08:18:53.604209 if ge-0/0/0.3500 session id 8 del
    Aug 29 08:18:53.604227 if ge-0/0/0.3500 del sub cnt 0 uifl cnt 0
    licensed count 0
    Aug 29 08:18:53.604239 if ge-0/0/0.3500 del empty
    Aug 29 08:18:53.604257 state:0 to index:2
    Aug 29 08:18:53.604270 sdb_summary_counter_decrement: sdb counter for
    index:2 changed from:1
    Aug 29 08:18:53.604282 sdb_summary_counter_decrement: sdb counter for
    index:9 changed from:1
    Aug 29 08:18:53.604695 sdb_remove_bundled_client_session: decremented
    counter for client sid:8 for state:0
    Aug 29 08:18:53.604708 client type:0 to index:17
    Aug 29 08:18:53.604719 sdb_summary_counter_decrement: sdb counter for
    index:17 changed from:1
    Aug 29 08:18:53.604731 sdb_summary_counter_decrement: sdb counter for
    index:29 changed from:1
    Aug 29 08:18:53.604743 sdb_summary_counter_decrement: sdb counter for
    index:0 changed from:1
    Aug 29 08:18:53.604755 sdb_remove_bundled_client_session: decremented
    total summary counter for sid:8
    Aug 29 08:18:53.604766 sdb_summary_counter_decrement: sdb counter for
    index:1 changed from:1
    Aug 29 08:18:53.604778 sdb_remove_bundled_client_session: decremented
    legacy summ count for client:8
    Aug 29 08:18:53.604811 removeSdbId: Removed SDB entry sdbId=8
    Aug 29 08:18:53.604835 removeDuplicateProtectionClient:
    mac=00:17:A4:E7:A6:7A useCount=1
    Aug 29 08:18:53.604873 removePrivateSdbPppoeMaxSessions: ge-0/0/0.3500
    removed
    Aug 29 08:18:53.604890 Session Terminated for
    Aug 29 08:18:53.604906 Sending PADS packet: sessionId=0 err=514
    Aug 29 08:18:53.604922 building PADS packet: sessionId=0 err=514

    Which seem to show that the configuration is working but the Dynamic
    Profile is not being added due to the error Operation not permitted.
    Checking the messages log I see the following

    Aug 29 08:18:38  vMX-1.ak pppoed: dyn_prof_send_request: Rejecting
    profile (basic-pppoe-profile - use_flow: 0) ADD from daemon pppoed
    because enhanced-universal-edge is disabled
    Aug 29 08:18:43  vMX-1.ak pppoed: dyn_prof_send_request: Rejecting
    profile (basic-pppoe-profile - use_flow: 0) ADD from daemon pppoed
    because enhanced-universal-edge is disabled
    

     

    Is this a result of the evaluation license not covering this? Or something else not set correctly?

     

    Cheers
    --Mark



  • 2.  RE: Unable to use Dynamic Profile on vMX Evaluation License
    Best Answer

    Posted 08-30-2016 02:15

    Hi Mark,

     

    You will need to enable the subscriber management features, this is done as below:

     

    https://www.juniper.net/documentation/en_US/junos15.1/topics/task/configuration/subscriber-management-enhanced-initial-setup.html

     

     



  • 3.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 09-01-2016 18:59

    Hi Matt 

     

    That was the part I was overlooking, 

     

    Thanks

    --Mark



  • 4.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 10-31-2016 08:16

    Hi Matt,

    Thank you for your useful information.

    I'm using vMX 14.1.R4.8 for BNG simulation. PPPoE client fails to receive ip address from BNG because of missing license.

    Is there anyway to solve this? Thank you very much.

     

    This is my configuration on vMX

     

    dynamic-profiles {
    PPPOE-PROFILE {
    interfaces {
    pp0 {
    unit "$junos-interface-unit" {
    pppoe-options {
    underlying-interface "$junos-underlying-interface";
    server;
    }
    family inet {
    unnumbered-address lo0.0;
    }
    }
    }
    }
    }
    }

    system {
    host-name R1;
    root-authentication {
    encrypted-password "$1$obuSnVsI$us/yGHzi.ijgfRnh9y5vK0"; ## SECRET-DATA
    }
    services {
    subscriber-management {
    enforce-strict-scale-limit-license;
    }
    }
    syslog {
    user * {
    any emergency;
    }
    file messages {
    any notice;
    authorization info;
    }
    file interactive-commands {
    interactive-commands any;
    }
    }
    }
    chassis {
    network-services enhanced-ip;
    }
    interfaces {
    ge-0/0/0 {
    flexible-vlan-tagging;
    unit 800 {
    encapsulation ppp-over-ether;
    vlan-id 800;
    pppoe-underlying-options {
    access-concentrator ABC;
    dynamic-profile PPPOE-PROFILE;
    }
    }
    unit 900 {
    encapsulation ppp-over-ether;
    vlan-id 900;
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 200.0.0.1/32;
    }
    }
    }
    }
    access {
    address-assignment {
    ##
    ## Warning: requires 'subscriber-address-assignment' license
    ##
    pool VLAN800 {
    family inet {
    network 118.1.1.0/24;
    range 1 {
    low 118.1.1.10;
    high 118.1.1.20;
    }
    dhcp-attributes {
    name-server {
    8.8.8.8;
    }
    }
    }
    }
    }
    }

     

     



  • 5.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 10-31-2016 08:27

    Get a trail license at https://www.juniper.net/us/en/dm/free-vmx-trial/.

     

    The vMX trial license will allow all BNG features at  unlimited scale for 60 days. After that your scale will be capped at 10 subscribers.



  • 6.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 10-31-2016 10:26

    Hi,

     

    Is there any reason you are using 14.1.R4.8? My recommendation would be to use vMX release 15.1F6 for your BNG simulation.

     

     



  • 7.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 11-04-2016 08:11

    Hi, i'm running VMX version 14.1R4.8 in UNL-Unified Net Lab, it's very easy to drag and drop router for doing lab. I'm searching how to convert an ESXi VMX 15.1F6 to use with UNL.

    I have a ESXi image of 15.1F5, but i got a problem when booting vFPC. It shows up an error about not enough disk space....

    I'm not familiar with Vmware EXSi, so please help me.

    Thank you so much.

     



  • 8.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 11-04-2016 08:33

    I aasume that you are using VMDK? You may get vMX 15.1F6 OVA files to overcome this issue.

    https://www.juniper.net/support/downloads/?p=vmx#sw

    or direct URL to vMX ESXi package:

    https://webdownload.juniper.net/swdl/dl/secure/site/1/record/62831.html

     

    Or evan better, you can use qcow2 file in KVM package so you don't have to convert format by using qemu-img.

    https://webdownload.juniper.net/swdl/dl/secure/site/1/record/62819.html

     



  • 9.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 11-05-2016 06:13

    Thanks a lot Szhong,

    Could you please upload to mediafire or mega, my account do not have enough privilege to download qcow2 file

    Appreciate your help.

     



  • 10.  RE: Unable to use Dynamic Profile on vMX Evaluation License

    Posted 11-05-2016 06:35

    Dear Szhong,

    I have a KVM version of 15.1F5, i extracted the tar file and got alot of file, including "jinstall64-vmx-15.1F5-S1.5-domestic.img", "vFPC-20160503.img", and many file with "metadata-usb" prefix.

    I tried to upload "jinstall64-vmx-15.1F5-S1.5-domestic.img" to use with UNL, but it did not work.

    Please help me mate.