Configuration Library
Highlighted
Configuration Library

IRB Configuration for both Trio (MX80) and non-Trio (MX240) Chipsets

[ Edited ]
‎11-04-2010 09:26 PM

Title:  IRB Configuration for both Trio (MX80) and non-Trio (MX240) Chipsets

 

Product: MX240 & MX80

Version: 9+

 

Description:

 

These configurations produce identical behavior. For some reason, the MX80 (on the Trio chipset) is unable to do bridging the way that the newer MX's can do it. They have to be configured as the old MX's were, in the ~9.2 days.

The problem is if you have 200 VLANs tagged (trunked in Cisco-land) on the interface. That equates to a HUGE configuration!

JTAC tells me the "new-style" configuration should be available in JUNOS 11.1

 

"New-Style" IRB Configuration (used on newer models of non-Trio MX routers, eg. MX240)


interfaces {
    interface-range EXAMPLE_RANGE {
        member-range xe-0/0/0 to xe-0/0/2;
        unit 0 {
            family bridge {
                interface-mode trunk;
                vlan-id-list [ 10 20 ];
            }
        }
    }
    irb {
        unit 10 {
            family inet {
                address 10.10.0.1/24 {
                }
            }
        }
        unit 20 {
            family inet {
                address 10.20.0.1/24 {
                }
            }
        }
    }
}
bridge-domains {
    vlan-10 {
        domain-type bridge;
        vlan-id 10;
        routing-interface irb.10;
    }
    vlan-20 {
        domain-type bridge;
        vlan-id 20;
        routing-interface irb.20;
    }
}

"Old-Style" IRB Configuration (used on MX80s and early models of other MX routers):


interfaces {
    xe-0/0/0 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        unit 10 {
            encapsulation vlan-bridge;
            vlan-id 10;
        }
        unit 20 {
            encapsulation vlan-bridge;
            vlan-id 20;
        }
    }
    xe-0/0/1 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        unit 10 {
            encapsulation vlan-bridge;
            vlan-id 10;
        }
        unit 20 {
            encapsulation vlan-bridge;
            vlan-id 20;
        }
    }
    xe-0/0/2 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        unit 10 {
            encapsulation vlan-bridge;
            vlan-id 10;
        }
        unit 20 {
            encapsulation vlan-bridge;
            vlan-id 20;
        }
    }
    irb {
        unit 10 {
            family inet {
                address 10.10.0.2/24;
            }
        }
        unit 20 {
            family inet {
                address 10.20.0.2/24;
            }
        }
    }
}
bridge-domains {
    vlan-10 {
        vlan-id 10;
        interface xe-0/0/0.10;
        routing-interface irb.10;
    }
    vlan-20 {
        vlan-id 20;
        interface xe-0/0/0.20;
        routing-interface irb.20;
    }
}

 

--
Chris Jones
JNCIE-ENT #272
Former JNCIP-SP
Former CCIE #25655
Former Juniper Ambassador