Configuration Library
Configuration Library

Multiple S-VLANs port-based selective QinQ on EX8200

[ Edited ]
‎02-13-2014 12:18 AM

Title: Configuration Example - Multiple S-VLANs selective QinQ

How to make port-based selective QinQ configuration with the partial c-vlans trunk.

 

Product:  EX8200

Version:  12.3R5.7

 

Network Topology:    EX8200 switch as aggregator for multi-vendor access layer switches. JPG file attached.

 

Description:

- Purpose:

1) C-VLANs 100-199 from access switch need to be tagged by S-VLAN 2000;

2) C-VLANs 200-299 from access switch need to be tagged by S-VLAN 3000;

3) C-VLANs 51, 52, 53 and 54 need to be trunked transparently;

 

- Description of the configuration:

The configuration shows how to configure multiple S-VLANs port-based selective QinQ for partial C-VLANs range. And how to trunk several C-VLANs transparently (for management and other L3 services);

 

Configuration:

EX8208

 

ethernet-switching-options {
    dot1q-tunneling {
        ether-type 0x8100;
    }
}

 

interfaces {
    ge-2/0/38 {
        mtu 9216;
        unit 0 {
            family ethernet-switching;
        }
    }
    ge-2/0/39 {
        mtu 9216;
        unit 0 {
            family ethernet-switching;
        }
    }
    ge-2/0/42 {
        mtu 9216;
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ PPPoE-QinQ VPN-QinQ ];
                }
            }
        }
    }

    vlan {
        unit 51 {
            description ETTH-MANAGEMENT;             family inet {
                address 172.16.4.1/26;
            }
        }
        unit 52 {
            description STB-UNICAST;             family inet {
                address 1.2.3.1/30;
            }
        }
        unit 53 {
            description MULTICAST-DOWNSTREAM;             family inet {
                address 10.43.127.1/24;
            }
        }
        unit 54 {
            description VoIP-CUSTOMERS;
            family inet {
                address 10.3.51.1/24;
            }
        }
    }
}

 

vlans {
    PPPoE-QinQ {
        description PPPoE
        vlan-id 2000;
        interface {
            ge-2/0/39.0;
            ge-2/0/38.0;
        }
        dot1q-tunneling {
            customer-vlans 100-199;
        }
    }
    VPN-QinQ {
        description VPN
        vlan-id 3000;
        interface {
            ge-2/0/39.0;
            ge-2/0/38.0;
        }
        dot1q-tunneling {
            customer-vlans 200-299;
        }
    }
    ETTH-MGMT {
        description ETTH-MANAGEMENT;
        vlan-id 51;
        interface {
            ge-2/0/39.0 {
                mapping {
                    51 {
                        swap;
                    }
                }
            }
            ge-2/0/38.0 {
                mapping {
                    51 {
                        swap;
                    }
                }
            }
        }
        l3-interface vlan.51;
    }
    IPTV {
        description STB-UNICAST;
        vlan-id 52;
        interface {
            ge-2/0/39.0 {
                mapping {
                    52 {
                        swap;
                    }
                }
            }
            ge-2/0/38.0 {
                mapping {
                    52 {
                        swap;
                    }
                }
            }
        }
        l3-interface vlan.52;
    }
    MCAST {
        description MULTICAST-DOWNSTREAM;
        vlan-id 53;
        interface {
            ge-2/0/39.0 {
                mapping {
                    53 {
                        swap;
                    }
                }
            }
            ge-2/0/38.0 {
                mapping {
                    53 {
                        swap;
                    }
                }
            }
        }
        l3-interface vlan.53;
    }
    SIP-KMR {
        description VoIP-CUSTOMERS;
        vlan-id 54;
        interface {
            ge-2/0/39.0 {
                mapping {
                    54 {
                        swap;
                    }
                }
            }
            ge-2/0/38.0 {
                mapping {
                    54 {
                        swap;
                    }
                }
            }
        }
        l3-interface vlan.54;
    }
}

 

Attachments