DX - Load Balancing & Application Acceleration
DX - Load Balancing & Application Acceleration

Disable ether1

‎10-14-2008 12:23 PM
Once upon a time, we were trying to get our DX3250 on different networks.  The experiment didn't work and now I need to remove the ether 1 interface IP address as it's causing some routing problems.  I can't seem to find the commands anywhere and setting a blank IP causes an error.  Does anyone know how I can set the ether 1 interface to "inactive" or set it to a blank IP address?
3 REPLIES 3
DX - Load Balancing & Application Acceleration

Re: Disable ether1

‎10-15-2008 06:23 AM

 

You cannot disable an interface, apart from leaving it unplugged.

 

 

You can use the 'set ether' commands to configure the port to use an unused IP with a /30 mask.   You could also look at setting the media type to an incorrect one so the link does not negotiate.  The command reference manual has the following:

 

set ether Commands....................................................................................213

set ether ip ............................................................................................213

set ether <n> media............................................................................214

set ether mtu.........................................................................................214

set ether netmask..................................................................................214

 

 

For example, I have:

 

ether1: IP address = 172.26.31.206  netmask = 255.255.255.0
ether1: Broadcast = 172.26.31.255
ether1: MAC = 00:30:48:69:42:c1 VMAC = 00:00:5e:00:01:02 MTU = 1500
ether1: media = 100baseTX full-duplex (100baseTX full-duplex) Status: active

 

I then alter the type to 1 (10baseT/UTP):

 

vauxhall% set ether 1 media 1
(*) vauxhall% sh ether 1
ether1: IP address = 172.26.31.206  netmask = 255.255.255.0
ether1: Broadcast = 172.26.31.255
ether1: MAC = 00:30:48:69:42:c1 VMAC = 00:00:5e:00:01:02 MTU = 1500
ether1: media = 10baseT/UTP Status: changed

 

I do a 'write' to commit the change:

 

(*) vauxhall% wr

 

 

I then lose my SSH connection as I was connected to that interface.  Via console I can now see:

 

vauxhall% sh ether 1
ether1: IP address = 172.26.31.206  netmask = 255.255.255.0
ether1: Broadcast = 172.26.31.255
ether1: MAC = 00:30:48:69:42:c1 VMAC = (unconfigured) MTU = 1500
ether1: media = 10baseT/UTP (autoselect half-duplex) Status: no carrier
ether1: supported media options:

 So I change it back so I can SSH back in to that IP:

 

vauxhall% set ether 1 media 4
(*) vauxhall% wr
Writing configuration. This may take a moment. If you've made
changes to the media settings and the device appears to hang, you
may need to reconfigure your hub or switch manually to match
the settings you've chosen here.
Done.

 

 

 If you look at changing the IP and/or mask the commands are:


vauxhall% sh ether 0
ether0: IP address = 10.10.4.1  netmask = 255.255.255.0
ether0: Broadcast = 10.10.4.255

vauxhall% set ether 0 ip 10.10.5.1

(*) vauxhall% wr

Writing configuration.
Done.
vauxhall% sh ether
ether0: IP address = 10.10.5.1  netmask = 255.255.255.0
ether0: Broadcast = 10.10.5.255

 

 

(The smallest available mask is /30, if you try to set /31 or /32 then there is an error message)

 

vauxhall% set ether 0 netmask 255.255.255.254
Error: Netmask cannot be 255.255.255.254

vauxhall% set ether 0 netmask 255.255.255.252
(*) vauxhall% wr
Writing configuration.
Done.
vauxhall%show ether 0
ether0: IP address = 10.10.5.1  netmask = 255.255.255.252
ether0: Broadcast = 10.10.5.3

 


 

 

 

DX - Load Balancing & Application Acceleration

Re: Disable ether1

‎10-15-2008 07:35 AM
Thanks, but this doesn't quite work.  The interface is still configured, it just doesn't work.  I guess I technically need to modify the routing table to stop traffic from going to this interface.  "show netstat -rn" shows traffic for a particular subnet going to "ether 1" which doesn't work.  I need it to go out "ether 0" and use the networks routers instead.  Can I modify the routing table somehow?
DX - Load Balancing & Application Acceleration

Re: Disable ether1

‎10-15-2008 07:41 AM
Whoop, answered my own question. Smiley Happy  If the interface isn't working, but configured on a subnet you need to get to, just change what subnet it's on.  I just set ether 1 to a private network that we don't use, sending my packets out the default route instead.  Would rather have "unset" the interface, but this works.
Announcements

DX SERIES

The Juniper Networks DX application acceleration platform delivers a complete data center acceleration solution for Web-enabled and IP-based business applications.

RSS Icon