Ethernet Switching
Highlighted
Ethernet Switching

ACX5048 Analyzer down

‎03-28-2017 07:23 AM

Hi,

I'm trying to get analyzer working on ACX5048.

I have firmware 15.1X54-D60.9

I am trying to sniff packets in my lab to try and figure out whats going wrong with the setup, but the analyzer is permanently down. None of the documentation tells you how to configure the output port, so I'm a bit stuck.

 

Here is the analyzer config and output interface config.

root@acx5048-pe-lab# show forwarding-options
analyzer {
       pi {
          input {
               ingress {
                    interface ge-0/0/4.101;
               }
               egress {
                     interface ge-0/0/4.101;
              }
     }
     output {
          interface ge-0/0/8.0;
     }
   }
}

{master:0}[edit]
root@acx5048-pe-lab# show interfaces ge-0/0/8
mtu 9192;
unit 0;

 

Analyzer info:

root@acx5048-pe-lab# run show forwarding-options analyzer
     Analyzer name : pi
     Mirror rate : 1
     Maximum packet length : 0
     State : down
     Ingress monitored interfaces : ge-0/0/4.101
     Egress monitored interfaces : ge-0/0/4.101

 

Normally in an EX switch you would set the output interface with family ethernet-switching, however, if I try that I cannot commit it.

 

root@acx5048-pe-lab# show interfaces ge-0/0/8
mtu 9192;
unit 0 {
family ethernet-switching;
}

{master:0}[edit]
root@acx5048-pe-lab# commit check
[edit interfaces ge-0/0/8 unit 0 family]
'ethernet-switching'
family vpls not valid on this interface.
error: configuration check-out failed

 

2 REPLIES 2
Highlighted
Ethernet Switching

Re: ACX5048 Analyzer down

‎03-28-2017 11:12 AM

Hello,

 

Did you check this documentation?

 

https://www.juniper.net/documentation/en_US/junos/topics/example/port-mirroring-local-qfx-series-els...

 

Regards,

 

Rushi

Highlighted
Ethernet Switching

Re: ACX5048 Analyzer down

‎03-29-2017 12:32 AM

I had read that yes - thankyou.

unfortunately it shows the target interface configured with ethernet-switching, which doesn't seem to be acceptable to the acx5k.

I found the solution this morning by configuring a vlan and including the interface in the vlan as follows:

 

root@acx5048-pe-lab# show interfaces ge-0/0/8
     description cust2;
     mtu 9192;
     encapsulation ethernet-bridge;
     unit 0;


root@acx5048-pe-lab# show vlans
test {
     vlan-id 100;
     interface ge-0/0/8.0;
}

 

root@acx5048-pe-lab# run show forwarding-options analyzer
Analyzer name : pi
Mirror rate : 1
Maximum packet length : 0
State : up
Ingress monitored interfaces : ge-0/0/4.101
Egress monitored interfaces : ge-0/0/4.101
Output interface : ge-0/0/8.0

 

 

Feedback