Ethernet Switching
Highlighted
Ethernet Switching

Aastra IP Phone and EX3300 switch

‎03-05-2013 07:46 AM

I'm new here, so loud HI to everyone!

 

I have one EX3300 in my infrastructure. There are few problems with cooperation between switch and IP phones (AASTRA 6755i). IP phones have PC ports and pc's attached to them. Problem is, that pc's can't ping LAN vlan's l3-interface on EX3300.

They can ping other hosts in this vlan but l3-interface is "invisible"

 

Configuration is as below:

 

root@SW_3300# show interfaces ge-0/0/3
description DAREK;
ether-options {
    speed {
        100m;
    }
}
unit 0 {
    description DAREK;
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members [ TEL LAN ];
        }
        native-vlan-id LAN;
    }
}

root@SW_3300# show vlans
LAN {
    vlan-id 16;
    interface {
        ge-0/0/3.0;
    }
    l3-interface vlan.16;


TEL {
    vlan-id 7;
    interface {
        ge-0/0/3.0;
    }
    l3-interface vlan.7;


root@SW_3300# show interfaces vlan.16
family inet {
    address 10.10.0.251/24;
}

root@SW_J307_3300# show interfaces vlan.7
family inet {
    address 10.40.0.1/24;
}


root@SW_J307_3300# show protocols

ospf {
    export all-local;
    area 0.0.0.0 {
        interface vlan.18;
        interface ge-0/0/10.0 {
            metric 50;
        }
    }
}
igmp-snooping {
    vlan all;
}
rstp {
    bridge-priority 16k;
}
lldp {
    interface all;
}
lldp-med {
    interface all;
}


On IP phones configuration is:

 

VoIP vlan id - 7

PC port vlan id - 16

 

IMPORTANT. Other pc's connected directly to EX3300 can ping l3-interface without any problems.

 

It's very strange, that while restarting the IP phone, for short time pings are going normaly. But when IP phone is fully operative, ping on pc (windows xp and 7) shows "Host is unreachable".

 

Any ideas what is wrong?

Tnaks in advance

GregPL

1 REPLY 1
Ethernet Switching

Re: Aastra IP Phone and EX3300 switch

‎03-20-2013 04:40 AM

Hi Greg,

 

Does the issue still persist? If yes.

 

1--Are you running DHCP in your network i;e does you phone and PC getts ip-address from DHCP server.
 If yes..did you check if you phone and pc getting the right ip-address from the right pool.

 

2--I see that you have configured the port as trunk, have you tried configuring the port as access and tested the result. (Access for data + voice vlan for voice)

 

3--Is there any manual Vlan configuration in the Ip-Phone.

 

4--What is the Junos version you are using.

 

5--Can you please check if there is arp entry for the PC in the switch when it is not pinging from behind the phone.

 

6--Clear the PC's arp entry from the switch reboot the phone and capture this log while initiating a ping from the PC.

 

monitor traffic interface ge-0/0/3 (affected port) <------------  Show real-time network traffic information

 

7--Can you please capture these logs as well.

 

show vlans extensive

run show ethernet-switching table | grep ge-0/0/3

 

 

Feedback